aboutsummaryrefslogtreecommitdiff
path: root/x11/libXext/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 01:02:26 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 01:02:26 +0000
commit2900ef85cf34cecf6cd0bc8e29dbd2e2a98f846a (patch)
tree6b249c299c3f6fe1486b31e139eb05111d961f20 /x11/libXext/Makefile
parent504af8c2aa052e68309117a89d8c162b3c606a0f (diff)
downloadports-2900ef85cf34cecf6cd0bc8e29dbd2e2a98f846a.tar.gz
ports-2900ef85cf34cecf6cd0bc8e29dbd2e2a98f846a.zip
Notes
Diffstat (limited to 'x11/libXext/Makefile')
-rw-r--r--x11/libXext/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/libXext/Makefile b/x11/libXext/Makefile
new file mode 100644
index 000000000000..0e4f1745dceb
--- /dev/null
+++ b/x11/libXext/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXext
+PORTVERSION= 6.4.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X11 Extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-6.4.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>