aboutsummaryrefslogtreecommitdiff
path: root/x11/libXrender/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-12-22 02:04:46 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-12-22 02:04:46 +0000
commit102cbb3b7f52931fe94f2ca266ad5157d0fc0b4d (patch)
treeed103596a06a07616d6ece2eedb2a92065ec0fad /x11/libXrender/Makefile
parent42359975691d33e2097222b8204bfee48482029d (diff)
downloadports-102cbb3b7f52931fe94f2ca266ad5157d0fc0b4d.tar.gz
ports-102cbb3b7f52931fe94f2ca266ad5157d0fc0b4d.zip
Notes
Diffstat (limited to 'x11/libXrender/Makefile')
-rw-r--r--x11/libXrender/Makefile24
1 files changed, 14 insertions, 10 deletions
diff --git a/x11/libXrender/Makefile b/x11/libXrender/Makefile
index 0fdfea6d0194..d0d3ed314400 100644
--- a/x11/libXrender/Makefile
+++ b/x11/libXrender/Makefile
@@ -5,23 +5,27 @@
# $FreeBSD$
#
-PORTNAME= xrender
+PORTNAME= libXrender
PORTVERSION= 0.8.3
CATEGORIES= x11-toolkits
-MASTER_SITES= http://fontconfig.org/release/
+MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
+DISTNAME= xrender-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= x11@FreeBSD.org
COMMENT= XRender extension for XFree86
-BUILD_DEPENDS= ${X11BASE}/lib/pkgconfig/render.pc:${PORTSDIR}/x11-toolkits/render
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/ice.pc:${PORTSDIR}/x11/xextensions
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/render.pc:${PORTSDIR}/x11-toolkits/render \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
-USE_X_PREFIX= yes
-CONFIGURE_ARGS= --prefix=${X11BASE}
-CONFIGURE_ENV+= PKG_CONFIG_PATH=${X11BASE}/lib/pkgconfig
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
-pre-build:
- @(cd ${WRKSRC}; ./configure ${CONFIGURE_ARGS} ${CONFIGURE_ENV})
-
.include <bsd.port.mk>