aboutsummaryrefslogtreecommitdiff
path: root/x11/libdmx
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-19 20:36:56 +0000
commitd4f0d0048a8755106a4b0445221a19761e746984 (patch)
treec87184c5bfeaf942c827c5f706186ce9786a2588 /x11/libdmx
parente82affd309fc2d8e5ea19b2e003f1296920bd825 (diff)
downloadports-d4f0d0048a8755106a4b0445221a19761e746984.tar.gz
ports-d4f0d0048a8755106a4b0445221a19761e746984.zip
Notes
Diffstat (limited to 'x11/libdmx')
-rw-r--r--x11/libdmx/Makefile36
-rw-r--r--x11/libdmx/distinfo3
-rw-r--r--x11/libdmx/pkg-descr6
-rw-r--r--x11/libdmx/pkg-plist6
4 files changed, 51 insertions, 0 deletions
diff --git a/x11/libdmx/Makefile b/x11/libdmx/Makefile
new file mode 100644
index 000000000000..e39458f26443
--- /dev/null
+++ b/x11/libdmx/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: libdmx
+# Date Created: 8 Feb 2006
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdmx
+PORTVERSION= 1.0.2
+CATEGORIES= x11
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= XKB file library
+
+XORG_CAT= lib
+USE_XORG= x11 xext xextproto dmxproto
+
+MAN3= DMX.3 \
+ DMXAddInput.3 \
+ DMXAddScreen.3 \
+ DMXChangeDesktopAttributes.3 \
+ DMXChangeScreensAttributes.3 \
+ DMXForceWindowCreation.3 \
+ DMXGetDesktopAttributes.3 \
+ DMXGetInputAttributes.3 \
+ DMXGetInputCount.3 \
+ DMXGetScreenAttributes.3 \
+ DMXGetScreenCount.3 \
+ DMXGetWindowAttributes.3 \
+ DMXQueryExtension.3 \
+ DMXQueryVersion.3 \
+ DMXRemoveInput.3 \
+ DMXRemoveScreen.3 \
+ DMXSync.3
+
+.include <bsd.port.mk>
diff --git a/x11/libdmx/distinfo b/x11/libdmx/distinfo
new file mode 100644
index 000000000000..8131963fa474
--- /dev/null
+++ b/x11/libdmx/distinfo
@@ -0,0 +1,3 @@
+MD5 (xorg/lib/libdmx-1.0.2.tar.bz2) = 4d866967210d06098fc9f302ed4c79b1
+SHA256 (xorg/lib/libdmx-1.0.2.tar.bz2) = fa3ff31a543f7cea04762c08f48b418e75230de8b4dfdf9d2d3ae9e2af26b9c4
+SIZE (xorg/lib/libdmx-1.0.2.tar.bz2) = 231083
diff --git a/x11/libdmx/pkg-descr b/x11/libdmx/pkg-descr
new file mode 100644
index 000000000000..f8549ce6ce20
--- /dev/null
+++ b/x11/libdmx/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the XKB file library.
+
+WWW: http://www.freedesktop.org/Software/xorg
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libdmx/pkg-plist b/x11/libdmx/pkg-plist
new file mode 100644
index 000000000000..1d6c42c745e2
--- /dev/null
+++ b/x11/libdmx/pkg-plist
@@ -0,0 +1,6 @@
+lib/libdmx.a
+lib/libdmx.la
+lib/libdmx.so
+lib/libdmx.so.1
+libdata/pkgconfig/dmx.pc
+@dirrmtry include/X11/extensions