aboutsummaryrefslogtreecommitdiff
path: root/x11/libfm-extra/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-08-01 10:16:31 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-08-01 10:16:31 +0000
commit9d86ec5bc288a709139cc9fc4bcfae3367e28209 (patch)
treee4dfed94ccbab394fe34c96eca5edac6b7d3f124 /x11/libfm-extra/Makefile
parentbfa3048623debfaaf618636044e625ac57c2543a (diff)
downloadports-9d86ec5bc288a709139cc9fc4bcfae3367e28209.tar.gz
ports-9d86ec5bc288a709139cc9fc4bcfae3367e28209.zip
Notes
Diffstat (limited to 'x11/libfm-extra/Makefile')
-rw-r--r--x11/libfm-extra/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/x11/libfm-extra/Makefile b/x11/libfm-extra/Makefile
index f677604deeec..4693c7b0ed55 100644
--- a/x11/libfm-extra/Makefile
+++ b/x11/libfm-extra/Makefile
@@ -1,29 +1,26 @@
# Created by: Kris Moore <kmoore@FreeBSD.org>
# $FreeBSD$
-PORTNAME= libfm-extra
-PORTVERSION= 1.2.3
-CATEGORIES= x11
-MASTER_SITES= SF/pcmanfm/PCManFM%20%2B%20Libfm%20%28tarball%20release%29/LibFM/
-DISTNAME= libfm-${PORTVERSION}
+PORTNAME= libfm
+PORTREVISION= 1
+PKGNAMESUFFIX= -extra
MAINTAINER= horia@racoviceanu.com
-COMMENT= Core library of PCManFM file manager
+COMMENT= LibFM-Extra library
LICENSE= LGPL21
-USES= gmake libtool pathfix pkgconfig tar:xz gettext-tools
-USE_GNOME= glib20 intltool intlhack
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+MASTERDIR= ${.CURDIR}/../${PORTNAME}
+
+DESCR= ${.CURDIR}/pkg-descr
+FILESDIR= ${.CURDIR}/files
+PATCHDIR= ${.CURDIR}/files
+PLIST= ${.CURDIR}/pkg-plist
-WRKSRC= ${WRKDIR}/libfm-${PORTVERSION}
+USE_LDCONFIG= yes
-EXTRA_PATCHES+= ${.CURDIR}/../libfm/files/patch-configure
+EXTRA_ONLY= yes
-CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --with-extra-only \
- --disable-static \
- --disable-nls
+OPTIONS_EXCLUDE=DOCS NLS
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"