aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnome
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /x11/libgnome
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile29
-rw-r--r--x11/libgnome/distinfo4
-rw-r--r--x11/libgnome/files/patch-ag2
-rw-r--r--x11/libgnome/files/patch-libgnome::Makefile.in6
-rw-r--r--x11/libgnome/files/patch-libgnome_gnome-program.c12
-rw-r--r--x11/libgnome/pkg-plist79
6 files changed, 68 insertions, 64 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index d752f7c6c44c..4bb69b27dbab 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= libgnome
-PORTVERSION= 2.6.1.2
-CATEGORIES?= x11 gnome
+PORTVERSION= 2.8.0
+CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
DIST_SUBDIR= gnome2
-MAINTAINER?= gnome@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
COMMENT= Libraries for GNOME, a GNU desktop environment
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
@@ -20,6 +20,7 @@ RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_XPM= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intlhack esound \
@@ -30,4 +31,24 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+GCONF_SCHEMAS= desktop_gnome_accessibility_keyboard.schemas \
+ desktop_gnome_accessibility_startup.schemas \
+ desktop_gnome_applications_browser.schemas \
+ desktop_gnome_applications_help_viewer.schemas \
+ desktop_gnome_applications_terminal.schemas \
+ desktop_gnome_applications_window_manager.schemas \
+ desktop_gnome_background.schemas \
+ desktop_gnome_file_views.schemas \
+ desktop_gnome_interface.schemas desktop_gnome_lockdown.schemas \
+ desktop_gnome_peripherals_keyboard.schemas \
+ desktop_gnome_peripherals_mouse.schemas \
+ desktop_gnome_sound.schemas desktop_gnome_thumbnailers.schemas \
+ desktop_gnome_typing_break.schemas
+
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e 's|gnome-data po doc|gnome-data po|g' \
+ ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>
diff --git a/x11/libgnome/distinfo b/x11/libgnome/distinfo
index eaf124ea95a5..0ce1fe747796 100644
--- a/x11/libgnome/distinfo
+++ b/x11/libgnome/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libgnome-2.6.1.2.tar.bz2) = 5970203d9f6822652cc95bdd72082bfb
-SIZE (gnome2/libgnome-2.6.1.2.tar.bz2) = 1050839
+MD5 (gnome2/libgnome-2.8.0.tar.bz2) = dab4ecbfa7ec1a2f22d2a48b6b83e937
+SIZE (gnome2/libgnome-2.8.0.tar.bz2) = 1164177
diff --git a/x11/libgnome/files/patch-ag b/x11/libgnome/files/patch-ag
index 131cf3baa5a4..157a59be15ac 100644
--- a/x11/libgnome/files/patch-ag
+++ b/x11/libgnome/files/patch-ag
@@ -11,7 +11,7 @@ $FreeBSD$
- "/bin/zsh", "/usr/bin/zsh",
- "/bin/tcsh", "/usr/bin/tcsh",
- "/bin/ksh", "/usr/bin/ksh",
-- "/bin/csh", "/bin/sh", 0
+- "/bin/csh", "/bin/sh", NULL
+ "/bin/csh", "/bin/sh",
+ LOCALBASE "/bin/bash",
+ LOCALBASE "/bin/zsh",
diff --git a/x11/libgnome/files/patch-libgnome::Makefile.in b/x11/libgnome/files/patch-libgnome::Makefile.in
index a3e14ed9e902..5a240a06a94c 100644
--- a/x11/libgnome/files/patch-libgnome::Makefile.in
+++ b/x11/libgnome/files/patch-libgnome::Makefile.in
@@ -1,6 +1,6 @@
---- libgnome/Makefile.in.orig Wed Feb 25 01:17:58 2004
-+++ libgnome/Makefile.in Wed Feb 25 01:20:59 2004
-@@ -159,6 +159,9 @@
+--- libgnome/Makefile.in.orig Mon May 31 16:33:14 2004
++++ libgnome/Makefile.in Mon May 31 16:33:45 2004
+@@ -211,6 +211,9 @@
libgnomeincludedir = $(includedir)/libgnome-2.0/libgnome
INCLUDES = \
diff --git a/x11/libgnome/files/patch-libgnome_gnome-program.c b/x11/libgnome/files/patch-libgnome_gnome-program.c
index 90fcdd22c777..9dd33f9c2838 100644
--- a/x11/libgnome/files/patch-libgnome_gnome-program.c
+++ b/x11/libgnome/files/patch-libgnome_gnome-program.c
@@ -1,6 +1,6 @@
---- libgnome/gnome-program.c.orig Wed Jul 23 05:35:30 2003
-+++ libgnome/gnome-program.c Mon Dec 22 01:19:23 2003
-@@ -894,17 +894,17 @@
+--- libgnome/gnome-program.c.orig Mon May 31 16:37:02 2004
++++ libgnome/gnome-program.c Mon May 31 16:37:05 2004
+@@ -895,17 +895,17 @@
attr_rel = "";
break;
case GNOME_FILE_DOMAIN_DATADIR:
@@ -21,7 +21,7 @@
attr_name = GNOME_PARAM_GNOME_DATADIR;
attr_rel = "/pixmaps";
break;
-@@ -916,7 +916,7 @@
+@@ -917,7 +917,7 @@
case GNOME_FILE_DOMAIN_HELP:
prefix_rel = "/share/gnome/help";
attr_name = GNOME_PARAM_GNOME_DATADIR;
@@ -30,7 +30,7 @@
break;
case GNOME_FILE_DOMAIN_APP_LIBDIR:
prefix_rel = "/lib";
-@@ -925,19 +925,19 @@
+@@ -926,19 +926,19 @@
search_path = FALSE;
break;
case GNOME_FILE_DOMAIN_APP_DATADIR:
@@ -53,7 +53,7 @@
attr_name = GNOME_PARAM_APP_DATADIR;
attr_rel = "/pixmaps";
search_path = FALSE;
-@@ -958,12 +958,12 @@
+@@ -959,12 +959,12 @@
attr_name = GNOME_PARAM_APP_DATADIR;
diff --git a/x11/libgnome/pkg-plist b/x11/libgnome/pkg-plist
index d8fed71104d6..c4423ffe156f 100644
--- a/x11/libgnome/pkg-plist
+++ b/x11/libgnome/pkg-plist
@@ -1,49 +1,4 @@
bin/gnome-open
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_accessibility_keyboard.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_accessibility_startup.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_applications_browser.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_applications_browser.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_applications_browser.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_applications_help_viewer.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_applications_window_manager.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_background.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_background.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_background.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_file_views.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_file_views.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_file_views.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_interface.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_interface.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_interface.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_lockdown.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_lockdown.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_lockdown.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_peripherals_keyboard.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_peripherals_mouse.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_sound.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_sound.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_sound.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_thumbnailers.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_thumbnailers.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_thumbnailers.schemas > /dev/null || /usr/bin/true
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/desktop_gnome_typing_break.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/desktop_gnome_typing_break.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/desktop_gnome_typing_break.schemas > /dev/null || /usr/bin/true
etc/sound/events/gnome-2.soundlist
etc/sound/events/gtk-events-2.soundlist
include/libgnome-2.0/libgnome/gnome-config.h
@@ -64,9 +19,35 @@ include/libgnome-2.0/libgnome/libgnometypebuiltins.h
lib/bonobo/monikers/libmoniker_extra_2.so
lib/libgnome-2.a
lib/libgnome-2.so
-lib/libgnome-2.so.600
+lib/libgnome-2.so.800
libdata/bonobo/servers/GNOME_Moniker_std.server
libdata/pkgconfig/libgnome-2.0.pc
+share/doc/libgnome/ch01s02.html
+share/doc/libgnome/ch01s03.html
+share/doc/libgnome/ch01s04.html
+share/doc/libgnome/ch01s05.html
+share/doc/libgnome/home.png
+share/doc/libgnome/index.html
+share/doc/libgnome/index.sgml
+share/doc/libgnome/left.png
+share/doc/libgnome/libgnome-gnome-config.html
+share/doc/libgnome/libgnome-gnome-exec.html
+share/doc/libgnome/libgnome-gnome-gconf.html
+share/doc/libgnome/libgnome-gnome-help.html
+share/doc/libgnome/libgnome-gnome-i18n.html
+share/doc/libgnome/libgnome-gnome-init.html
+share/doc/libgnome/libgnome-gnome-program.html
+share/doc/libgnome/libgnome-gnome-score.html
+share/doc/libgnome/libgnome-gnome-sound.html
+share/doc/libgnome/libgnome-gnome-triggers.html
+share/doc/libgnome/libgnome-gnome-url.html
+share/doc/libgnome/libgnome-gnome-util.html
+share/doc/libgnome/libgnome-libgnometypebuiltins.html
+share/doc/libgnome/libgnome.devhelp
+share/doc/libgnome/libgnome.html
+share/doc/libgnome/right.png
+share/doc/libgnome/style.css
+share/doc/libgnome/up.png
share/locale/am/LC_MESSAGES/libgnome-2.0.mo
share/locale/ar/LC_MESSAGES/libgnome-2.0.mo
share/locale/az/LC_MESSAGES/libgnome-2.0.mo
@@ -106,6 +87,8 @@ share/locale/mk/LC_MESSAGES/libgnome-2.0.mo
share/locale/ml/LC_MESSAGES/libgnome-2.0.mo
share/locale/mn/LC_MESSAGES/libgnome-2.0.mo
share/locale/ms/LC_MESSAGES/libgnome-2.0.mo
+share/locale/nb/LC_MESSAGES/libgnome-2.0.mo
+share/locale/ne/LC_MESSAGES/libgnome-2.0.mo
share/locale/nl/LC_MESSAGES/libgnome-2.0.mo
share/locale/nn/LC_MESSAGES/libgnome-2.0.mo
share/locale/no/LC_MESSAGES/libgnome-2.0.mo
@@ -119,8 +102,8 @@ share/locale/sk/LC_MESSAGES/libgnome-2.0.mo
share/locale/sl/LC_MESSAGES/libgnome-2.0.mo
share/locale/sq/LC_MESSAGES/libgnome-2.0.mo
share/locale/sr/LC_MESSAGES/libgnome-2.0.mo
-share/locale/sr@ije/LC_MESSAGES/libgnome-2.0.mo
share/locale/sr@Latn/LC_MESSAGES/libgnome-2.0.mo
+share/locale/sr@ije/LC_MESSAGES/libgnome-2.0.mo
share/locale/sv/LC_MESSAGES/libgnome-2.0.mo
share/locale/ta/LC_MESSAGES/libgnome-2.0.mo
share/locale/th/LC_MESSAGES/libgnome-2.0.mo
@@ -131,6 +114,6 @@ share/locale/wa/LC_MESSAGES/libgnome-2.0.mo
share/locale/yi/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_CN/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libgnome-2.0.mo
-@dirrm %%DOCSDIR%%
+@dirrm share/doc/libgnome
@dirrm include/libgnome-2.0/libgnome
@dirrm include/libgnome-2.0