aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnome
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-17 09:29:33 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-17 09:29:33 +0000
commit20172aa4430615bcbe4ef6bce7b8bcbb11472776 (patch)
treefb2d1d4f6fc85336784402aa186328305bb5a321 /x11/libgnome
parent3b95f1a92cef0de375907d8eb23742e2e319aa9c (diff)
downloadports-20172aa4430615bcbe4ef6bce7b8bcbb11472776.tar.gz
ports-20172aa4430615bcbe4ef6bce7b8bcbb11472776.zip
Notes
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 7e8c63675348..42951f527e5c 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -26,6 +26,7 @@ USE_XPM= yes
USE_GMAKE= yes
USE_ESOUND= yes
USE_BISON= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
@@ -37,11 +38,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
+ s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
+ s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>