aboutsummaryrefslogtreecommitdiff
path: root/x11/libgnome
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-08-07 07:19:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-08-07 07:19:55 +0000
commitc6bc0f61ba9a49bbeb8f9e7dce21015b1d3fbb5d (patch)
treec44771316e4c5916bb2d8a0468ea3785594dd67f /x11/libgnome
parente1e8d4fa7da2ccfecc509f3c024a3573fa70c060 (diff)
downloadports-c6bc0f61ba9a49bbeb8f9e7dce21015b1d3fbb5d.tar.gz
ports-c6bc0f61ba9a49bbeb8f9e7dce21015b1d3fbb5d.zip
Notes
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile18
-rw-r--r--x11/libgnome/distinfo2
-rw-r--r--x11/libgnome/files/patch-help-converters::gnome-vfs-module::Makefile.in13
-rw-r--r--x11/libgnome/files/patch-help-converters::info::main.c45
-rw-r--r--x11/libgnome/pkg-plist13
5 files changed, 37 insertions, 54 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 42951f527e5c..2efadb1d72ce 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= libgnome
-PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTVERSION= 2.0.2
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= 2.0.0/releases/gnome-2.0-desktop-final
+MASTER_SITE_SUBDIR= 2.0.0/sources/${PORTNAME}
DIST_SUBDIR= gnome2
MAINTAINER?= gnome@FreeBSD.org
@@ -24,25 +23,18 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GMAKE= yes
-USE_ESOUND= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier esound
USE_BISON= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-html-dir=${PREFIX}/share/doc \
- --with-gconf-source=xml::${PREFIX}/etc/gconf/gconf.xml.defaults
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
- s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>
diff --git a/x11/libgnome/distinfo b/x11/libgnome/distinfo
index 9ccca30f0041..feaaadb11071 100644
--- a/x11/libgnome/distinfo
+++ b/x11/libgnome/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libgnome-2.0.1.tar.bz2) = bab4a2528928f35d2c2a3a790a1ac84c
+MD5 (gnome2/libgnome-2.0.2.tar.bz2) = d4e0860a4e4a003cf130a5234f97ca22
diff --git a/x11/libgnome/files/patch-help-converters::gnome-vfs-module::Makefile.in b/x11/libgnome/files/patch-help-converters::gnome-vfs-module::Makefile.in
index e7df520cedc5..d2267d824fcf 100644
--- a/x11/libgnome/files/patch-help-converters::gnome-vfs-module::Makefile.in
+++ b/x11/libgnome/files/patch-help-converters::gnome-vfs-module::Makefile.in
@@ -1,14 +1,11 @@
-
-$FreeBSD$
-
---- help-converters/gnome-vfs-module/Makefile.in.orig Wed Feb 27 15:17:54 2002
-+++ help-converters/gnome-vfs-module/Makefile.in Wed Feb 27 15:34:24 2002
-@@ -134,12 +134,12 @@
+--- help-converters/gnome-vfs-module/Makefile.in.orig Wed Aug 7 01:46:48 2002
++++ help-converters/gnome-vfs-module/Makefile.in Wed Aug 7 01:49:21 2002
+@@ -138,12 +138,12 @@
cxxflags_set = @cxxflags_set@
gnomelocaledir = @gnomelocaledir@
--INCLUDES = -I$(top_srcdir) $(HELP_VFS_MODULE_CFLAGS)
-+INCLUDES = -DPREFIX="\"$(PREFIX)\"" -DLOCALBASE="\"$(LOCALBASE)\"" -DX11BASE="\"$(X11BASE)\"" -I$(top_srcdir) $(HELP_VFS_MODULE_CFLAGS)
+-INCLUDES = -I$(top_srcdir) $(HELP_VFS_MODULE_CFLAGS) -DSERVERDIR=\"$(libexecdir)\"
++INCLUDES = -DPREFIX="\"$(PREFIX)\"" -DLOCALBASE="\"$(LOCALBASE)\"" -DX11BASE="\"$(X11BASE)\"" -I$(top_srcdir) $(HELP_VFS_MODULE_CFLAGS) -DSERVERDIR=\"$(libexecdir)\"
modules_LTLIBRARIES = libvfs-help.la
diff --git a/x11/libgnome/files/patch-help-converters::info::main.c b/x11/libgnome/files/patch-help-converters::info::main.c
index 221f00345893..cd3f6f1c8363 100644
--- a/x11/libgnome/files/patch-help-converters::info::main.c
+++ b/x11/libgnome/files/patch-help-converters::info::main.c
@@ -1,25 +1,22 @@
-
-$FreeBSD$
-
---- help-converters/info/main.c 2002/02/20 18:02:08 1.1
-+++ help-converters/info/main.c 2002/02/20 18:08:43
-@@ -87,13 +87,15 @@
- char buf[PATH_MAX];
+--- help-converters/info/main.c.orig Mon Aug 5 14:06:06 2002
++++ help-converters/info/main.c Wed Aug 7 01:52:35 2002
+@@ -104,13 +104,15 @@
+ char buf[PATH_MAX];
- /* First, find the directory that the info file is in. */
-- dirs[0] = "/usr/info";
-- dirs[1] = "/usr/share/info";
-+ dirs[0] = "/usr/share/info";
-+ dirs[1] = PREFIX "/info";
-+ dirs[2] = LOCALBASE "/info";
-+ dirs[3] = X11BASE "/info";
- /* We now have at least one directory to look in. This is
- * necessary because we may not have an 'INFOPATH' set */
-- ndirs = 2;
-+ ndirs = 4;
- if(infopath)
-- for(ndirs = 2, ctmp = strtok(infopath, ":"); ndirs < 64 && ctmp; ndirs++, ctmp = strtok(NULL, ":"))
-+ for(ndirs = 4, ctmp = strtok(infopath, ":"); ndirs < 64 && ctmp; ndirs++, ctmp = strtok(NULL, ":"))
- dirs[ndirs] = strdup(ctmp);
-
- for(i = 0; i < ndirs; i++)
+ /* First, find the directory that the info file is in. */
+- dirs[0] = "/usr/info";
+- dirs[1] = "/usr/share/info";
++ dirs[0] = "/usr/share/info";
++ dirs[1] = PREFIX "/info";
++ dirs[2] = LOCALBASE "/info";
++ dirs[3] = X11BASE "/info";
+ /* We now have at least one directory to look in. This is
+ * necessary because we may not have an 'INFOPATH' set */
+- ndirs = 2;
++ ndirs = 4;
+ if(infopath) {
+- for (ndirs = 2, ctmp = strtok(infopath, ":"); ndirs < 64 && ctmp; ndirs++, ctmp = strtok(NULL, ":")) {
++ for (ndirs = 4, ctmp = strtok(infopath, ":"); ndirs < 64 && ctmp; ndirs++, ctmp = strtok(NULL, ":")) {
+ dirs[ndirs] = strdup(ctmp);
+ }
+ }
diff --git a/x11/libgnome/pkg-plist b/x11/libgnome/pkg-plist
index 31f0c446f397..6b4cacd81bd6 100644
--- a/x11/libgnome/pkg-plist
+++ b/x11/libgnome/pkg-plist
@@ -1,6 +1,3 @@
-bin/gnome2-db2html
-bin/gnome2-info2html
-bin/gnome2-man2html
etc/gconf/gconf.xml.defaults/desktop/%gconf.xml
etc/gconf/gconf.xml.defaults/desktop/gnome/%gconf.xml
etc/gconf/gconf.xml.defaults/desktop/gnome/accessibility/%gconf.xml
@@ -92,6 +89,9 @@ lib/libgnome-2.so
lib/libgnome-2.so.0
libdata/bonobo/servers/GNOME_Moniker_std.server
libdata/pkgconfig/libgnome-2.0.pc
+libexec/gnome2-db2html
+libexec/gnome2-info2html
+libexec/gnome2-man2html
share/doc/libgnome/index.html
share/doc/libgnome/index.sgml
share/doc/libgnome/libgnome-gnome-config.html
@@ -116,6 +116,8 @@ share/gnome/sgml/docbook/gnome-customization-0.1/gnome-custom.xsl
share/gnome/sgml/docbook/gnome-customization-0.1/gnome-customization.xsl
share/gnome/sgml/docbook/gnome-customization-0.1/l10n.xml
share/locale/az/LC_MESSAGES/libgnome-2.0.mo
+share/locale/bg/LC_MESSAGES/libgnome-2.0.mo
+share/locale/bs/LC_MESSAGES/libgnome-2.0.mo
share/locale/da/LC_MESSAGES/libgnome-2.0.mo
share/locale/de/LC_MESSAGES/libgnome-2.0.mo
share/locale/es/LC_MESSAGES/libgnome-2.0.mo
@@ -144,9 +146,6 @@ share/locale/vi/LC_MESSAGES/libgnome-2.0.mo
share/locale/wa/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_CN/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libgnome-2.0.mo
-@dirrm share/gnome/sgml/docbook/gnome-customization-0.1
-@dirrm share/gnome/sgml/docbook
-@dirrm share/gnome/sgml
@dirrm share/doc/libgnome
@dirrm include/libgnome-2.0/libgnome
@dirrm include/libgnome-2.0
@@ -204,5 +203,3 @@ share/locale/zh_TW/LC_MESSAGES/libgnome-2.0.mo
@dirrm etc/gconf/gconf.xml.defaults/desktop/gnome/accessibility
@dirrm etc/gconf/gconf.xml.defaults/desktop/gnome
@dirrm etc/gconf/gconf.xml.defaults/desktop
-@unexec /bin/rmdir %D/etc/sound/events 2>/dev/null || /usr/bin/true
-@unexec /bin/rmdir %D/etc/sound 2>/dev/null || /usr/bin/true