aboutsummaryrefslogtreecommitdiff
path: root/x11/libsx
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-01-13 07:43:51 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-01-13 07:43:51 +0000
commit7092cf4386667338635693c03153b60abc000a48 (patch)
treef0d242b8cd86c9fd1245dcc90c72d1d5f1d35ca7 /x11/libsx
parentccd663182a68a8be13b1ece705322cae594478da (diff)
downloadports-7092cf4386667338635693c03153b60abc000a48.tar.gz
ports-7092cf4386667338635693c03153b60abc000a48.zip
Import of libsx, a simple X library.
Closes PR #2289. Submitted by: pgiffuni@FPS.biblos.unal.edu.co
Notes
Notes: svn path=/head/; revision=5333
Diffstat (limited to 'x11/libsx')
-rw-r--r--x11/libsx/Makefile32
-rw-r--r--x11/libsx/distinfo1
-rw-r--r--x11/libsx/files/patch-aa64
-rw-r--r--x11/libsx/pkg-comment1
-rw-r--r--x11/libsx/pkg-descr11
-rw-r--r--x11/libsx/pkg-plist20
6 files changed, 129 insertions, 0 deletions
diff --git a/x11/libsx/Makefile b/x11/libsx/Makefile
new file mode 100644
index 000000000000..ac94b4079d97
--- /dev/null
+++ b/x11/libsx/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libsx
+# Version required: 1.1
+# Date created: 5 December 1996
+# Whom: pgiffuni@FPS.biblos.unal.edu.co
+#
+# $Id$
+#
+
+DISTNAME= libsx
+PKGNAME= libsx-1.1
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITE_SUBDIR= libraries
+
+MAINTAINER= pgiffuni@FPS.biblos.unal.edu.co
+
+USE_X11= yes
+ALL_TARGET= src
+
+do-install:
+ cp ${WRKSRC}/src/libsx.a ${PREFIX}/lib
+ mkdir -p ${PREFIX}/include/X11
+ cp ${WRKSRC}/src/libsx.h ${PREFIX}/include/X11
+
+post-install:
+.if !defined(NOPORTDOCS)
+ mkdir -p ${PREFIX}/share/doc/libsx
+ cp ${WRKSRC}/docs/* ${PREFIX}/share/doc/libsx
+ gzip -9nf ${PREFIX}/share/doc/libsx/*.doc
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/libsx/distinfo b/x11/libsx/distinfo
new file mode 100644
index 000000000000..8554682170ce
--- /dev/null
+++ b/x11/libsx/distinfo
@@ -0,0 +1 @@
+MD5 (libsx.tar.gz) = 7af2aacd3e73624457476553e9430ad7
diff --git a/x11/libsx/files/patch-aa b/x11/libsx/files/patch-aa
new file mode 100644
index 000000000000..4eb95453a57b
--- /dev/null
+++ b/x11/libsx/files/patch-aa
@@ -0,0 +1,64 @@
+*** libsx_defs.orig Mon Feb 28 11:04:26 1994
+--- libsx_defs Tue Dec 24 01:13:01 1996
+***************
+*** 9,15 ****
+ # you have it). Using cc seems to also work on the RS/6000 (though
+ # you may need the -xansi or -ansi flag).
+ #CC = gcc
+! CC = cc
+
+
+ # Using gcc it's nice to be real strict and compile with -Wall, for
+--- 9,15 ----
+ # you have it). Using cc seems to also work on the RS/6000 (though
+ # you may need the -xansi or -ansi flag).
+ #CC = gcc
+! #CC = cc
+
+
+ # Using gcc it's nice to be real strict and compile with -Wall, for
+***************
+*** 46,60 ****
+ # If you're daring, and you have OpenGL, try:
+ # CFLAGS = -g -D_POSIX_SOURCE -DOPENGL_SUPPORT
+ #
+! CFLAGS = -g -D_POSIX_SOURCE
+
+ #
+ # if you are on a System V (like the SGI) machine, just define RANLIB
+ # to be something innocuous like `echo'. On a Sun or other BSD machine
+ # (like a DECstation, AIX) we need to run the ranlib program.
+ #
+! #RANLIB=ranlib
+! RANLIB=echo
+
+ #
+ # libraries we need to link with...
+--- 46,60 ----
+ # If you're daring, and you have OpenGL, try:
+ # CFLAGS = -g -D_POSIX_SOURCE -DOPENGL_SUPPORT
+ #
+! CFLAGS = -O -D_POSIX_SOURCE -I$(X11BASE)/include
+
+ #
+ # if you are on a System V (like the SGI) machine, just define RANLIB
+ # to be something innocuous like `echo'. On a Sun or other BSD machine
+ # (like a DECstation, AIX) we need to run the ranlib program.
+ #
+! RANLIB=ranlib
+! #RANLIB=echo
+
+ #
+ # libraries we need to link with...
+***************
+*** 83,87 ****
+ #
+ LIBSX = ../src/libsx.a
+ #LIBS = $(LIBSX) -lXaw -lXmu -lXt -lX11
+! LIBS = $(LIBSX) -lXaw -lXmu -lXt -lX11
+!
+--- 83,86 ----
+ #
+ LIBSX = ../src/libsx.a
+ #LIBS = $(LIBSX) -lXaw -lXmu -lXt -lX11
+! LIBS = $(LIBSX) -lXaw -lXmu -lXt -lX11 -lm -lXext -L$(X11BASE)/lib
diff --git a/x11/libsx/pkg-comment b/x11/libsx/pkg-comment
new file mode 100644
index 000000000000..55c54fe6ec16
--- /dev/null
+++ b/x11/libsx/pkg-comment
@@ -0,0 +1 @@
+Simple X Windows library.
diff --git a/x11/libsx/pkg-descr b/x11/libsx/pkg-descr
new file mode 100644
index 000000000000..2b7c9debcd16
--- /dev/null
+++ b/x11/libsx/pkg-descr
@@ -0,0 +1,11 @@
+Libsx is a library of code that sits on top of and to the side of the
+Athena widget set. Its purpose is to make writing X applications
+*much* easier. To accomplish this, libsx encapsulates a large
+portion of the uglier details that arise while programming in X and
+it fills in some gaps that exist with the Athena Widget set (such as
+a widget for drawing graphics); libsx tries to simplify the common
+case down to a single function call with only a few arguments.
+
+ by Dominic Giamapolo
+ dbg@sgi.com
+
diff --git a/x11/libsx/pkg-plist b/x11/libsx/pkg-plist
new file mode 100644
index 000000000000..327f8463312d
--- /dev/null
+++ b/x11/libsx/pkg-plist
@@ -0,0 +1,20 @@
+lib/libsx.a
+include/X11/libsx.h
+share/doc/libsx/libsx_intro
+share/doc/libsx/button.doc.gz
+share/doc/libsx/color.doc.gz
+share/doc/libsx/draw_area.doc.gz
+share/doc/libsx/drawing.doc.gz
+share/doc/libsx/font.doc.gz
+share/doc/libsx/form.doc.gz
+share/doc/libsx/general.libsx.doc.gz
+share/doc/libsx/label.doc.gz
+share/doc/libsx/list.doc.gz
+share/doc/libsx/menu.doc.gz
+share/doc/libsx/misc.doc.gz
+share/doc/libsx/popups.doc.gz
+share/doc/libsx/scrollbar.doc.gz
+share/doc/libsx/string_entry.doc.gz
+share/doc/libsx/text_edit.doc.gz
+share/doc/libsx/toggle.doc.gz
+share/doc/libsx/windows.doc.gz