aboutsummaryrefslogtreecommitdiff
path: root/x11/libxcb/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-02 16:06:17 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-02 16:06:17 +0000
commite30c3ee917800a89d0f75ec62374be8673b7afad (patch)
tree00e5a4ffbb034d87ca82bac572b8b799e568982e /x11/libxcb/Makefile
parent1136018e7ddecb22baed0c1d9b7873c75b7d9012 (diff)
downloadports-e30c3ee917800a89d0f75ec62374be8673b7afad.tar.gz
ports-e30c3ee917800a89d0f75ec62374be8673b7afad.zip
Notes
Diffstat (limited to 'x11/libxcb/Makefile')
-rw-r--r--x11/libxcb/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/x11/libxcb/Makefile b/x11/libxcb/Makefile
index cc0789e5e774..d9e45402b7c6 100644
--- a/x11/libxcb/Makefile
+++ b/x11/libxcb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libxcb
PORTVERSION= 1.9.1
+PORTREVISION= 1
CATEGORIES= x11 python
MASTER_SITES= http://xcb.freedesktop.org/dist/
@@ -30,6 +31,7 @@ GNU_CONFIGURE= yes
.for f in XPROTO_CFLAGS XPROTO_LIBS XDMCP_CFLAGS XDMCP_LIBS NEEDED_CFLAGS NEEDED_LIBS
CONFIGURE_ARGS+=${f}="${${f}}"
.endfor
+CONFIGURE_ARGS+=--enable-xkb
CONFIGURE_ENV= LIBS="`pkg-config --libs pthread-stubs`"
NEEDED_CFLAGS= -I${LOCALBASE}/include
@@ -41,14 +43,12 @@ XDMCP_LIBS= -L${LOCALBASE}/lib -lXdmcp
XPROTO_CFLAGS= -I${LOCALBASE}/include
XPROTO_LIBS= -L${LOCALBASE}/lib
-NO_STAGE= yes
-.include "${.CURDIR}/manpages"
-
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MAKE} -C ${WRKSRC}/doc ${INSTALL_TARGET}
+ ${SETENV} DESTDIR=${STAGEDIR} ${MAKE} -C ${WRKSRC}/doc ${INSTALL_TARGET}
.endif
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxcb*.so.*
.include <bsd.port.mk>