aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4menu
diff options
context:
space:
mode:
authorConrad Meyer <cem@FreeBSD.org>2020-04-12 20:23:56 +0000
committerConrad Meyer <cem@FreeBSD.org>2020-04-12 20:23:56 +0000
commit6a23bfc35e9dde3c19c5972200794b5aa9cc4688 (patch)
tree12ef98b005197b6c56a2803ddc892d5aa2c1babd /x11/libxfce4menu
parentb9fd8f17a4f205fc8c1b22d48ced32b5a010610a (diff)
downloadports-6a23bfc35e9dde3c19c5972200794b5aa9cc4688.tar.gz
ports-6a23bfc35e9dde3c19c5972200794b5aa9cc4688.zip
x11/libxfce4menu: Fix leaked keygrabs when layout changes
As diagnosed by Jethro Nederhof, xfce-shortcuts-grabber.c attempts to update grabbed key shortcuts when xkeyboard layout changes. Unfortunately, it had no memory of which keycodes it has actually grabbed. Instead, it attempted to ungrab the *new* keycode, which obviously doesn't actually ungrab those codes. This went unnoticed for some time, probably because nothing collided with important keys. Recently, a default PrintScreen shortcut was added to Xfce, which for whatever reason seems to collide with Up in initial layout. When the kbd layout changes, the shortcut ungrabs the *new* Printscreen keycode and then re-grabs the same keycode, leaving the Up keycode grabbed. Fix this by giving xfce-shortcuts-grabber some memory of which keycodes it has grabbed. When it grabs a key, it remembers the keycode it grabbed in the XfceKey object. When it ungrabs a key, it ungrabs the keycodes in the XfceKey object, rather than those for the new keyboard layout. PR: 244290 Reported by: Aryeh Friedman <aryeh.friedman AT gmail.com>, many others Approved by: madpilot Differential Revision: https://reviews.freebsd.org/D24338
Notes
Notes: svn path=/head/; revision=531554
Diffstat (limited to 'x11/libxfce4menu')
-rw-r--r--x11/libxfce4menu/Makefile1
-rw-r--r--x11/libxfce4menu/files/patch-libxfce4kbd-private_xfce-shortcuts-grabber.c99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 0faeb81b39cc..c880d9f0a113 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libxfce4menu
PORTVERSION= 4.14.1
+PORTREVISION= 1
CATEGORIES= x11 xfce
MASTER_SITES= XFCE
DISTNAME= libxfce4ui-${DISTVERSIONFULL}
diff --git a/x11/libxfce4menu/files/patch-libxfce4kbd-private_xfce-shortcuts-grabber.c b/x11/libxfce4menu/files/patch-libxfce4kbd-private_xfce-shortcuts-grabber.c
new file mode 100644
index 000000000000..45a0ada41560
--- /dev/null
+++ b/x11/libxfce4menu/files/patch-libxfce4kbd-private_xfce-shortcuts-grabber.c
@@ -0,0 +1,99 @@
+--- libxfce4kbd-private/xfce-shortcuts-grabber.c.orig 2020-04-08 15:05:21 UTC
++++ libxfce4kbd-private/xfce-shortcuts-grabber.c
+@@ -74,6 +74,16 @@ struct _XfceKey
+ {
+ guint keyval;
+ guint modifiers;
++ /*
++ * Cache of old keycodes grabbed by this key. Used to ungrab the keycodes we
++ * actually grabbed.
++ *
++ * An arbitrary number of keys may generate the same keyval. Rather than add
++ * memory allocation to this path, I just constrained the unmapping behavior
++ * to 8 identically coded keys. It seems unlikely? But I am no xkeyboard
++ * expert.
++ */
++ int keycodes[8];
+ };
+
+
+@@ -269,12 +279,20 @@ xfce_shortcuts_grabber_grab (XfceShortcutsGrabber *gra
+ }
+
+ /* Get all keys generating keyval */
+- if (!gdk_keymap_get_entries_for_keyval (keymap,key->keyval,
++ if (grab && !gdk_keymap_get_entries_for_keyval (keymap,key->keyval,
+ &keys, &n_keys))
+ {
+ TRACE ("Got no keys for keyval");
+ return;
+ }
++ if (grab)
++ {
++ if (n_keys > G_N_ELEMENTS(key->keycodes))
++ TRACE ("Got %d keys for keyval but can remember only %d", n_keys,
++ (int)G_N_ELEMENTS(key->keycodes));
++ }
++ else
++ n_keys = G_N_ELEMENTS(key->keycodes);
+
+ if (n_keys == 0)
+ {
+@@ -290,9 +308,9 @@ xfce_shortcuts_grabber_grab (XfceShortcutsGrabber *gra
+ for (i = 0; i < n_keys; i ++)
+ {
+ /* Grab all hardware keys generating keyval */
++ if (grab)
++ TRACE ("New Keycode: %d", keys[i].keycode);
+
+- TRACE ("Keycode: %d", keys[i].keycode);
+-
+ for (j = 0; j < screens; j++)
+ {
+ /* Do the grab on all screens */
+@@ -338,11 +356,14 @@ xfce_shortcuts_grabber_grab (XfceShortcutsGrabber *gra
+ False,
+ GrabModeAsync,
+ GrabModeAsync);
+- else
++ else {
++ if (key->keycodes[i] == -1)
++ break;
+ XUngrabKey (GDK_DISPLAY_XDISPLAY (display),
+- keys[i].keycode,
++ key->keycodes[i],
+ modifiers | mod_masks [k],
+ root_window);
++ }
+ }
+
+ gdk_flush ();
+@@ -355,9 +376,18 @@ xfce_shortcuts_grabber_grab (XfceShortcutsGrabber *gra
+ TRACE ("Failed to ungrab");
+ }
+ }
++ /* Remember the old keycode, as we need it to ungrab. */
++ if (grab && i < G_N_ELEMENTS (key->keycodes))
++ key->keycodes[i] = keys[i].keycode;
++ else if (!grab)
++ key->keycodes[i] = -1;
+ }
+
+- g_free (keys);
++ if (grab) {
++ g_free (keys);
++ for (; i < G_N_ELEMENTS (key->keycodes); i++)
++ key->keycodes[i] = -1;
++ }
+ }
+
+
+@@ -514,6 +544,8 @@ xfce_shortcuts_grabber_add (XfceShortcutsGrabber *grab
+ g_return_if_fail (shortcut != NULL);
+
+ key = g_new0 (XfceKey, 1);
++ for (size_t i = 0; i < G_N_ELEMENTS (key->keycodes); i++)
++ key->keycodes[i] = -1;
+
+ gtk_accelerator_parse (shortcut, &key->keyval, &key->modifiers);
+