aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4menu
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-05-11 18:15:40 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-05-11 18:15:40 +0000
commitebcf65c2dfa46c8fae00dcde872de3b015424ddc (patch)
tree91bb0d46c41d587019b534882312c095a0c47cbd /x11/libxfce4menu
parentad4e927f247ba1c8fcfd4d1dc0e91221d75a57e7 (diff)
downloadports-ebcf65c2dfa46c8fae00dcde872de3b015424ddc.tar.gz
ports-ebcf65c2dfa46c8fae00dcde872de3b015424ddc.zip
Fix keyboard shortcuts with Shift.
Reviewed by: wblock@ Obtained from: Git upstream (master branch)
Notes
Notes: svn path=/head/; revision=317901
Diffstat (limited to 'x11/libxfce4menu')
-rw-r--r--x11/libxfce4menu/Makefile2
-rw-r--r--x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcut-dialog.c13
-rw-r--r--x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcuts-grabber.c24
3 files changed, 38 insertions, 1 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 832543525cfe..b39cd09b920d 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxfce4menu
PORTVERSION= 4.10.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= libxfce4ui-${PORTVERSION}
diff --git a/x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcut-dialog.c b/x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcut-dialog.c
new file mode 100644
index 000000000000..8f87c4e255a2
--- /dev/null
+++ b/x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcut-dialog.c
@@ -0,0 +1,13 @@
+https://bugzilla.xfce.org/show_bug.cgi?id=8744
+
+--- ./libxfce4kbd-private/xfce-shortcut-dialog.c.orig 2012-04-28 19:46:52.000000000 +0000
++++ ./libxfce4kbd-private/xfce-shortcut-dialog.c 2013-05-09 09:19:32.000000000 +0000
+@@ -327,6 +327,8 @@
+ &keyval, NULL, NULL, &consumed);
+
+ /* Get the modifiers */
++ if ((modifiers & GDK_SHIFT_MASK) && (consumed & GDK_SHIFT_MASK))
++ consumed &= ~GDK_SHIFT_MASK;
+ modifiers &= ~consumed;
+ modifiers &= mod_mask;
+
diff --git a/x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcuts-grabber.c b/x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcuts-grabber.c
new file mode 100644
index 000000000000..983d2f1ec839
--- /dev/null
+++ b/x11/libxfce4menu/files/patch-libxfce4kbd-private__xfce-shortcuts-grabber.c
@@ -0,0 +1,24 @@
+https://bugzilla.xfce.org/show_bug.cgi?id=8744
+
+--- ./libxfce4kbd-private/xfce-shortcuts-grabber.c.orig 2012-04-28 19:46:52.000000000 +0000
++++ ./libxfce4kbd-private/xfce-shortcuts-grabber.c 2013-05-09 09:25:50.000000000 +0000
+@@ -512,8 +512,10 @@
+ &keyval, NULL, NULL, &consumed);
+
+ /* Get the modifiers */
+- modifiers &= ~consumed;
++ if ((modifiers & GDK_SHIFT_MASK) && (consumed & GDK_SHIFT_MASK))
++ consumed &= ~GDK_SHIFT_MASK;
+ gdk_keymap_add_virtual_modifiers (keymap, &modifiers);
++ modifiers &= ~consumed;
+ modifiers &= mod_mask;
+
+ context.keyval = keyval;
+@@ -521,6 +523,7 @@
+
+ raw_shortcut_name = gtk_accelerator_name (keyval, modifiers);
+ TRACE ("Looking for %s", raw_shortcut_name);
++ gtk_accelerator_parse (raw_shortcut_name, &context.keyval, &context.modifiers);
+ g_free (raw_shortcut_name);
+
+ g_hash_table_foreach (grabber->priv->keys, (GHFunc) find_event_key, &context);