aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4util/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-28 18:11:36 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-28 18:11:36 +0000
commit6ec65083f74d56fac065a9c33cf7a905c836bac9 (patch)
tree6e5a51f6c9a38650ec9a590c0dd0c616dd321e86 /x11/libxfce4util/Makefile
parent6bda1e2ccb8e3dd89a2943a4d8155500870e682f (diff)
downloadports-6ec65083f74d56fac065a9c33cf7a905c836bac9.tar.gz
ports-6ec65083f74d56fac065a9c33cf7a905c836bac9.zip
Notes
Diffstat (limited to 'x11/libxfce4util/Makefile')
-rw-r--r--x11/libxfce4util/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
new file mode 100644
index 000000000000..9c06063481ec
--- /dev/null
+++ b/x11/libxfce4util/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libxfce4util
+# Date created: 7 June 2003
+# Whom: James Earl <jdearl@telus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxfce4util
+PORTVERSION= 3.99.2
+CATEGORIES= x11
+MASTER_SITES= http://www.xfce.org/archive/xfce4-rc2/src/ \
+ ftp://ftp.unix-ag.org/user/bmeurer/xfce4/rc2/separate/ \
+ http://usuarios.lycos.es/xfce4/tarballs/rc2/separate/ \
+ http://linux.imp.mx/xfce4/rc2/xfce4-rc2/src/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= XFce 4 library with non-graphical helper functions
+
+USE_GNOME= glib20
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/${PORTNAME}/Makefile.in
+
+.include <bsd.port.mk>