aboutsummaryrefslogtreecommitdiff
path: root/x11/libxfce4util/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-30 16:49:12 +0000
commit4b68fc723bc6478544954fa1a7554ca5c269f611 (patch)
tree752bd2703b89f85a96b337b223e14ab4bb621705 /x11/libxfce4util/Makefile
parent66521294b08078847ba4c56a6423c20cf34d68f8 (diff)
downloadports-4b68fc723bc6478544954fa1a7554ca5c269f611.tar.gz
ports-4b68fc723bc6478544954fa1a7554ca5c269f611.zip
Notes
Diffstat (limited to 'x11/libxfce4util/Makefile')
-rw-r--r--x11/libxfce4util/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/x11/libxfce4util/Makefile b/x11/libxfce4util/Makefile
index 63aa1a74aaa3..e9719465beaa 100644
--- a/x11/libxfce4util/Makefile
+++ b/x11/libxfce4util/Makefile
@@ -25,12 +25,11 @@ USE_XFCE= configenv
CONFIGURE_ARGS+=--disable-gtk-doc-html
-OPTIONS= NLS "Enable Native Language Support" on \
- APIDOCS "Install api documentation" off
+OPTIONS_DEFINE= NLS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
@@ -39,12 +38,12 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_APIDOCS)
-CONFIGURE_ARGS+=--without-html-dir
-PLIST_SUB+= APIDOCS="@comment "
-.else
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--with-html-dir=${PREFIX}/share/gtk-doc/html
PLIST_SUB+= APIDOCS=""
+.else
+CONFIGURE_ARGS+=--without-html-dir
+PLIST_SUB+= APIDOCS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>