aboutsummaryrefslogtreecommitdiff
path: root/x11/lilyterm
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2017-12-13 18:42:44 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2017-12-13 18:42:44 +0000
commitaf27f035cf05f0302f9b74b39430b38f8a38a371 (patch)
treee9d41ba94fd68f1fcdaeba30489654be0309c2fd /x11/lilyterm
parentf5addc17d529403baa152f94456195345fcd036e (diff)
downloadports-af27f035cf05f0302f9b74b39430b38f8a38a371.tar.gz
ports-af27f035cf05f0302f9b74b39430b38f8a38a371.zip
[new port] x11/lilyterm: Lightweight, but functional terminal emulator
Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D13463
Notes
Notes: svn path=/head/; revision=456225
Diffstat (limited to 'x11/lilyterm')
-rw-r--r--x11/lilyterm/Makefile36
-rw-r--r--x11/lilyterm/distinfo3
-rw-r--r--x11/lilyterm/files/patch-data_lilyterm.conf179
-rw-r--r--x11/lilyterm/pkg-descr3
-rw-r--r--x11/lilyterm/pkg-plist23
5 files changed, 244 insertions, 0 deletions
diff --git a/x11/lilyterm/Makefile b/x11/lilyterm/Makefile
new file mode 100644
index 000000000000..a05f0f96e763
--- /dev/null
+++ b/x11/lilyterm/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= lilyterm
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.9.4
+CATEGORIES= x11
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Lightweight, but functional terminal emulator
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= gettext gmake pkgconfig
+USE_GNOME= cairo gdkpixbuf2 gtk20 vte
+USE_XORG= x11 xext
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= Tetralet
+GH_PROJECT= LilyTerm
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/lilyterm
+ ${MV} ${STAGEDIR}${PREFIX}/etc/xdg/lilyterm.conf \
+ ${STAGEDIR}${PREFIX}/etc/xdg/lilyterm.conf.sample
+
+.include <bsd.port.mk>
diff --git a/x11/lilyterm/distinfo b/x11/lilyterm/distinfo
new file mode 100644
index 000000000000..b5d88af44667
--- /dev/null
+++ b/x11/lilyterm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509307368
+SHA256 (Tetralet-LilyTerm-v0.9.9.4_GH0.tar.gz) = 310cafcc6c155db1862ee42bd2d57da5083d8f6616ffa3a50083113c06846c3a
+SIZE (Tetralet-LilyTerm-v0.9.9.4_GH0.tar.gz) = 345032
diff --git a/x11/lilyterm/files/patch-data_lilyterm.conf b/x11/lilyterm/files/patch-data_lilyterm.conf
new file mode 100644
index 000000000000..9351d09bb1d8
--- /dev/null
+++ b/x11/lilyterm/files/patch-data_lilyterm.conf
@@ -0,0 +1,179 @@
+--- data/lilyterm.conf.orig 2013-02-27 09:04:56 UTC
++++ data/lilyterm.conf
+@@ -1,10 +1,10 @@
+ [main]
+
+ # Auto save settings when closing window.
+-auto_save = 0
++auto_save = 1
+
+ # The version of this profile's format. DO NOT EDIT IT!
+-version = 0.9.9
++version = 0.9.9.3
+
+ # The default font name of vte terminal.
+ font_name = Monospace 12
+@@ -13,7 +13,7 @@ font_name = Monospace 12
+ column = 80
+
+ # The default row of vte terminal.
+-row = 24
++row = 30
+
+ # Use true opacity in vte box.
+ # 0: do NOT use rgba, 1: force to use rgba.
+@@ -33,7 +33,7 @@ window_opacity = 0.050
+
+ # The opacity of transparent window when inactive.
+ # Left it blank to disable this feature.
+-window_opacity_inactive = 0.200
++window_opacity_inactive =
+
+ # Use transparent background.
+ # It will use true transparent if the window manager were composited.
+@@ -89,15 +89,15 @@ show_color_selection_menu = 1
+
+ # The normal text color used in vte terminal.
+ # You may use black, #000000 or #000000000000 here.
+-foreground_color = white
++foreground_color =
+
+-# Sets the background color for text which is under the cursor.
++# The background color used in vte terminal.
+ # You may use black, #000000 or #000000000000 here.
+-cursor_color = #55B5E7
++background_color =
+
+-# The background color used in vte terminal.
++# Sets the background color for text which is under the cursor.
+ # You may use black, #000000 or #000000000000 here.
+-background_color = black
++cursor_color = #5555b5b5e7e7
+
+ # Shows [Increase window size], [Decrease window size],
+ # [Reset to default font/size] and [Reset to system font/size]
+@@ -143,7 +143,7 @@ enable_hyperlink = 1
+ # 0: Follow GTK+ settings for cursor blinking.
+ # 1: Cursor blinks.
+ # 2: Cursor does not blink.
+-cursor_blinks = 0
++cursor_blinks = 1
+
+ # Shows copy/paste menu on right click menu.
+ show_copy_paste_menu = 1
+@@ -302,7 +302,7 @@ disable_key_binding = Ctrl grave
+
+ # Add a new tab.
+ # Left it blank to disable this function key.
+-new_tab_key = Ctrl T
++new_tab_key = Shift+Ctrl T
+
+ # Close current tab.
+ # Left it blank to disable this function key.
+@@ -314,7 +314,7 @@ edit_label_key =
+
+ # Find the strings matching the search regex.
+ # Left it blank to disable this function key.
+-find_key = Ctrl F
++find_key = Shift+Ctrl F
+
+ # Find the previous string matching the search regex.
+ # Left it blank to disable this function key.
+@@ -322,7 +322,7 @@ find_key_prev = Shift F3
+
+ # Find the next string matching the search regex.
+ # Left it blank to disable this function key.
+-find_key_next = F3
++find_key_next = Shift+Ctrl F3
+
+ # Switch to prev tab.
+ # Left it blank to disable this function key.
+@@ -406,19 +406,19 @@ switch_to_tab_12 = Ctrl F12
+
+ # Open a new window with current dir.
+ # Left it blank to disable this function key.
+-new_window =
++new_window = Shift+Ctrl N
+
+ # Select all the text in the Vte Terminal box.
+ # Left it blank to disable this function key.
+-select_all = Ctrl O
++select_all = Shift+Ctrl O
+
+ # Copy the text to clipboard.
+ # Left it blank to disable this function key.
+-copy_clipboard = Ctrl Delete
++copy_clipboard = Shift+Ctrl C
+
+ # Paste the text in clipboard.
+ # Left it blank to disable this function key.
+-paste_clipboard = Ctrl Insert
++paste_clipboard = Shift+Ctrl V
+
+ # Paste the text in the primary clipboard.
+ # Left it blank to disable this function key.
+@@ -471,42 +471,41 @@ theme =
+ # Invert the ansi colors, like invert the darkred to red, darkblue to bule.
+ invert_color = 0
+
++# Enable the custom colors specified with Color# below.
++custom_theme = 0
++
+ # The brightness for ansi colors used in terminal.
+ brightness = 0.200
+
+ # The brightness for ansi colors used in terminal when inactive.
+ # Left it blank to disable this feature.
+-inactive_brightness = -2.000
+-
+-# The ANSI color code for Normal Black
+-# You may use black, #000000 or #000000000000 here.
+-Color0 =
++inactive_brightness = 0.200
+
+-# The ANSI color code for Normal Red
++# The ANSI color code for Dark Red
+ # You may use black, #000000 or #000000000000 here.
+ Color1 =
+
+-# The ANSI color code for Normal Green
++# The ANSI color code for Dark Green
+ # You may use black, #000000 or #000000000000 here.
+ Color2 =
+
+-# The ANSI color code for Normal Yellow
++# The ANSI color code for Dark Yellow
+ # You may use black, #000000 or #000000000000 here.
+ Color3 =
+
+-# The ANSI color code for Normal Blue
++# The ANSI color code for Dark Blue
+ # You may use black, #000000 or #000000000000 here.
+ Color4 =
+
+-# The ANSI color code for Normal Magenta
++# The ANSI color code for Dark Magenta
+ # You may use black, #000000 or #000000000000 here.
+ Color5 =
+
+-# The ANSI color code for Normal Cyan
++# The ANSI color code for Dark Cyan
+ # You may use black, #000000 or #000000000000 here.
+ Color6 =
+
+-# The ANSI color code for Normal White
++# The ANSI color code for Dark White
+ # You may use black, #000000 or #000000000000 here.
+ Color7 =
+
+@@ -538,10 +537,6 @@ Color13 =
+ # You may use black, #000000 or #000000000000 here.
+ Color14 =
+
+-# The ANSI color code for Bright White
+-# You may use black, #000000 or #000000000000 here.
+-Color15 =
+-
+
+ [command]
+
diff --git a/x11/lilyterm/pkg-descr b/x11/lilyterm/pkg-descr
new file mode 100644
index 000000000000..07f4d78e1cf8
--- /dev/null
+++ b/x11/lilyterm/pkg-descr
@@ -0,0 +1,3 @@
+A lightweight, but functional terminal emulator.
+
+WWW: https://github.com/Tetralet/LilyTerm
diff --git a/x11/lilyterm/pkg-plist b/x11/lilyterm/pkg-plist
new file mode 100644
index 000000000000..2ab657410002
--- /dev/null
+++ b/x11/lilyterm/pkg-plist
@@ -0,0 +1,23 @@
+bin/lilyterm
+@sample etc/xdg/lilyterm.conf.sample
+man/man1/lilyterm.1.gz
+share/applications/lilyterm.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lilyterm.conf
+%%NLS%%share/locale/de/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/es/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/it/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/lilyterm.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lilyterm.mo
+share/pixmaps/lilyterm.png
+share/pixmaps/lilyterm.xpm