aboutsummaryrefslogtreecommitdiff
path: root/x11/lxmenu-data
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-21 13:20:24 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-21 13:20:24 +0000
commit1eca2345e92ca75e6e8cd6ef6415ce9075decf98 (patch)
treec1534965a7e352d955d87cf97065fa7f82b5d86d /x11/lxmenu-data
parent4b6f30c5cce5eb41c107c7f7cc071efd78989b91 (diff)
downloadports-1eca2345e92ca75e6e8cd6ef6415ce9075decf98.tar.gz
ports-1eca2345e92ca75e6e8cd6ef6415ce9075decf98.zip
Notes
Diffstat (limited to 'x11/lxmenu-data')
-rw-r--r--x11/lxmenu-data/Makefile31
1 files changed, 22 insertions, 9 deletions
diff --git a/x11/lxmenu-data/Makefile b/x11/lxmenu-data/Makefile
index 1bf3325706da..cc64dac4510a 100644
--- a/x11/lxmenu-data/Makefile
+++ b/x11/lxmenu-data/Makefile
@@ -1,24 +1,37 @@
-# New ports collection makefile for: lxmenu-data
-# Date created: Fri Sept 24 09:52:35 EST 2010
-# Whom: Kris Moore <kmoore@freebsd.org>
-#
+# Created by: Kris Moore <kmoore@freebsd.org>
# $FreeBSD$
-#
PORTNAME= lxmenu-data
PORTVERSION= 0.1.2
CATEGORIES= x11
-MASTER_SITES= SF/lxde/lxmenu-data%20%28desktop%20menu%29/lxmenu-data%20${PORTVERSION}
+MASTER_SITES= SF/lxde/lxmenu-data%20%28desktop%20menu%29/lxmenu-data%20${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Menu data used by lxpanel
+LICENSE= GPLv2
+
+USES= gettext
USE_XORG= x11 xmu
USE_GNOME= intltool
-USES= gettext
-GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:env
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${LOCALBASE} --sysconfdir=${LOCALBASE}/etc
USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTDOCS= AUTHORS README TODO
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>