aboutsummaryrefslogtreecommitdiff
path: root/x11/lxpanel/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-01-28 05:03:54 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-01-28 05:03:54 +0000
commit25d63d1bcf9b2beabe495f2cb4e936907681ac86 (patch)
tree7f9e226bdb4ee7a7762f246dbe72dcc75ec1eb7f /x11/lxpanel/Makefile
parent75a4753b180e5cb7ce665bc2a678ae8406920c6a (diff)
downloadports-25d63d1bcf9b2beabe495f2cb4e936907681ac86.tar.gz
ports-25d63d1bcf9b2beabe495f2cb4e936907681ac86.zip
Notes
Diffstat (limited to 'x11/lxpanel/Makefile')
-rw-r--r--x11/lxpanel/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
new file mode 100644
index 000000000000..e58f81b00fa5
--- /dev/null
+++ b/x11/lxpanel/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: lxpanel
+# Date created: Sat Oct 7 01:22:35 CST 2006
+# Whom: Lin, Cheng-Tao <b89605222@ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lxpanel
+PORTVERSION= 0.2.4
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lxde
+
+MAINTAINER= b89605222@ntu.edu.tw
+COMMENT= LXPanel is a lightweight X11 desktop panel
+
+USE_XLIB= yes
+USE_GNOME= gtk20 gnomelibs gnomedesktop
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= automake:19
+CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= LDFLAGS="-L${X11BASE}/lib" CFLAGS="-I${LOCALBASE}/include"
+CFLAGS+= -I${WRKSRC}
+USE_GMAKE= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,linux,sys,' \
+ M${WRKSRC}/src/plugins/volume/volume-impl.c
+ @${REINPLACE_CMD} -e 's,$$(DATADIRNAME)/locale,share/locale,' \
+ ${WRKSRC}/po/Makefile.in.in
+
+.include <bsd.port.mk>