aboutsummaryrefslogtreecommitdiff
path: root/x11/lxpanel
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2013-03-10 15:08:04 +0000
committerKris Moore <kmoore@FreeBSD.org>2013-03-10 15:08:04 +0000
commitad638b4b9a189c2e4a902d8952b95529584d9e81 (patch)
tree79471b7b78d3ace439c369e1ee81f5274c6f4838 /x11/lxpanel
parentc50be625fb6f3123382eb04ab88da339a3d5dabf (diff)
downloadports-ad638b4b9a189c2e4a902d8952b95529584d9e81.tar.gz
ports-ad638b4b9a189c2e4a902d8952b95529584d9e81.zip
Notes
Diffstat (limited to 'x11/lxpanel')
-rw-r--r--x11/lxpanel/Makefile10
-rw-r--r--x11/lxpanel/distinfo4
-rw-r--r--x11/lxpanel/files/patch-src__plugins__batt__batt.c33
-rw-r--r--x11/lxpanel/pkg-plist80
4 files changed, 92 insertions, 35 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 10bc3ec725d4..16a49d943612 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lxpanel
-PORTVERSION= 0.5.10
+PORTVERSION= 0.5.12
CATEGORIES= x11
MASTER_SITES= SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}
@@ -16,8 +16,8 @@ COMMENT= LXPanel is a lightweight X11 desktop panel
LIB_DEPENDS= menu-cache.1:${PORTSDIR}/x11/menu-cache
RUN_DEPENDS= ${LOCALBASE}/share/desktop-directories/lxde-audio-video.directory:${PORTSDIR}/x11/lxmenu-data
-OPTIONS= ALSA "enable ALSA audio architecture support" Off \
- NLS "NLS support" On
+OPTIONS_DEFINE= ALSA NLS
+OPTIONS_DEFAULT=NLS
USE_XORG= x11 xmu
USE_GNOME= gnomehack gtk20 pkgconfig libwnck
@@ -34,13 +34,13 @@ MAN1= lxpanel.1 lxpanelctl.1
.include <bsd.port.pre.mk>
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MALSA}
RUN_DEPENDS+= ${LINUXBASE}/lib/libasound.so.2:${PORTSDIR}/audio/linux-f10-alsa-lib
.else
CONFIGURE_ARGS+=--disable-alsa
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/x11/lxpanel/distinfo b/x11/lxpanel/distinfo
index a5f7b749c83a..01b236e5e388 100644
--- a/x11/lxpanel/distinfo
+++ b/x11/lxpanel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lxpanel-0.5.10.tar.gz) = 5f003c38035009fbfcdbb1f1ed8d15cbbdd1216310d1d67a843fe632049996d4
-SIZE (lxpanel-0.5.10.tar.gz) = 1330296
+SHA256 (lxpanel-0.5.12.tar.gz) = 11cfe76f6241bbac556e57a6efc079b6e10dceea76a8bdaf4c749afdb81d15ab
+SIZE (lxpanel-0.5.12.tar.gz) = 2048801
diff --git a/x11/lxpanel/files/patch-src__plugins__batt__batt.c b/x11/lxpanel/files/patch-src__plugins__batt__batt.c
index bfd98c72e8f4..2adc4970b586 100644
--- a/x11/lxpanel/files/patch-src__plugins__batt__batt.c
+++ b/x11/lxpanel/files/patch-src__plugins__batt__batt.c
@@ -1,7 +1,9 @@
---- src/plugins/batt/batt.c.orig 2012-05-20 09:57:39.000000000 -0400
-+++ src/plugins/batt/batt.c 2012-09-05 13:18:22.428078608 -0400
-@@ -71,7 +71,7 @@
- GdkPixmap *pixmap;
+diff --git src/plugins/batt/batt.c src/plugins/batt/batt.c
+index d288132..6088c53 100644
+--- src/plugins/batt/batt.c
++++ src/plugins/batt/batt.c
+@@ -68,7 +68,7 @@ typedef struct {
+ cairo_surface_t *pixmap;
GtkWidget *drawingArea;
int orientation;
- unsigned int alarmTime,
@@ -9,7 +11,7 @@
border,
height,
length,
-@@ -120,16 +120,16 @@
+@@ -118,7 +118,6 @@ void update_display(lx_battery *lx_b, gboolean repaint) {
char tooltip[ 256 ];
battery *b = lx_b->b;
/* unit: mW */
@@ -17,18 +19,21 @@
gboolean isCharging;
if (! lx_b->pixmap )
- return;
+@@ -128,9 +127,12 @@ void update_display(lx_battery *lx_b, gboolean repaint) {
+ cairo_set_line_width (cr, 1.0);
/* no battery is found */
- if( b == NULL )
+ if( b == NULL || b->percentage < 0 )
{
gtk_widget_set_tooltip_text( lx_b->drawingArea, _("No batteries found") );
-+ gdk_draw_rectangle(lx_b->pixmap, lx_b->bg, TRUE, 0, 0, lx_b->width, lx_b->height);
++ gdk_cairo_set_source_color(cr, &lx_b->background);
++ cairo_rectangle(cr, 0, 0, lx_b->width, lx_b->height);
++ cairo_fill(cr);
return;
}
-@@ -138,12 +138,11 @@
+@@ -141,12 +143,11 @@ void update_display(lx_battery *lx_b, gboolean repaint) {
/* fixme: only one battery supported */
@@ -43,7 +48,7 @@
{
/* Shrug this should be done using glibs process functions */
/* Alarms should not run concurrently; determine whether an alarm is
-@@ -173,7 +172,7 @@
+@@ -176,7 +177,7 @@ void update_display(lx_battery *lx_b, gboolean repaint) {
int left_seconds = b->seconds - 3600 * hours;
int minutes = left_seconds / 60;
snprintf(tooltip, 256,
@@ -52,7 +57,7 @@
lx_b->b->percentage,
hours,
minutes );
-@@ -184,10 +183,10 @@
+@@ -187,10 +188,10 @@ void update_display(lx_battery *lx_b, gboolean repaint) {
int left_seconds = b->seconds - 3600 * hours;
int minutes = left_seconds / 60;
snprintf(tooltip, 256,
@@ -66,7 +71,7 @@
} else {
snprintf(tooltip, 256,
_("Battery: %d%% charged"),
-@@ -367,7 +366,7 @@
+@@ -375,7 +376,7 @@ constructor(Plugin *p, char **fp)
= lx_b->dischargingColor1 = lx_b->dischargingColor2 = NULL;
/* Set default values for integers */
@@ -75,7 +80,7 @@
lx_b->requestedBorder = 1;
line s;
-@@ -396,8 +395,8 @@
+@@ -404,8 +405,8 @@ constructor(Plugin *p, char **fp)
lx_b->dischargingColor1 = g_strdup(s.t[1]);
else if (!g_ascii_strcasecmp(s.t[0], "DischargingColor2"))
lx_b->dischargingColor2 = g_strdup(s.t[1]);
@@ -86,7 +91,7 @@
else if (!g_ascii_strcasecmp(s.t[0], "BorderWidth"))
lx_b->requestedBorder = atoi(s.t[1]);
else if (!g_ascii_strcasecmp(s.t[0], "Size")) {
-@@ -573,7 +572,7 @@
+@@ -554,7 +555,7 @@ static void config(Plugin *p, GtkWindow* parent) {
_("Hide if there is no battery"), &b->hide_if_no_battery, CONF_TYPE_BOOL,
#endif
_("Alarm command"), &b->alarmCommand, CONF_TYPE_STR,
@@ -95,7 +100,7 @@
_("Background color"), &b->backgroundColor, CONF_TYPE_STR,
_("Charging color 1"), &b->chargingColor1, CONF_TYPE_STR,
_("Charging color 2"), &b->chargingColor2, CONF_TYPE_STR,
-@@ -593,7 +592,7 @@
+@@ -574,7 +575,7 @@ static void save(Plugin* p, FILE* fp) {
lxpanel_put_bool(fp, "HideIfNoBattery",lx_b->hide_if_no_battery);
lxpanel_put_str(fp, "AlarmCommand", lx_b->alarmCommand);
diff --git a/x11/lxpanel/pkg-plist b/x11/lxpanel/pkg-plist
index 22a80f059471..68131b07795d 100644
--- a/x11/lxpanel/pkg-plist
+++ b/x11/lxpanel/pkg-plist
@@ -42,88 +42,136 @@ include/lxpanel/plugin.h
%%DATADIR%%/images/volume-low.png
%%DATADIR%%/images/volume-medium.png
%%DATADIR%%/images/window-manager.png
+%%DATADIR%%/images/xkb-flags/ad.png
%%DATADIR%%/images/xkb-flags/ae.png
+%%DATADIR%%/images/xkb-flags/af.png
+%%DATADIR%%/images/xkb-flags/al.png
%%DATADIR%%/images/xkb-flags/am.png
%%DATADIR%%/images/xkb-flags/ar.png
+%%DATADIR%%/images/xkb-flags/ara.png
%%DATADIR%%/images/xkb-flags/at.png
%%DATADIR%%/images/xkb-flags/az.png
+%%DATADIR%%/images/xkb-flags/ba.png
+%%DATADIR%%/images/xkb-flags/bd.png
%%DATADIR%%/images/xkb-flags/be.png
+%%DATADIR%%/images/xkb-flags/ben.png
%%DATADIR%%/images/xkb-flags/bg.png
%%DATADIR%%/images/xkb-flags/bh.png
%%DATADIR%%/images/xkb-flags/br.png
+%%DATADIR%%/images/xkb-flags/brai.png
+%%DATADIR%%/images/xkb-flags/bt.png
+%%DATADIR%%/images/xkb-flags/bw.png
%%DATADIR%%/images/xkb-flags/by.png
%%DATADIR%%/images/xkb-flags/ca.png
+%%DATADIR%%/images/xkb-flags/cd.png
%%DATADIR%%/images/xkb-flags/ch.png
+%%DATADIR%%/images/xkb-flags/cm.png
+%%DATADIR%%/images/xkb-flags/cn.png
%%DATADIR%%/images/xkb-flags/cu.png
%%DATADIR%%/images/xkb-flags/cz.png
%%DATADIR%%/images/xkb-flags/de.png
+%%DATADIR%%/images/xkb-flags/dev.png
%%DATADIR%%/images/xkb-flags/dj.png
%%DATADIR%%/images/xkb-flags/dk.png
+%%DATADIR%%/images/xkb-flags/dvorak.png
%%DATADIR%%/images/xkb-flags/dz.png
%%DATADIR%%/images/xkb-flags/ee.png
%%DATADIR%%/images/xkb-flags/eg.png
+%%DATADIR%%/images/xkb-flags/epo.png
%%DATADIR%%/images/xkb-flags/es.png
-%%DATADIR%%/images/xkb-flags/eu.png
+%%DATADIR%%/images/xkb-flags/et.png
%%DATADIR%%/images/xkb-flags/fi.png
+%%DATADIR%%/images/xkb-flags/fo.png
%%DATADIR%%/images/xkb-flags/fr.png
+%%DATADIR%%/images/xkb-flags/gb.png
%%DATADIR%%/images/xkb-flags/ge.png
+%%DATADIR%%/images/xkb-flags/gh.png
+%%DATADIR%%/images/xkb-flags/gn.png
%%DATADIR%%/images/xkb-flags/gr.png
%%DATADIR%%/images/xkb-flags/hr.png
%%DATADIR%%/images/xkb-flags/hu.png
+%%DATADIR%%/images/xkb-flags/ie.png
%%DATADIR%%/images/xkb-flags/il.png
+%%DATADIR%%/images/xkb-flags/in.png
%%DATADIR%%/images/xkb-flags/iq.png
+%%DATADIR%%/images/xkb-flags/ir.png
%%DATADIR%%/images/xkb-flags/is.png
%%DATADIR%%/images/xkb-flags/it.png
%%DATADIR%%/images/xkb-flags/jo.png
%%DATADIR%%/images/xkb-flags/jp.png
+%%DATADIR%%/images/xkb-flags/ke.png
+%%DATADIR%%/images/xkb-flags/kg.png
+%%DATADIR%%/images/xkb-flags/kh.png
%%DATADIR%%/images/xkb-flags/km.png
+%%DATADIR%%/images/xkb-flags/kp.png
%%DATADIR%%/images/xkb-flags/kr.png
%%DATADIR%%/images/xkb-flags/kw.png
+%%DATADIR%%/images/xkb-flags/kz.png
%%DATADIR%%/images/xkb-flags/la.png
+%%DATADIR%%/images/xkb-flags/latam.png
%%DATADIR%%/images/xkb-flags/lb.png
+%%DATADIR%%/images/xkb-flags/lk.png
%%DATADIR%%/images/xkb-flags/lt.png
+%%DATADIR%%/images/xkb-flags/lv.png
%%DATADIR%%/images/xkb-flags/ly.png
%%DATADIR%%/images/xkb-flags/ma.png
+%%DATADIR%%/images/xkb-flags/mao.png
+%%DATADIR%%/images/xkb-flags/me.png
%%DATADIR%%/images/xkb-flags/mk.png
+%%DATADIR%%/images/xkb-flags/ml.png
+%%DATADIR%%/images/xkb-flags/mm.png
%%DATADIR%%/images/xkb-flags/mn.png
+%%DATADIR%%/images/xkb-flags/mt.png
+%%DATADIR%%/images/xkb-flags/mv.png
%%DATADIR%%/images/xkb-flags/mx.png
+%%DATADIR%%/images/xkb-flags/nec_vndr-jp.png
+%%DATADIR%%/images/xkb-flags/ng.png
%%DATADIR%%/images/xkb-flags/nl.png
%%DATADIR%%/images/xkb-flags/no.png
+%%DATADIR%%/images/xkb-flags/np.png
%%DATADIR%%/images/xkb-flags/om.png
+%%DATADIR%%/images/xkb-flags/ph.png
+%%DATADIR%%/images/xkb-flags/pk.png
%%DATADIR%%/images/xkb-flags/pl.png
-%%DATADIR%%/images/xkb-flags/ps.png
%%DATADIR%%/images/xkb-flags/pt.png
%%DATADIR%%/images/xkb-flags/qa.png
-%%DATADIR%%/images/xkb-flags/qc.png
%%DATADIR%%/images/xkb-flags/ro.png
+%%DATADIR%%/images/xkb-flags/rs.png
%%DATADIR%%/images/xkb-flags/ru.png
%%DATADIR%%/images/xkb-flags/sa.png
%%DATADIR%%/images/xkb-flags/sd.png
%%DATADIR%%/images/xkb-flags/se.png
%%DATADIR%%/images/xkb-flags/si.png
%%DATADIR%%/images/xkb-flags/sk.png
+%%DATADIR%%/images/xkb-flags/sn.png
%%DATADIR%%/images/xkb-flags/so.png
%%DATADIR%%/images/xkb-flags/sr.png
%%DATADIR%%/images/xkb-flags/sy.png
%%DATADIR%%/images/xkb-flags/th.png
+%%DATADIR%%/images/xkb-flags/tj.png
+%%DATADIR%%/images/xkb-flags/tm.png
%%DATADIR%%/images/xkb-flags/tn.png
%%DATADIR%%/images/xkb-flags/tr.png
+%%DATADIR%%/images/xkb-flags/tw.png
+%%DATADIR%%/images/xkb-flags/tz.png
%%DATADIR%%/images/xkb-flags/ua.png
-%%DATADIR%%/images/xkb-flags/uk.png
-%%DATADIR%%/images/xkb-flags/un.png
%%DATADIR%%/images/xkb-flags/us.png
%%DATADIR%%/images/xkb-flags/uy.png
+%%DATADIR%%/images/xkb-flags/uz.png
%%DATADIR%%/images/xkb-flags/vn.png
%%DATADIR%%/images/xkb-flags/ye.png
-%%DATADIR%%/images/xkb-flags/yu.png
-%%DATADIR%%/ui/launchbar.ui
-%%DATADIR%%/ui/netstatus.ui
-%%DATADIR%%/ui/panel-pref.ui
+%%DATADIR%%/images/xkb-flags/za.png
%%DATADIR%%/profile/default/config
%%DATADIR%%/profile/default/panels/panel
%%DATADIR%%/profile/two_panels/config
%%DATADIR%%/profile/two_panels/panels/bottom
%%DATADIR%%/profile/two_panels/panels/top
+%%DATADIR%%/ui/launchbar.ui
+%%DATADIR%%/ui/netstatus.ui
+%%DATADIR%%/ui/panel-pref.ui
+%%DATADIR%%/xkeyboardconfig/layouts.cfg
+%%DATADIR%%/xkeyboardconfig/models.cfg
+%%DATADIR%%/xkeyboardconfig/toggle.cfg
%%NLS%%share/locale/af/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/ar/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/be/LC_MESSAGES/lxpanel.mo
@@ -153,10 +201,10 @@ include/lxpanel/plugin.h
%%NLS%%share/locale/it/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/ja/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/kk/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/km/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/lg/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/ml/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/ms/LC_MESSAGES/lxpanel.mo
%%NLS%%share/locale/nb/LC_MESSAGES/lxpanel.mo
@@ -193,8 +241,11 @@ include/lxpanel/plugin.h
@dirrm %%DATADIR%%/profile/two_panels
@dirrm %%DATADIR%%/profile
@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%/xkeyboardconfig
@dirrm %%DATADIR%%
@dirrm include/lxpanel
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/es_VE/LC_MESSAGES
@dirrmtry share/locale/es_VE
@dirrmtry share/locale/fo/LC_MESSAGES
@@ -207,8 +258,8 @@ include/lxpanel/plugin.h
@dirrmtry share/locale/km
@dirrmtry share/locale/lg/LC_MESSAGES
@dirrmtry share/locale/lg
-@dirrmtry share/locale/nn/LC_MESSAGES
-@dirrmtry share/locale/nn
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/te/LC_MESSAGES
@@ -217,8 +268,9 @@ include/lxpanel/plugin.h
@dirrmtry share/locale/tt_RU
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
@dirrmtry share/locale/ur_PK/LC_MESSAGES
@dirrmtry share/locale/ur_PK
@dirrmtry lib/lxpanel/plugins
@dirrmtry lib/lxpanel
-@dirrmtry lib/pkgconfig