aboutsummaryrefslogtreecommitdiff
path: root/x11/mate-desktop
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /x11/mate-desktop
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'x11/mate-desktop')
-rw-r--r--x11/mate-desktop/Makefile55
-rw-r--r--x11/mate-desktop/distinfo2
-rw-r--r--x11/mate-desktop/pkg-descr3
-rw-r--r--x11/mate-desktop/pkg-plist232
4 files changed, 292 insertions, 0 deletions
diff --git a/x11/mate-desktop/Makefile b/x11/mate-desktop/Makefile
new file mode 100644
index 000000000000..a797a0b8fe9a
--- /dev/null
+++ b/x11/mate-desktop/Makefile
@@ -0,0 +1,55 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-desktop
+PORTVERSION= 1.6.1
+CATEGORIES= x11 mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Additional UI API for MATE
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
+
+PORTSCOUT= limitw:1,even
+
+USES= bison gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= docutils
+USE_XORG= x11 xrandr
+USE_GNOME= gnomehier gdkpixbuf2 glib20 gtk20 intlhack ltverhack
+USE_PYTHON= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0 \
+ --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc \
+ --disable-desktop-docs
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.mate.accessibility-keyboard.gschema.xml \
+ org.mate.accessibility-startup.gschema.xml \
+ org.mate.applications-at-mobility.gschema.xml \
+ org.mate.applications-at-visual.gschema.xml \
+ org.mate.applications-browser.gschema.xml \
+ org.mate.applications-office.gschema.xml \
+ org.mate.applications-terminal.gschema.xml \
+ org.mate.background.gschema.xml \
+ org.mate.file-views.gschema.xml \
+ org.mate.interface.gschema.xml \
+ org.mate.lockdown.gschema.xml \
+ org.mate.peripherals-keyboard.gschema.xml \
+ org.mate.peripherals-mouse.gschema.xml \
+ org.mate.sound.gschema.xml \
+ org.mate.thumbnail-cache.gschema.xml \
+ org.mate.thumbnailers.gschema.xml \
+ org.mate.typing-break.gschema.xml
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmate-desktop-2.so.17
+
+.include <bsd.port.mk>
diff --git a/x11/mate-desktop/distinfo b/x11/mate-desktop/distinfo
new file mode 100644
index 000000000000..6fa0d999d3b8
--- /dev/null
+++ b/x11/mate-desktop/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-desktop-1.6.1.tar.xz) = fe65f4035fe74510e6f35df0c0e29cbf8a6501852adc3971773d0072b914aed5
+SIZE (mate/mate-desktop-1.6.1.tar.xz) = 832720
diff --git a/x11/mate-desktop/pkg-descr b/x11/mate-desktop/pkg-descr
new file mode 100644
index 000000000000..e4eba5b7a4a1
--- /dev/null
+++ b/x11/mate-desktop/pkg-descr
@@ -0,0 +1,3 @@
+This is a collection of APIs not included in libmateui.
+
+WWW: http://mate-desktop.org/
diff --git a/x11/mate-desktop/pkg-plist b/x11/mate-desktop/pkg-plist
new file mode 100644
index 000000000000..70c156cc6e77
--- /dev/null
+++ b/x11/mate-desktop/pkg-plist
@@ -0,0 +1,232 @@
+bin/mate-about
+include/mate-desktop-2.0/libmate/mate-desktop-item.h
+include/mate-desktop-2.0/libmate/mate-desktop-utils.h
+include/mate-desktop-2.0/libmateui/mate-bg-crossfade.h
+include/mate-desktop-2.0/libmateui/mate-bg.h
+include/mate-desktop-2.0/libmateui/mate-desktop-thumbnail.h
+include/mate-desktop-2.0/libmateui/mate-rr-config.h
+include/mate-desktop-2.0/libmateui/mate-rr-labeler.h
+include/mate-desktop-2.0/libmateui/mate-rr.h
+lib/libmate-desktop-2.a
+lib/libmate-desktop-2.la
+lib/libmate-desktop-2.so
+lib/libmate-desktop-2.so.17
+libdata/pkgconfig/mate-desktop-2.0.pc
+man/man1/mate-about.1.gz
+share/MateConf/gsettings/mate-desktop.convert
+share/applications/mate-about.desktop
+%%DOCSDIR%%/MateBG.html
+%%DOCSDIR%%/MateDesktopItem.html
+%%DOCSDIR%%/MateDesktopThumbnailFactory.html
+%%DOCSDIR%%/MateRRLabeler.html
+%%DOCSDIR%%/background.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/intro.html
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/libmate.html
+%%DOCSDIR%%/mate-desktop-Miscellaneous-Functions.html
+%%DOCSDIR%%/mate-desktop-Miscellaneous-Thumbnail-Functions.html
+%%DOCSDIR%%/mate-desktop-mate-rr-config.html
+%%DOCSDIR%%/mate-desktop-mate-rr-crtc.html
+%%DOCSDIR%%/mate-desktop-mate-rr-mode.html
+%%DOCSDIR%%/mate-desktop-mate-rr-output.html
+%%DOCSDIR%%/mate-desktop-mate-rr-screen.html
+%%DOCSDIR%%/mate-desktop.devhelp2
+%%DOCSDIR%%/randr.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/thumbnail.html
+%%DOCSDIR%%/up.png
+share/libmate-desktop/pnp.ids
+share/locale/af/LC_MESSAGES/mate-desktop.mo
+share/locale/am/LC_MESSAGES/mate-desktop.mo
+share/locale/an/LC_MESSAGES/mate-desktop.mo
+share/locale/ar/LC_MESSAGES/mate-desktop.mo
+share/locale/as/LC_MESSAGES/mate-desktop.mo
+share/locale/ast/LC_MESSAGES/mate-desktop.mo
+share/locale/az/LC_MESSAGES/mate-desktop.mo
+share/locale/be/LC_MESSAGES/mate-desktop.mo
+share/locale/be@latin/LC_MESSAGES/mate-desktop.mo
+share/locale/bg/LC_MESSAGES/mate-desktop.mo
+share/locale/bn/LC_MESSAGES/mate-desktop.mo
+share/locale/bn_IN/LC_MESSAGES/mate-desktop.mo
+share/locale/br/LC_MESSAGES/mate-desktop.mo
+share/locale/bs/LC_MESSAGES/mate-desktop.mo
+share/locale/ca/LC_MESSAGES/mate-desktop.mo
+share/locale/ca@valencia/LC_MESSAGES/mate-desktop.mo
+share/locale/crh/LC_MESSAGES/mate-desktop.mo
+share/locale/cs/LC_MESSAGES/mate-desktop.mo
+share/locale/cy/LC_MESSAGES/mate-desktop.mo
+share/locale/da/LC_MESSAGES/mate-desktop.mo
+share/locale/de/LC_MESSAGES/mate-desktop.mo
+share/locale/dz/LC_MESSAGES/mate-desktop.mo
+share/locale/el/LC_MESSAGES/mate-desktop.mo
+share/locale/en@shaw/LC_MESSAGES/mate-desktop.mo
+share/locale/en_AU/LC_MESSAGES/mate-desktop.mo
+share/locale/en_CA/LC_MESSAGES/mate-desktop.mo
+share/locale/en_GB/LC_MESSAGES/mate-desktop.mo
+share/locale/eo/LC_MESSAGES/mate-desktop.mo
+share/locale/es/LC_MESSAGES/mate-desktop.mo
+share/locale/et/LC_MESSAGES/mate-desktop.mo
+share/locale/eu/LC_MESSAGES/mate-desktop.mo
+share/locale/fa/LC_MESSAGES/mate-desktop.mo
+share/locale/fi/LC_MESSAGES/mate-desktop.mo
+share/locale/fr/LC_MESSAGES/mate-desktop.mo
+share/locale/fur/LC_MESSAGES/mate-desktop.mo
+share/locale/ga/LC_MESSAGES/mate-desktop.mo
+share/locale/gl/LC_MESSAGES/mate-desktop.mo
+share/locale/gu/LC_MESSAGES/mate-desktop.mo
+share/locale/he/LC_MESSAGES/mate-desktop.mo
+share/locale/hi/LC_MESSAGES/mate-desktop.mo
+share/locale/hr/LC_MESSAGES/mate-desktop.mo
+share/locale/hu/LC_MESSAGES/mate-desktop.mo
+share/locale/hy/LC_MESSAGES/mate-desktop.mo
+share/locale/ia/LC_MESSAGES/mate-desktop.mo
+share/locale/id/LC_MESSAGES/mate-desktop.mo
+share/locale/ig/LC_MESSAGES/mate-desktop.mo
+share/locale/is/LC_MESSAGES/mate-desktop.mo
+share/locale/it/LC_MESSAGES/mate-desktop.mo
+share/locale/ja/LC_MESSAGES/mate-desktop.mo
+share/locale/ka/LC_MESSAGES/mate-desktop.mo
+share/locale/kk/LC_MESSAGES/mate-desktop.mo
+share/locale/kn/LC_MESSAGES/mate-desktop.mo
+share/locale/ko/LC_MESSAGES/mate-desktop.mo
+share/locale/ku/LC_MESSAGES/mate-desktop.mo
+share/locale/ky/LC_MESSAGES/mate-desktop.mo
+share/locale/li/LC_MESSAGES/mate-desktop.mo
+share/locale/lo/LC_MESSAGES/mate-desktop.mo
+share/locale/lt/LC_MESSAGES/mate-desktop.mo
+share/locale/lv/LC_MESSAGES/mate-desktop.mo
+share/locale/mai/LC_MESSAGES/mate-desktop.mo
+share/locale/mg/LC_MESSAGES/mate-desktop.mo
+share/locale/mi/LC_MESSAGES/mate-desktop.mo
+share/locale/mk/LC_MESSAGES/mate-desktop.mo
+share/locale/ml/LC_MESSAGES/mate-desktop.mo
+share/locale/mn/LC_MESSAGES/mate-desktop.mo
+share/locale/mr/LC_MESSAGES/mate-desktop.mo
+share/locale/ms/LC_MESSAGES/mate-desktop.mo
+share/locale/nb/LC_MESSAGES/mate-desktop.mo
+share/locale/nds/LC_MESSAGES/mate-desktop.mo
+share/locale/ne/LC_MESSAGES/mate-desktop.mo
+share/locale/nl/LC_MESSAGES/mate-desktop.mo
+share/locale/nn/LC_MESSAGES/mate-desktop.mo
+share/locale/nso/LC_MESSAGES/mate-desktop.mo
+share/locale/oc/LC_MESSAGES/mate-desktop.mo
+share/locale/or/LC_MESSAGES/mate-desktop.mo
+share/locale/pa/LC_MESSAGES/mate-desktop.mo
+share/locale/pl/LC_MESSAGES/mate-desktop.mo
+share/locale/ps/LC_MESSAGES/mate-desktop.mo
+share/locale/pt/LC_MESSAGES/mate-desktop.mo
+share/locale/pt_BR/LC_MESSAGES/mate-desktop.mo
+share/locale/ro/LC_MESSAGES/mate-desktop.mo
+share/locale/ru/LC_MESSAGES/mate-desktop.mo
+share/locale/rw/LC_MESSAGES/mate-desktop.mo
+share/locale/si/LC_MESSAGES/mate-desktop.mo
+share/locale/sk/LC_MESSAGES/mate-desktop.mo
+share/locale/sl/LC_MESSAGES/mate-desktop.mo
+share/locale/sq/LC_MESSAGES/mate-desktop.mo
+share/locale/sr/LC_MESSAGES/mate-desktop.mo
+share/locale/sr@latin/LC_MESSAGES/mate-desktop.mo
+share/locale/sv/LC_MESSAGES/mate-desktop.mo
+share/locale/ta/LC_MESSAGES/mate-desktop.mo
+share/locale/te/LC_MESSAGES/mate-desktop.mo
+share/locale/th/LC_MESSAGES/mate-desktop.mo
+share/locale/tk/LC_MESSAGES/mate-desktop.mo
+share/locale/tr/LC_MESSAGES/mate-desktop.mo
+share/locale/ug/LC_MESSAGES/mate-desktop.mo
+share/locale/uk/LC_MESSAGES/mate-desktop.mo
+share/locale/ur/LC_MESSAGES/mate-desktop.mo
+share/locale/uz/LC_MESSAGES/mate-desktop.mo
+share/locale/uz@cyrillic/LC_MESSAGES/mate-desktop.mo
+share/locale/vi/LC_MESSAGES/mate-desktop.mo
+share/locale/wa/LC_MESSAGES/mate-desktop.mo
+share/locale/xh/LC_MESSAGES/mate-desktop.mo
+share/locale/yi/LC_MESSAGES/mate-desktop.mo
+share/locale/yo/LC_MESSAGES/mate-desktop.mo
+share/locale/zh_CN/LC_MESSAGES/mate-desktop.mo
+share/locale/zh_HK/LC_MESSAGES/mate-desktop.mo
+share/locale/zh_TW/LC_MESSAGES/mate-desktop.mo
+share/locale/zu/LC_MESSAGES/mate-desktop.mo
+share/mate-about/mate-version.xml
+@dirrm share/mate-about
+@dirrmtry share/locale/zu/LC_MESSAGES
+@dirrmtry share/locale/zu
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/yo/LC_MESSAGES
+@dirrmtry share/locale/yo
+@dirrmtry share/locale/yi/LC_MESSAGES
+@dirrmtry share/locale/yi
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/nso/LC_MESSAGES
+@dirrmtry share/locale/nso
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mi/LC_MESSAGES
+@dirrmtry share/locale/mi
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/lo/LC_MESSAGES
+@dirrmtry share/locale/lo
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/ig/LC_MESSAGES
+@dirrmtry share/locale/ig
+@dirrmtry share/locale/ia/LC_MESSAGES
+@dirrmtry share/locale/ia
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/crh/LC_MESSAGES
+@dirrmtry share/locale/crh
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
+@dirrmtry share/locale/an/LC_MESSAGES
+@dirrmtry share/locale/an
+@dirrm share/libmate-desktop
+@dirrm %%DOCSDIR%%
+@dirrm include/mate-desktop-2.0/libmateui
+@dirrm include/mate-desktop-2.0/libmate
+@dirrm include/mate-desktop-2.0