aboutsummaryrefslogtreecommitdiff
path: root/x11/mate-session-manager
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /x11/mate-session-manager
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'x11/mate-session-manager')
-rw-r--r--x11/mate-session-manager/Makefile36
-rw-r--r--x11/mate-session-manager/distinfo2
-rw-r--r--x11/mate-session-manager/files/patch-mate-session_gsm-autostart-app.c10
-rw-r--r--x11/mate-session-manager/pkg-descr4
-rw-r--r--x11/mate-session-manager/pkg-plist187
5 files changed, 239 insertions, 0 deletions
diff --git a/x11/mate-session-manager/Makefile b/x11/mate-session-manager/Makefile
new file mode 100644
index 000000000000..225753401ff7
--- /dev/null
+++ b/x11/mate-session-manager/Makefile
@@ -0,0 +1,36 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-session-manager
+PORTVERSION= 1.6.1
+CATEGORIES= x11 mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Session component for the MATE desktop
+
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libupower-glib.so:${PORTSDIR}/sysutils/upower \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+RUN_DEPENDS= ${LOCALBASE}/sbin/console-kit-daemon:${PORTSDIR}/sysutils/consolekit \
+ ${LOCALBASE}/bin/xdpyinfo:${PORTSDIR}/x11/xdpyinfo
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= settingsdaemon
+USE_XORG= ice sm xau xext xrandr xrender xtrans xtst
+USE_GNOME= glib20 gnomehier gtk20 intlhack librsvg2 libxslt pango
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-docbook-docs \
+ --with-gtk=2.0 \
+ --with-systemd=no
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.mate.session.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/x11/mate-session-manager/distinfo b/x11/mate-session-manager/distinfo
new file mode 100644
index 000000000000..dd729c45aaf0
--- /dev/null
+++ b/x11/mate-session-manager/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-session-manager-1.6.1.tar.xz) = 4ee7b4ae18df5becd986b05634428edf0ad8de150a14dc29848b6d34ab312ce9
+SIZE (mate/mate-session-manager-1.6.1.tar.xz) = 641524
diff --git a/x11/mate-session-manager/files/patch-mate-session_gsm-autostart-app.c b/x11/mate-session-manager/files/patch-mate-session_gsm-autostart-app.c
new file mode 100644
index 000000000000..f7e5285d5206
--- /dev/null
+++ b/x11/mate-session-manager/files/patch-mate-session_gsm-autostart-app.c
@@ -0,0 +1,10 @@
+--- mate-session/gsm-autostart-app.c.orig 2008-08-20 14:18:52.000000000 -0400
++++ mate-session/gsm-autostart-app.c 2008-08-20 14:19:02.000000000 -0400
+@@ -25,6 +25,7 @@
+ #include <string.h>
+ #include <sys/wait.h>
+ #include <errno.h>
++#include <signal.h>
+
+ #include <glib.h>
+ #include <gio/gio.h>
diff --git a/x11/mate-session-manager/pkg-descr b/x11/mate-session-manager/pkg-descr
new file mode 100644
index 000000000000..05005ed2b0c0
--- /dev/null
+++ b/x11/mate-session-manager/pkg-descr
@@ -0,0 +1,4 @@
+This provides session management for the MATE desktop, and
+provides the tools used to start the desktop.
+
+WWW: http://mate-desktop.org/
diff --git a/x11/mate-session-manager/pkg-plist b/x11/mate-session-manager/pkg-plist
new file mode 100644
index 000000000000..316e38d6df3f
--- /dev/null
+++ b/x11/mate-session-manager/pkg-plist
@@ -0,0 +1,187 @@
+bin/mate-session
+bin/mate-session-properties
+bin/mate-session-save
+bin/mate-wm
+man/man1/mate-session-properties.1.gz
+man/man1/mate-session-save.1.gz
+man/man1/mate-session.1.gz
+man/man1/mate-wm.1.gz
+share/MateConf/gsettings/mate-session.convert
+share/applications/mate-session-properties.desktop
+share/icons/hicolor/16x16/apps/mate-session-properties.png
+share/icons/hicolor/22x22/apps/mate-session-properties.png
+share/icons/hicolor/24x24/apps/mate-session-properties.png
+share/icons/hicolor/32x32/apps/mate-session-properties.png
+share/icons/hicolor/48x48/apps/mate-session-properties.png
+share/icons/hicolor/scalable/apps/mate-session-properties.svg
+share/locale/af/LC_MESSAGES/mate-session-manager.mo
+share/locale/am/LC_MESSAGES/mate-session-manager.mo
+share/locale/ar/LC_MESSAGES/mate-session-manager.mo
+share/locale/as/LC_MESSAGES/mate-session-manager.mo
+share/locale/ast/LC_MESSAGES/mate-session-manager.mo
+share/locale/az/LC_MESSAGES/mate-session-manager.mo
+share/locale/be/LC_MESSAGES/mate-session-manager.mo
+share/locale/be@latin/LC_MESSAGES/mate-session-manager.mo
+share/locale/bg/LC_MESSAGES/mate-session-manager.mo
+share/locale/bn/LC_MESSAGES/mate-session-manager.mo
+share/locale/bn_IN/LC_MESSAGES/mate-session-manager.mo
+share/locale/br/LC_MESSAGES/mate-session-manager.mo
+share/locale/bs/LC_MESSAGES/mate-session-manager.mo
+share/locale/ca/LC_MESSAGES/mate-session-manager.mo
+share/locale/ca@valencia/LC_MESSAGES/mate-session-manager.mo
+share/locale/crh/LC_MESSAGES/mate-session-manager.mo
+share/locale/cs/LC_MESSAGES/mate-session-manager.mo
+share/locale/cy/LC_MESSAGES/mate-session-manager.mo
+share/locale/da/LC_MESSAGES/mate-session-manager.mo
+share/locale/de/LC_MESSAGES/mate-session-manager.mo
+share/locale/dz/LC_MESSAGES/mate-session-manager.mo
+share/locale/el/LC_MESSAGES/mate-session-manager.mo
+share/locale/en@shaw/LC_MESSAGES/mate-session-manager.mo
+share/locale/en_CA/LC_MESSAGES/mate-session-manager.mo
+share/locale/en_GB/LC_MESSAGES/mate-session-manager.mo
+share/locale/eo/LC_MESSAGES/mate-session-manager.mo
+share/locale/es/LC_MESSAGES/mate-session-manager.mo
+share/locale/et/LC_MESSAGES/mate-session-manager.mo
+share/locale/eu/LC_MESSAGES/mate-session-manager.mo
+share/locale/fa/LC_MESSAGES/mate-session-manager.mo
+share/locale/fi/LC_MESSAGES/mate-session-manager.mo
+share/locale/fr/LC_MESSAGES/mate-session-manager.mo
+share/locale/fur/LC_MESSAGES/mate-session-manager.mo
+share/locale/fy/LC_MESSAGES/mate-session-manager.mo
+share/locale/ga/LC_MESSAGES/mate-session-manager.mo
+share/locale/gl/LC_MESSAGES/mate-session-manager.mo
+share/locale/gu/LC_MESSAGES/mate-session-manager.mo
+share/locale/ha/LC_MESSAGES/mate-session-manager.mo
+share/locale/he/LC_MESSAGES/mate-session-manager.mo
+share/locale/hi/LC_MESSAGES/mate-session-manager.mo
+share/locale/hr/LC_MESSAGES/mate-session-manager.mo
+share/locale/hu/LC_MESSAGES/mate-session-manager.mo
+share/locale/hy/LC_MESSAGES/mate-session-manager.mo
+share/locale/id/LC_MESSAGES/mate-session-manager.mo
+share/locale/ig/LC_MESSAGES/mate-session-manager.mo
+share/locale/is/LC_MESSAGES/mate-session-manager.mo
+share/locale/it/LC_MESSAGES/mate-session-manager.mo
+share/locale/ja/LC_MESSAGES/mate-session-manager.mo
+share/locale/ka/LC_MESSAGES/mate-session-manager.mo
+share/locale/kn/LC_MESSAGES/mate-session-manager.mo
+share/locale/ko/LC_MESSAGES/mate-session-manager.mo
+share/locale/ku/LC_MESSAGES/mate-session-manager.mo
+share/locale/lt/LC_MESSAGES/mate-session-manager.mo
+share/locale/lv/LC_MESSAGES/mate-session-manager.mo
+share/locale/mai/LC_MESSAGES/mate-session-manager.mo
+share/locale/mg/LC_MESSAGES/mate-session-manager.mo
+share/locale/mi/LC_MESSAGES/mate-session-manager.mo
+share/locale/mk/LC_MESSAGES/mate-session-manager.mo
+share/locale/ml/LC_MESSAGES/mate-session-manager.mo
+share/locale/mn/LC_MESSAGES/mate-session-manager.mo
+share/locale/mr/LC_MESSAGES/mate-session-manager.mo
+share/locale/ms/LC_MESSAGES/mate-session-manager.mo
+share/locale/nb/LC_MESSAGES/mate-session-manager.mo
+share/locale/nds/LC_MESSAGES/mate-session-manager.mo
+share/locale/ne/LC_MESSAGES/mate-session-manager.mo
+share/locale/nl/LC_MESSAGES/mate-session-manager.mo
+share/locale/nn/LC_MESSAGES/mate-session-manager.mo
+share/locale/nso/LC_MESSAGES/mate-session-manager.mo
+share/locale/oc/LC_MESSAGES/mate-session-manager.mo
+share/locale/or/LC_MESSAGES/mate-session-manager.mo
+share/locale/pa/LC_MESSAGES/mate-session-manager.mo
+share/locale/pl/LC_MESSAGES/mate-session-manager.mo
+share/locale/ps/LC_MESSAGES/mate-session-manager.mo
+share/locale/pt/LC_MESSAGES/mate-session-manager.mo
+share/locale/pt_BR/LC_MESSAGES/mate-session-manager.mo
+share/locale/ro/LC_MESSAGES/mate-session-manager.mo
+share/locale/ru/LC_MESSAGES/mate-session-manager.mo
+share/locale/rw/LC_MESSAGES/mate-session-manager.mo
+share/locale/si/LC_MESSAGES/mate-session-manager.mo
+share/locale/sk/LC_MESSAGES/mate-session-manager.mo
+share/locale/sl/LC_MESSAGES/mate-session-manager.mo
+share/locale/sq/LC_MESSAGES/mate-session-manager.mo
+share/locale/sr/LC_MESSAGES/mate-session-manager.mo
+share/locale/sr@latin/LC_MESSAGES/mate-session-manager.mo
+share/locale/sv/LC_MESSAGES/mate-session-manager.mo
+share/locale/ta/LC_MESSAGES/mate-session-manager.mo
+share/locale/te/LC_MESSAGES/mate-session-manager.mo
+share/locale/th/LC_MESSAGES/mate-session-manager.mo
+share/locale/tk/LC_MESSAGES/mate-session-manager.mo
+share/locale/tr/LC_MESSAGES/mate-session-manager.mo
+share/locale/ug/LC_MESSAGES/mate-session-manager.mo
+share/locale/uk/LC_MESSAGES/mate-session-manager.mo
+share/locale/uz/LC_MESSAGES/mate-session-manager.mo
+share/locale/uz@cyrillic/LC_MESSAGES/mate-session-manager.mo
+share/locale/vi/LC_MESSAGES/mate-session-manager.mo
+share/locale/wa/LC_MESSAGES/mate-session-manager.mo
+share/locale/xh/LC_MESSAGES/mate-session-manager.mo
+share/locale/yo/LC_MESSAGES/mate-session-manager.mo
+share/locale/zh_CN/LC_MESSAGES/mate-session-manager.mo
+share/locale/zh_HK/LC_MESSAGES/mate-session-manager.mo
+share/locale/zh_TW/LC_MESSAGES/mate-session-manager.mo
+share/locale/zu/LC_MESSAGES/mate-session-manager.mo
+share/mate-session-manager/gsm-inhibit-dialog.ui
+share/mate-session-manager/session-properties.ui
+share/xsessions/mate.desktop
+@dirrmtry share/xsessions
+@dirrm share/mate-session-manager
+@dirrmtry share/locale/zu/LC_MESSAGES
+@dirrmtry share/locale/zu
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/yo/LC_MESSAGES
+@dirrmtry share/locale/yo
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/nso/LC_MESSAGES
+@dirrmtry share/locale/nso
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mi/LC_MESSAGES
+@dirrmtry share/locale/mi
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/ig/LC_MESSAGES
+@dirrmtry share/locale/ig
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/ha/LC_MESSAGES
+@dirrmtry share/locale/ha
+@dirrmtry share/locale/fy/LC_MESSAGES
+@dirrmtry share/locale/fy
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/crh/LC_MESSAGES
+@dirrmtry share/locale/crh
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as