aboutsummaryrefslogtreecommitdiff
path: root/x11/mate-terminal
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /x11/mate-terminal
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'x11/mate-terminal')
-rw-r--r--x11/mate-terminal/Makefile30
-rw-r--r--x11/mate-terminal/distinfo2
-rw-r--r--x11/mate-terminal/files/patch-configure.ac13
-rw-r--r--x11/mate-terminal/files/patch-src_terminal-screen.c98
-rw-r--r--x11/mate-terminal/files/patch-src_terminal.c11
-rw-r--r--x11/mate-terminal/pkg-descr3
-rw-r--r--x11/mate-terminal/pkg-plist288
7 files changed, 445 insertions, 0 deletions
diff --git a/x11/mate-terminal/Makefile b/x11/mate-terminal/Makefile
new file mode 100644
index 000000000000..fd1c24bc2bef
--- /dev/null
+++ b/x11/mate-terminal/Makefile
@@ -0,0 +1,30 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-terminal
+PORTVERSION= 1.6.1
+CATEGORIES= x11 mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Terminal component for the MATE Desktop
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= autogen common:build docutils intlhack
+USE_XORG= sm x11
+USE_GNOME= dconf glib20 gnomehier gtk20 vte
+INSTALLS_OMF= yes
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.*
+
+GLIB_SCHEMAS= org.mate.terminal.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/x11/mate-terminal/distinfo b/x11/mate-terminal/distinfo
new file mode 100644
index 000000000000..15d3065ca6a8
--- /dev/null
+++ b/x11/mate-terminal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-terminal-1.6.1.tar.xz) = ebcb1c323e9a5cae7f4ed0548b57de34f6ef3361d5b1bf6bc5921f5a49e0301b
+SIZE (mate/mate-terminal-1.6.1.tar.xz) = 1459056
diff --git a/x11/mate-terminal/files/patch-configure.ac b/x11/mate-terminal/files/patch-configure.ac
new file mode 100644
index 000000000000..131e4c85b69d
--- /dev/null
+++ b/x11/mate-terminal/files/patch-configure.ac
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2009-05-03 15:25:26.000000000 -0400
++++ configure.ac 2009-05-03 15:26:34.000000000 -0400
+@@ -96,6 +96,10 @@ AC_SUBST([GLIB_GENMARSHAL])
+ GLIB_MKENUMS="$($PKG_CONFIG --variable=glib_mkenums glib-2.0)"
+ AC_SUBST([GLIB_MKENUMS])
+
++AC_CHECK_LIB(util, kinfo_getfile,
++ [LIBS="${LIBS} -lutil"
++ AC_DEFINE(HAVE_KINFO_GETFILE, 1, [Define if you have the kinfo_getfile function])], [:])
++
+ AC_PATH_PROG([GTK_BUILDER_CONVERT],[gtk-builder-convert],[false])
+ if test "$GTK_BUILDER_CONVERT" = "false"; then
+ AC_MSG_ERROR([gtk-builder-convert not found])
diff --git a/x11/mate-terminal/files/patch-src_terminal-screen.c b/x11/mate-terminal/files/patch-src_terminal-screen.c
new file mode 100644
index 000000000000..7a078c72fe06
--- /dev/null
+++ b/x11/mate-terminal/files/patch-src_terminal-screen.c
@@ -0,0 +1,98 @@
+--- src/terminal-screen.c.orig 2012-07-27 16:58:59.000000000 -0500
++++ src/terminal-screen.c 2012-07-27 17:03:08.000000000 -0500
+@@ -18,6 +18,15 @@
+
+ #include <config.h>
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/sysctl.h>
++#include <sys/param.h>
++#include <sys/user.h>
++#ifdef HAVE_KINFO_GETFILE
++#include <libutil.h>
++#endif
++#endif
+ #include <string.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+@@ -190,16 +199,29 @@
+ static char *
+ cwd_of_pid (int pid)
+ {
++#ifndef __FreeBSD__
+ static const char patterns[][18] =
+ {
+ "/proc/%d/cwd", /* Linux */
+ "/proc/%d/path/cwd", /* Solaris >= 10 */
+ };
++#else
++#if __FreeBSD_version > 800018 || (__FreeBSD_version < 800000 && __FreeBSD_version >= 700104)
++ struct kinfo_file *freep, *kif;
++#ifndef HAVE_KINFO_GETFILE
++ size_t len;
++ int name[4];
++#else
++ int cnt;
++#endif /* HAVE_KINFO_GETFILE */
++#endif /* __FreeBSD_version > 800018 || (__FreeBSD_version < 800000 && __FreeBSD_version >= 700104) */
++#endif /* __FreeBSD__ */
+ guint i;
+
+ if (pid == -1)
+ return NULL;
+
++#ifndef __FreeBSD__
+ /* Try to get the working directory using various OS-specific mechanisms */
+ for (i = 0; i < G_N_ELEMENTS (patterns); ++i)
+ {
+@@ -237,6 +259,49 @@
+ return working_dir;
+ }
+ }
++#else
++ int fgpid = pid;
++#if __FreeBSD_version > 800018 || (__FreeBSD_version < 800000 && __FreeBSD_version >= 700104)
++#ifndef HAVE_KINFO_GETFILE
++ name[0] = CTL_KERN;
++ name[1] = KERN_PROC;
++ name[2] = KERN_PROC_FILEDESC;
++ name[3] = fgpid;
++
++ if (sysctl (name, 4, NULL, &len, NULL, 0) < 0)
++ return NULL;
++ freep = kif = g_malloc (len);
++ if (sysctl (name, 4, kif, &len, NULL, 0) < 0)
++ {
++ g_free (freep);
++ return NULL;
++ }
++#else
++ freep = kinfo_getfile (fgpid, &cnt);
++#endif /* HAVE_KINFO_GETFILE */
++
++#ifndef HAVE_KINFO_GETFILE
++ for (i = 0; i < len / sizeof (*kif); i++, kif++)
++ {
++ if (kif->kf_structsize != sizeof (*kif))
++ continue;
++#else
++ for (i = 0; i < cnt; i++)
++ {
++ kif = &freep[i];
++#endif /* HAVE_KINFO_GETFILE */
++ if (kif->kf_fd == KF_FD_TYPE_CWD)
++ {
++ char *working_dir;
++
++ working_dir = g_strdup (kif->kf_path);
++ g_free (freep);
++ return working_dir;
++ }
++ }
++ g_free (freep);
++#endif /* __FreeBSD_version > 800018 || (__FreeBSD_version < 800000 && __FreeBSD_version >= 700104) */
++#endif /* __FreeBSD__ */
+
+ return NULL;
+ }
diff --git a/x11/mate-terminal/files/patch-src_terminal.c b/x11/mate-terminal/files/patch-src_terminal.c
new file mode 100644
index 000000000000..ee7241e30ca0
--- /dev/null
+++ b/x11/mate-terminal/files/patch-src_terminal.c
@@ -0,0 +1,11 @@
+--- src/terminal.c.orig 2012-07-27 16:57:04.000000000 -0500
++++ src/terminal.c 2012-07-27 16:57:20.000000000 -0500
+@@ -598,7 +598,7 @@
+ data = g_new (OwnData, 1);
+ data->factory_name = get_factory_name_for_display (display_name);
+ data->options = options;
+- data->exit_code = -1;
++ data->exit_code = EXIT_SUCCESS;
+ data->argv = argv_copy;
+ data->argc = argc_copy;
+
diff --git a/x11/mate-terminal/pkg-descr b/x11/mate-terminal/pkg-descr
new file mode 100644
index 000000000000..93e461d3ff46
--- /dev/null
+++ b/x11/mate-terminal/pkg-descr
@@ -0,0 +1,3 @@
+Default terminal emulator for the MATE Desktop.
+
+WWW: http://mate-desktop.org/
diff --git a/x11/mate-terminal/pkg-plist b/x11/mate-terminal/pkg-plist
new file mode 100644
index 000000000000..aa2c3ecd00ca
--- /dev/null
+++ b/x11/mate-terminal/pkg-plist
@@ -0,0 +1,288 @@
+bin/mate-terminal
+man/man1/mate-terminal.1.gz
+share/applications/mate-terminal.desktop
+share/locale/am/LC_MESSAGES/mate-terminal.mo
+share/locale/ar/LC_MESSAGES/mate-terminal.mo
+share/locale/as/LC_MESSAGES/mate-terminal.mo
+share/locale/ast/LC_MESSAGES/mate-terminal.mo
+share/locale/az/LC_MESSAGES/mate-terminal.mo
+share/locale/be/LC_MESSAGES/mate-terminal.mo
+share/locale/be@latin/LC_MESSAGES/mate-terminal.mo
+share/locale/bg/LC_MESSAGES/mate-terminal.mo
+share/locale/bn/LC_MESSAGES/mate-terminal.mo
+share/locale/bn_IN/LC_MESSAGES/mate-terminal.mo
+share/locale/br/LC_MESSAGES/mate-terminal.mo
+share/locale/bs/LC_MESSAGES/mate-terminal.mo
+share/locale/ca/LC_MESSAGES/mate-terminal.mo
+share/locale/ca@valencia/LC_MESSAGES/mate-terminal.mo
+share/locale/cs/LC_MESSAGES/mate-terminal.mo
+share/locale/cy/LC_MESSAGES/mate-terminal.mo
+share/locale/da/LC_MESSAGES/mate-terminal.mo
+share/locale/de/LC_MESSAGES/mate-terminal.mo
+share/locale/dz/LC_MESSAGES/mate-terminal.mo
+share/locale/el/LC_MESSAGES/mate-terminal.mo
+share/locale/en@shaw/LC_MESSAGES/mate-terminal.mo
+share/locale/en_AU/LC_MESSAGES/mate-terminal.mo
+share/locale/en_CA/LC_MESSAGES/mate-terminal.mo
+share/locale/en_GB/LC_MESSAGES/mate-terminal.mo
+share/locale/eo/LC_MESSAGES/mate-terminal.mo
+share/locale/es/LC_MESSAGES/mate-terminal.mo
+share/locale/et/LC_MESSAGES/mate-terminal.mo
+share/locale/eu/LC_MESSAGES/mate-terminal.mo
+share/locale/fa/LC_MESSAGES/mate-terminal.mo
+share/locale/fi/LC_MESSAGES/mate-terminal.mo
+share/locale/fr/LC_MESSAGES/mate-terminal.mo
+share/locale/fur/LC_MESSAGES/mate-terminal.mo
+share/locale/ga/LC_MESSAGES/mate-terminal.mo
+share/locale/gl/LC_MESSAGES/mate-terminal.mo
+share/locale/gu/LC_MESSAGES/mate-terminal.mo
+share/locale/he/LC_MESSAGES/mate-terminal.mo
+share/locale/hi/LC_MESSAGES/mate-terminal.mo
+share/locale/hr/LC_MESSAGES/mate-terminal.mo
+share/locale/hu/LC_MESSAGES/mate-terminal.mo
+share/locale/hy/LC_MESSAGES/mate-terminal.mo
+share/locale/id/LC_MESSAGES/mate-terminal.mo
+share/locale/it/LC_MESSAGES/mate-terminal.mo
+share/locale/ja/LC_MESSAGES/mate-terminal.mo
+share/locale/ka/LC_MESSAGES/mate-terminal.mo
+share/locale/kk/LC_MESSAGES/mate-terminal.mo
+share/locale/kn/LC_MESSAGES/mate-terminal.mo
+share/locale/ko/LC_MESSAGES/mate-terminal.mo
+share/locale/ku/LC_MESSAGES/mate-terminal.mo
+share/locale/ky/LC_MESSAGES/mate-terminal.mo
+share/locale/lt/LC_MESSAGES/mate-terminal.mo
+share/locale/lv/LC_MESSAGES/mate-terminal.mo
+share/locale/mai/LC_MESSAGES/mate-terminal.mo
+share/locale/mg/LC_MESSAGES/mate-terminal.mo
+share/locale/mk/LC_MESSAGES/mate-terminal.mo
+share/locale/ml/LC_MESSAGES/mate-terminal.mo
+share/locale/mn/LC_MESSAGES/mate-terminal.mo
+share/locale/mr/LC_MESSAGES/mate-terminal.mo
+share/locale/ms/LC_MESSAGES/mate-terminal.mo
+share/locale/nb/LC_MESSAGES/mate-terminal.mo
+share/locale/nds/LC_MESSAGES/mate-terminal.mo
+share/locale/ne/LC_MESSAGES/mate-terminal.mo
+share/locale/nl/LC_MESSAGES/mate-terminal.mo
+share/locale/nn/LC_MESSAGES/mate-terminal.mo
+share/locale/oc/LC_MESSAGES/mate-terminal.mo
+share/locale/or/LC_MESSAGES/mate-terminal.mo
+share/locale/pa/LC_MESSAGES/mate-terminal.mo
+share/locale/pl/LC_MESSAGES/mate-terminal.mo
+share/locale/ps/LC_MESSAGES/mate-terminal.mo
+share/locale/pt/LC_MESSAGES/mate-terminal.mo
+share/locale/pt_BR/LC_MESSAGES/mate-terminal.mo
+share/locale/ro/LC_MESSAGES/mate-terminal.mo
+share/locale/ru/LC_MESSAGES/mate-terminal.mo
+share/locale/rw/LC_MESSAGES/mate-terminal.mo
+share/locale/si/LC_MESSAGES/mate-terminal.mo
+share/locale/sk/LC_MESSAGES/mate-terminal.mo
+share/locale/sl/LC_MESSAGES/mate-terminal.mo
+share/locale/sq/LC_MESSAGES/mate-terminal.mo
+share/locale/sr/LC_MESSAGES/mate-terminal.mo
+share/locale/sr@latin/LC_MESSAGES/mate-terminal.mo
+share/locale/sv/LC_MESSAGES/mate-terminal.mo
+share/locale/ta/LC_MESSAGES/mate-terminal.mo
+share/locale/te/LC_MESSAGES/mate-terminal.mo
+share/locale/th/LC_MESSAGES/mate-terminal.mo
+share/locale/tr/LC_MESSAGES/mate-terminal.mo
+share/locale/ug/LC_MESSAGES/mate-terminal.mo
+share/locale/uk/LC_MESSAGES/mate-terminal.mo
+share/locale/vi/LC_MESSAGES/mate-terminal.mo
+share/locale/wa/LC_MESSAGES/mate-terminal.mo
+share/locale/xh/LC_MESSAGES/mate-terminal.mo
+share/locale/zh_CN/LC_MESSAGES/mate-terminal.mo
+share/locale/zh_HK/LC_MESSAGES/mate-terminal.mo
+share/locale/zh_TW/LC_MESSAGES/mate-terminal.mo
+%%DATADIR%%/encodings-dialog.ui
+%%DATADIR%%/find-dialog.ui
+%%DATADIR%%/keybinding-editor.ui
+%%DATADIR%%/profile-manager.ui
+%%DATADIR%%/profile-new-dialog.ui
+%%DATADIR%%/profile-preferences.ui
+%%DATADIR%%/skey-challenge.ui
+%%DATADIR%%/terminal.about
+%%DATADIR%%/terminal.xml
+share/mate/help/mate-terminal/C/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/C/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/C/legal.xml
+share/mate/help/mate-terminal/C/mate-terminal.xml
+share/mate/help/mate-terminal/bg/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/bg/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/bg/legal.xml
+share/mate/help/mate-terminal/bg/mate-terminal.xml
+share/mate/help/mate-terminal/ca/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/ca/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/ca/mate-terminal.xml
+share/mate/help/mate-terminal/cs/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/cs/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/cs/mate-terminal.xml
+share/mate/help/mate-terminal/da/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/da/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/da/mate-terminal.xml
+share/mate/help/mate-terminal/de/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/de/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/de/mate-terminal.xml
+share/mate/help/mate-terminal/el/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/el/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/el/mate-terminal.xml
+share/mate/help/mate-terminal/en_GB/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/en_GB/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/en_GB/mate-terminal.xml
+share/mate/help/mate-terminal/es/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/es/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/es/mate-terminal.xml
+share/mate/help/mate-terminal/fr/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/fr/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/fr/mate-terminal.xml
+share/mate/help/mate-terminal/it/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/it/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/it/mate-terminal.xml
+share/mate/help/mate-terminal/ja/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/ja/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/ja/legal.xml
+share/mate/help/mate-terminal/ja/mate-terminal.xml
+share/mate/help/mate-terminal/ko/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/ko/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/ko/mate-terminal.xml
+share/mate/help/mate-terminal/oc/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/oc/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/oc/mate-terminal.xml
+share/mate/help/mate-terminal/pt_BR/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/pt_BR/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/pt_BR/mate-terminal.xml
+share/mate/help/mate-terminal/ro/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/ro/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/ro/legal.xml
+share/mate/help/mate-terminal/ro/mate-terminal.xml
+share/mate/help/mate-terminal/ru/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/ru/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/ru/mate-terminal.xml
+share/mate/help/mate-terminal/sv/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/sv/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/sv/mate-terminal.xml
+share/mate/help/mate-terminal/uk/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/uk/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/uk/mate-terminal.xml
+share/mate/help/mate-terminal/zh_CN/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/zh_CN/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/zh_CN/mate-terminal.xml
+share/mate/help/mate-terminal/zh_TW/figures/mate-terminal-default.png
+share/mate/help/mate-terminal/zh_TW/figures/mate-terminal-tabbed.png
+share/mate/help/mate-terminal/zh_TW/legal.xml
+share/mate/help/mate-terminal/zh_TW/mate-terminal.xml
+share/omf/mate-terminal/mate-terminal-C.omf
+share/omf/mate-terminal/mate-terminal-bg.omf
+share/omf/mate-terminal/mate-terminal-ca.omf
+share/omf/mate-terminal/mate-terminal-cs.omf
+share/omf/mate-terminal/mate-terminal-da.omf
+share/omf/mate-terminal/mate-terminal-de.omf
+share/omf/mate-terminal/mate-terminal-el.omf
+share/omf/mate-terminal/mate-terminal-en_GB.omf
+share/omf/mate-terminal/mate-terminal-es.omf
+share/omf/mate-terminal/mate-terminal-fr.omf
+share/omf/mate-terminal/mate-terminal-it.omf
+share/omf/mate-terminal/mate-terminal-ja.omf
+share/omf/mate-terminal/mate-terminal-ko.omf
+share/omf/mate-terminal/mate-terminal-oc.omf
+share/omf/mate-terminal/mate-terminal-pt_BR.omf
+share/omf/mate-terminal/mate-terminal-ro.omf
+share/omf/mate-terminal/mate-terminal-ru.omf
+share/omf/mate-terminal/mate-terminal-sv.omf
+share/omf/mate-terminal/mate-terminal-uk.omf
+share/omf/mate-terminal/mate-terminal-zh_CN.omf
+share/omf/mate-terminal/mate-terminal-zh_TW.omf
+@dirrm share/omf/mate-terminal
+@dirrm share/mate/help/mate-terminal/zh_TW/figures
+@dirrm share/mate/help/mate-terminal/zh_TW
+@dirrm share/mate/help/mate-terminal/zh_CN/figures
+@dirrm share/mate/help/mate-terminal/zh_CN
+@dirrm share/mate/help/mate-terminal/uk/figures
+@dirrm share/mate/help/mate-terminal/uk
+@dirrm share/mate/help/mate-terminal/sv/figures
+@dirrm share/mate/help/mate-terminal/sv
+@dirrm share/mate/help/mate-terminal/ru/figures
+@dirrm share/mate/help/mate-terminal/ru
+@dirrm share/mate/help/mate-terminal/ro/figures
+@dirrm share/mate/help/mate-terminal/ro
+@dirrm share/mate/help/mate-terminal/pt_BR/figures
+@dirrm share/mate/help/mate-terminal/pt_BR
+@dirrm share/mate/help/mate-terminal/oc/figures
+@dirrm share/mate/help/mate-terminal/oc
+@dirrm share/mate/help/mate-terminal/ko/figures
+@dirrm share/mate/help/mate-terminal/ko
+@dirrm share/mate/help/mate-terminal/ja/figures
+@dirrm share/mate/help/mate-terminal/ja
+@dirrm share/mate/help/mate-terminal/it/figures
+@dirrm share/mate/help/mate-terminal/it
+@dirrm share/mate/help/mate-terminal/fr/figures
+@dirrm share/mate/help/mate-terminal/fr
+@dirrm share/mate/help/mate-terminal/es/figures
+@dirrm share/mate/help/mate-terminal/es
+@dirrm share/mate/help/mate-terminal/en_GB/figures
+@dirrm share/mate/help/mate-terminal/en_GB
+@dirrm share/mate/help/mate-terminal/el/figures
+@dirrm share/mate/help/mate-terminal/el
+@dirrm share/mate/help/mate-terminal/de/figures
+@dirrm share/mate/help/mate-terminal/de
+@dirrm share/mate/help/mate-terminal/da/figures
+@dirrm share/mate/help/mate-terminal/da
+@dirrm share/mate/help/mate-terminal/cs/figures
+@dirrm share/mate/help/mate-terminal/cs
+@dirrm share/mate/help/mate-terminal/ca/figures
+@dirrm share/mate/help/mate-terminal/ca
+@dirrm share/mate/help/mate-terminal/bg/figures
+@dirrm share/mate/help/mate-terminal/bg
+@dirrm share/mate/help/mate-terminal/C/figures
+@dirrm share/mate/help/mate-terminal/C
+@dirrm share/mate/help/mate-terminal
+@dirrm %%DATADIR%%
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/xh/LC_MESSAGES
+@dirrmtry share/locale/xh
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/hy/LC_MESSAGES
+@dirrmtry share/locale/hy
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as