aboutsummaryrefslogtreecommitdiff
path: root/x11/mlterm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-25 11:50:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-25 11:50:24 +0000
commitc9e1ad637a252b6801eb0acdd75fe7af1c088eee (patch)
tree71e8c41811e4758af40953f289b27b3f2698e4e8 /x11/mlterm
parenta012c682a02d96692cd64f4305c9f579968e8f5d (diff)
downloadports-c9e1ad637a252b6801eb0acdd75fe7af1c088eee.tar.gz
ports-c9e1ad637a252b6801eb0acdd75fe7af1c088eee.zip
Notes
Diffstat (limited to 'x11/mlterm')
-rw-r--r--x11/mlterm/Makefile88
1 files changed, 20 insertions, 68 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 3718a5278c16..8248c332c98b 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -24,6 +24,7 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= CAIRO DOCS FRIBIDI IBUS M17NLIB REGIS SCIM SIXEL UIM
+OPTIONS_SUB= yes
CAIRO_DESC= Use Cairo for type engine (experimental)
FRIBIDI_DESC= Use Fribidi for BiDi rendering
IBUS_DESC= IBUS support (experimental)
@@ -33,93 +34,44 @@ SCIM_DESC= SCIM support (experimental)
SIXEL_DESC= Sixel graphics support
UIM_DESC= uim support (experimental)
-.include <bsd.port.options.mk>
+FRIBIDI_CONFIGURE_ENABLE= fribidi
+FRIBIDI_LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi
-.if ${PORT_OPTIONS:MFRIBIDI}
-CONFIGURE_ARGS+= --enable-fribidi
-LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
-PLIST_SUB+= FRIBIDI=""
-.else
-CONFIGURE_ARGS+= --disable-fribidi
-PLIST_SUB+= FRIBIDI="@comment "
-.endif
+UIM_CONFIGURE_ENABLE= uim
+UIM_LIB_DEPENDS= libuim.so:${PORTSDIR}/textproc/uim
-.if ${PORT_OPTIONS:MUIM}
-CONFIGURE_ARGS+= --enable-uim
-LIB_DEPENDS+= libuim.so:${PORTSDIR}/textproc/uim
-PLIST_SUB+= UIM=""
-.else
-CONFIGURE_ARGS+= --disable-uim
-PLIST_SUB+= UIM="@comment "
-.endif
+M17NLIB_CONFIGURE_ENABLE= m17nlib
+M17NLIB_LIB_DEPENDS= libm17n.so:${PORTSDIR}/devel/m17n-lib
-.if ${PORT_OPTIONS:MM17NLIB}
-CONFIGURE_ARGS+= --enable-m17nlib
-LIB_DEPENDS+= libm17n.so:${PORTSDIR}/devel/m17n-lib
-PLIST_SUB+= M17NLIB=""
-.else
-CONFIGURE_ARGS+= --disable-m17nlib
-PLIST_SUB+= M17NLIB="@comment "
-.endif
+SCIM_CONFIGURE_ENABLE= scim
+SCIM_LIB_DEPENDS= libscim-1.0.so:${PORTSDIR}/textproc/scim
-.if ${PORT_OPTIONS:MSCIM}
-CONFIGURE_ARGS+= --enable-scim
-LIB_DEPENDS+= libscim-1.0.so:${PORTSDIR}/textproc/scim
-PLIST_SUB+= SCIM=""
-.else
-CONFIGURE_ARGS+= --disable-scim
-PLIST_SUB+= SCIM="@comment "
-.endif
+IBUS_CONFIGURE_ENABLE= ibus
+IBUS_LIB_DEPENDS= libibus-1.0.so:${PORTSDIR}/textproc/ibus
-.if ${PORT_OPTIONS:MIBUS}
-CONFIGURE_ARGS+= --enable-ibus
-LIB_DEPENDS+= libibus-1.0.so:${PORTSDIR}/textproc/ibus
-PLIST_SUB+= IBUS=""
-.else
-CONFIGURE_ARGS+= --disable-ibus
-PLIST_SUB+= IBUS="@comment "
-.endif
+CAIRO_LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
+CAIRO_CONFIGURE_ON= --with-type-engines="xcore,xft,cairo"
+CAIRO_CONFIGURE_OFF= --with-type-engines="xcore,xft"
-.if ${PORT_OPTIONS:MCAIRO}
-CONFIGURE_ARGS+= --with-type-engines="xcore,xft,cairo"
-LIB_DEPENDS+= libcairo.so:${PORTSDIR}/graphics/cairo
-PLIST_SUB+= CAIRO=""
-.else
-CONFIGURE_ARGS+= --with-type-engines="xcore,xft"
-PLIST_SUB+= CAIRO="@comment "
-.endif
+SIXEL_CONFIGURE_ENABLE= sixel
-.if ${PORT_OPTIONS:MSIXEL}
-CONFIGURE_ARGS+= --enable-sixel
-PLIST_SUB+= SIXEL=""
-.else
-CONFIGURE_ARGS+= --disable-sixel
-PLIST_SUB+= SIXEL="@comment "
-.endif
+REGIS_LIB_DEPENDS= libSDL.so:${PORTSDIR}/devel/sdl12 \
+ libSDL_ttf.so:${PORTSDIR}/graphics/sdl_ttf \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MREGIS}
-LIB_DEPENDS+= libSDL.so:${PORTSDIR}/devel/sdl12 \
- libSDL_ttf.so:${PORTSDIR}/graphics/sdl_ttf \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
EXTERNAL_TOOLS+=,registobmp
-PLIST_SUB+= REGIS=""
-.else
-PLIST_SUB+= REGIS="@comment "
.endif
CONFIGURE_ARGS+=--with-tools="${EXTERNAL_TOOLS}"
-.if ${OSVERSION} < 900004
-LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
-.endif
-
post-configure:
@${REINPLACE_CMD} -e "s,@CGI_BIN@,${PREFIX}/libexec/w3mmlconfig," \
${WRKSRC}/tool/w3mmlconfig/mlconfig.cgi
-.if ${OSVERSION} >= 900004
@${REINPLACE_CMD} -e 's|kik_utmp_bsd|kik_utmp_utmper|' \
${WRKSRC}/kiklib/src/Makefile
-.endif
post-install:
(cd ${WRKSRC}/tool/w3mmlconfig && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \