aboutsummaryrefslogtreecommitdiff
path: root/x11/p5-Clipboard
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-14 11:59:05 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-14 11:59:05 +0000
commit1824782297a7d8b2d272f6b7aff77a3d1b855b76 (patch)
treef7cf775ff7843cbe574918919c3c7ebd2a0f1653 /x11/p5-Clipboard
parent70f71a0de06f9715de3f933f63194c489f7500d3 (diff)
downloadports-1824782297a7d8b2d272f6b7aff77a3d1b855b76.tar.gz
ports-1824782297a7d8b2d272f6b7aff77a3d1b855b76.zip
Notes
Diffstat (limited to 'x11/p5-Clipboard')
-rw-r--r--x11/p5-Clipboard/Makefile34
-rw-r--r--x11/p5-Clipboard/distinfo2
-rw-r--r--x11/p5-Clipboard/pkg-descr8
-rw-r--r--x11/p5-Clipboard/pkg-plist11
4 files changed, 55 insertions, 0 deletions
diff --git a/x11/p5-Clipboard/Makefile b/x11/p5-Clipboard/Makefile
new file mode 100644
index 000000000000..20cd000e7718
--- /dev/null
+++ b/x11/p5-Clipboard/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: x11/p5-Clipboard
+# Date created: 14 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Clipboard
+PORTVERSION= 0.08
+CATEGORIES= x11 perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/K/KI/KING
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Access to X11 clipboard from Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/All.pm:${PORTSDIR}/devel/p5-IO-All \
+ ${SITE_PERL}/Spiffy.pm:${PORTSDIR}/devel/p5-Spiffy
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ xclip:${PORTSDIR}/x11/xclip
+
+PERL_CONFIGURE= yes
+
+MAN1= clipaccumulate.1 clipbrowse.1 clipedit.1 clipjoin.1
+MAN3= Clipboard.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/p5-Clipboard/distinfo b/x11/p5-Clipboard/distinfo
new file mode 100644
index 000000000000..21f354e6b6a6
--- /dev/null
+++ b/x11/p5-Clipboard/distinfo
@@ -0,0 +1,2 @@
+MD5 (Clipboard-0.08.tar.gz) = 87d4c83229b0b9fcba477f9e707eaf05
+SIZE (Clipboard-0.08.tar.gz) = 13866
diff --git a/x11/p5-Clipboard/pkg-descr b/x11/p5-Clipboard/pkg-descr
new file mode 100644
index 000000000000..30187a541c02
--- /dev/null
+++ b/x11/p5-Clipboard/pkg-descr
@@ -0,0 +1,8 @@
+Who doesn't remember the first time they learned to copy and paste, and
+generated an exponentially growing text document? Yes, that's right,
+clipboards are magical.
+
+With Clipboard.pm, this magic is now trivial to access,
+cross-platformly, from your Perl code.
+
+WWW: http://search.cpan.org/dist/Clipboard/
diff --git a/x11/p5-Clipboard/pkg-plist b/x11/p5-Clipboard/pkg-plist
new file mode 100644
index 000000000000..ff1969165217
--- /dev/null
+++ b/x11/p5-Clipboard/pkg-plist
@@ -0,0 +1,11 @@
+bin/clipaccumulate
+bin/clipbrowse
+bin/clipedit
+bin/clipjoin
+%%SITE_PERL%%/Clipboard.pm
+%%SITE_PERL%%/Clipboard/Pb.pm
+%%SITE_PERL%%/Clipboard/Win32.pm
+%%SITE_PERL%%/Clipboard/Xclip.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Clipboard/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Clipboard 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Clipboard 2>/dev/null || true