aboutsummaryrefslogtreecommitdiff
path: root/x11/p5-X11-GUITest
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-10-28 06:30:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-10-28 06:30:54 +0000
commit3706defea4eeba6111d21ebb88b3559569c1dffd (patch)
tree775d85ae0f6dfd2dd853b54016ddbc63df7770af /x11/p5-X11-GUITest
parent4b16da7d29fdc05aaaf696a448a4763f4cd17f4f (diff)
downloadports-3706defea4eeba6111d21ebb88b3559569c1dffd.tar.gz
ports-3706defea4eeba6111d21ebb88b3559569c1dffd.zip
add p5-X11-GUITest 0.20
Provides GUI testing/interaction facilities
Notes
Notes: svn path=/head/; revision=120375
Diffstat (limited to 'x11/p5-X11-GUITest')
-rw-r--r--x11/p5-X11-GUITest/Makefile26
-rw-r--r--x11/p5-X11-GUITest/distinfo2
-rw-r--r--x11/p5-X11-GUITest/pkg-descr6
-rw-r--r--x11/p5-X11-GUITest/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/x11/p5-X11-GUITest/Makefile b/x11/p5-X11-GUITest/Makefile
new file mode 100644
index 000000000000..ec1f270f50c7
--- /dev/null
+++ b/x11/p5-X11-GUITest/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: X11-GUITest
+# Date created: Oct 28, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= X11-GUITest
+PORTVERSION= 0.20
+CATEGORIES= x11 perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
+MASTER_SITE_SUBDIR= X11/:cpan \
+ x11guitest/:sf
+PKGNAMEPREFIX= p5-
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:cpan \
+ ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Provides GUI testing/interaction facilities
+
+PERL_CONFIGURE= yes
+MAN3= X11::GUITest.3
+
+.include <bsd.port.mk>
diff --git a/x11/p5-X11-GUITest/distinfo b/x11/p5-X11-GUITest/distinfo
new file mode 100644
index 000000000000..073878aedfd7
--- /dev/null
+++ b/x11/p5-X11-GUITest/distinfo
@@ -0,0 +1,2 @@
+MD5 (X11-GUITest-0.20.tar.gz) = d175896c876b932e11f5a3ffa313f189
+SIZE (X11-GUITest-0.20.tar.gz) = 39913
diff --git a/x11/p5-X11-GUITest/pkg-descr b/x11/p5-X11-GUITest/pkg-descr
new file mode 100644
index 000000000000..bb748a470ff5
--- /dev/null
+++ b/x11/p5-X11-GUITest/pkg-descr
@@ -0,0 +1,6 @@
+This Perl package is intended to facilitate the testing of GUI applications by
+means of user emulation. It can be used to test/interact with GUI applications;
+which have been built upon the X library or toolkits (i.e., GTK+, Xt, Qt,
+Motif, etc.) that "wrap" the X library's functionality.
+
+WWW: http://search.cpan.org/dist/X11-GUITest/
diff --git a/x11/p5-X11-GUITest/pkg-plist b/x11/p5-X11-GUITest/pkg-plist
new file mode 100644
index 000000000000..6655434efa29
--- /dev/null
+++ b/x11/p5-X11-GUITest/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/X11/GUITest.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/X11
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest/GUITest.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest/GUITest.bs
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/X11/GUITest
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/X11