aboutsummaryrefslogtreecommitdiff
path: root/x11/p5-X11-IdleTime/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-25 17:49:23 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-25 17:49:23 +0000
commitfa984a41697dd39e50ec44bb21cdf6345191ab0b (patch)
tree253ccd8102bf90cd521702041f1a1b9726da0ac4 /x11/p5-X11-IdleTime/Makefile
parent458d3d20d3a9f7b3744411bbec2ba53e15b09816 (diff)
downloadports-fa984a41697dd39e50ec44bb21cdf6345191ab0b.tar.gz
ports-fa984a41697dd39e50ec44bb21cdf6345191ab0b.zip
Notes
Diffstat (limited to 'x11/p5-X11-IdleTime/Makefile')
-rw-r--r--x11/p5-X11-IdleTime/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11/p5-X11-IdleTime/Makefile b/x11/p5-X11-IdleTime/Makefile
new file mode 100644
index 000000000000..8dfbde7822ef
--- /dev/null
+++ b/x11/p5-X11-IdleTime/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-X11-IdleTime
+# Date created: 9 July 2003
+# Whom: Sean Farley <sean-freebsd@farley.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= X11-IdleTime
+PORTVERSION= 0.01
+CATEGORIES= x11 perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= X11
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl module that reports number of seconds that X11 has been idle
+
+BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_XLIB= yes
+USE_REINPLACE= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${SITE_PERL}
+MAN3= X11::IdleTime.3
+
+post-patch:
+.for i in IdleTime.pm
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/${i}
+.endfor
+
+.include <bsd.port.pre.mk>
+
+##
+## this port requires PERL 5.8.x or later
+##
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>