aboutsummaryrefslogtreecommitdiff
path: root/x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-27 20:29:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-27 20:29:36 +0000
commitef944cd3535703c6f81803ea9c79523d18bf2c5a (patch)
tree59ff42fd6dd4aeb0189ec1ae805c13207a7bb391 /x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt
parent3ccba726e98b92146ad0a4158dd028c2f05b5d00 (diff)
downloadports-ef944cd3535703c6f81803ea9c79523d18bf2c5a.tar.gz
ports-ef944cd3535703c6f81803ea9c79523d18bf2c5a.zip
Notes
Diffstat (limited to 'x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt')
-rw-r--r--x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt b/x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt
new file mode 100644
index 000000000000..1618abb2c2ba
--- /dev/null
+++ b/x11/plasma5-libkscreen/files/patch-backends_CMakeLists.txt
@@ -0,0 +1,13 @@
+--- backends/CMakeLists.txt.orig 2017-01-19 20:29:18 UTC
++++ backends/CMakeLists.txt
+@@ -1,6 +1,9 @@
+ add_subdirectory(fake)
+ add_subdirectory(qscreen)
+-add_subdirectory(kwayland)
++
++if (KF5Wayland_FOUND)
++ add_subdirectory(kwayland)
++endif()
+
+ if(${XCB_RANDR_FOUND})
+ message(STATUS "Will build xrandr backend.")