aboutsummaryrefslogtreecommitdiff
path: root/x11/plasma5-plasma-integration
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-27 20:29:36 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-27 20:29:36 +0000
commitef944cd3535703c6f81803ea9c79523d18bf2c5a (patch)
tree59ff42fd6dd4aeb0189ec1ae805c13207a7bb391 /x11/plasma5-plasma-integration
parent3ccba726e98b92146ad0a4158dd028c2f05b5d00 (diff)
downloadports-ef944cd3535703c6f81803ea9c79523d18bf2c5a.tar.gz
ports-ef944cd3535703c6f81803ea9c79523d18bf2c5a.zip
Notes
Diffstat (limited to 'x11/plasma5-plasma-integration')
-rw-r--r--x11/plasma5-plasma-integration/Makefile38
-rw-r--r--x11/plasma5-plasma-integration/distinfo3
-rw-r--r--x11/plasma5-plasma-integration/pkg-descr3
-rw-r--r--x11/plasma5-plasma-integration/pkg-plist48
4 files changed, 92 insertions, 0 deletions
diff --git a/x11/plasma5-plasma-integration/Makefile b/x11/plasma5-plasma-integration/Makefile
new file mode 100644
index 000000000000..7a690c6a4e38
--- /dev/null
+++ b/x11/plasma5-plasma-integration/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= plasma-integration
+DISTVERSION= ${KDE_PLASMA_VERSION}
+CATEGORIES= x11 kde kde-plasma
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt Platform Theme integration plugins for the Plasma workspaces
+
+RUN_DEPENDS= hack-font>=0:x11-fonts/hack-font
+
+USES= cmake:outsource compiler:c++11-lib cpe gettext kde:5 pkgconfig \
+ shebangfix tar:xz
+USE_KDE= auth bookmarks breeze codecs completion config configwidgets \
+ coreaddons ecm i18n iconthemes itemviews jobwidgets kio \
+ notifications service solid wayland \
+ widgetsaddons windowsystem xmlgui
+USE_QT5= concurrent core dbus gui network qml quick quickcontrols2 widgets \
+ x11extras xml \
+ buildtools_build qmake_build
+USE_XORG= xcb xcursor
+
+SHEBANG_FILES= src/platformtheme/fonts_akregator.pl \
+ src/platformtheme/fonts_global.pl \
+ src/platformtheme/fonts_kate.pl \
+ src/platformtheme/mono_font.pl
+
+OPTIONS_SINGLE= NOTO
+OPTIONS_SINGLE_NOTO= LIGHT BIG
+OPTIONS_DEFAULT= LIGHT
+NOTO_DESC= KDE default font
+LIGHT_DESC= Use noto-light
+BIG_DESC= Use complete noto
+
+LIGHT_RUN_DEPENDS= noto-lite>=0:x11-fonts/noto-lite
+BIG_RUN_DEPENDS= noto>=0:x11-fonts/noto
+
+.include <bsd.port.mk>
diff --git a/x11/plasma5-plasma-integration/distinfo b/x11/plasma5-plasma-integration/distinfo
new file mode 100644
index 000000000000..645961322bd5
--- /dev/null
+++ b/x11/plasma5-plasma-integration/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523811831
+SHA256 (KDE/plasma/5.12.4/plasma-integration-5.12.4.tar.xz) = 8b4e25cea0e533b95682e613b8dcc3f8ebe2e100610b03805ba08952eb64be61
+SIZE (KDE/plasma/5.12.4/plasma-integration-5.12.4.tar.xz) = 53488
diff --git a/x11/plasma5-plasma-integration/pkg-descr b/x11/plasma5-plasma-integration/pkg-descr
new file mode 100644
index 000000000000..b2485c11bba4
--- /dev/null
+++ b/x11/plasma5-plasma-integration/pkg-descr
@@ -0,0 +1,3 @@
+Qt Platform Theme integration plugins for the Plasma workspaces.
+
+WWW: https://www.kde.org/plasma-desktop
diff --git a/x11/plasma5-plasma-integration/pkg-plist b/x11/plasma5-plasma-integration/pkg-plist
new file mode 100644
index 000000000000..46f62d83f135
--- /dev/null
+++ b/x11/plasma5-plasma-integration/pkg-plist
@@ -0,0 +1,48 @@
+%%QT_PLUGINDIR%%/platformthemes/KDEPlasmaPlatformTheme.so
+share/kconf_update/fonts_akregator.pl
+share/kconf_update/fonts_akregator.upd
+share/kconf_update/fonts_global.pl
+share/kconf_update/fonts_global.upd
+share/kconf_update/fonts_global_toolbar.upd
+share/kconf_update/fonts_kate.pl
+share/kconf_update/fonts_kate.upd
+share/locale/ar/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ast/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ca/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ca@valencia/LC_MESSAGES/plasmaintegration5.mo
+share/locale/cs/LC_MESSAGES/plasmaintegration5.mo
+share/locale/da/LC_MESSAGES/plasmaintegration5.mo
+share/locale/de/LC_MESSAGES/plasmaintegration5.mo
+share/locale/el/LC_MESSAGES/plasmaintegration5.mo
+share/locale/en_GB/LC_MESSAGES/plasmaintegration5.mo
+share/locale/es/LC_MESSAGES/plasmaintegration5.mo
+share/locale/et/LC_MESSAGES/plasmaintegration5.mo
+share/locale/eu/LC_MESSAGES/plasmaintegration5.mo
+share/locale/fi/LC_MESSAGES/plasmaintegration5.mo
+share/locale/fr/LC_MESSAGES/plasmaintegration5.mo
+share/locale/gl/LC_MESSAGES/plasmaintegration5.mo
+share/locale/he/LC_MESSAGES/plasmaintegration5.mo
+share/locale/hu/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ia/LC_MESSAGES/plasmaintegration5.mo
+share/locale/it/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ja/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ko/LC_MESSAGES/plasmaintegration5.mo
+share/locale/nb/LC_MESSAGES/plasmaintegration5.mo
+share/locale/nl/LC_MESSAGES/plasmaintegration5.mo
+share/locale/nn/LC_MESSAGES/plasmaintegration5.mo
+share/locale/pa/LC_MESSAGES/plasmaintegration5.mo
+share/locale/pl/LC_MESSAGES/plasmaintegration5.mo
+share/locale/pt/LC_MESSAGES/plasmaintegration5.mo
+share/locale/pt_BR/LC_MESSAGES/plasmaintegration5.mo
+share/locale/ru/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sk/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sl/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sr/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sr@ijekavian/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sr@latin/LC_MESSAGES/plasmaintegration5.mo
+share/locale/sv/LC_MESSAGES/plasmaintegration5.mo
+share/locale/tr/LC_MESSAGES/plasmaintegration5.mo
+share/locale/uk/LC_MESSAGES/plasmaintegration5.mo
+share/locale/zh_CN/LC_MESSAGES/plasmaintegration5.mo
+share/locale/zh_TW/LC_MESSAGES/plasmaintegration5.mo