aboutsummaryrefslogtreecommitdiff
path: root/x11/qimageblitz
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /x11/qimageblitz
parentbdcf355d6dedb8678255a8053a2b423f9cc7cc6c (diff)
Notes
Diffstat (limited to 'x11/qimageblitz')
-rw-r--r--x11/qimageblitz/Makefile31
-rw-r--r--x11/qimageblitz/distinfo3
-rw-r--r--x11/qimageblitz/pkg-descr6
-rw-r--r--x11/qimageblitz/pkg-plist9
4 files changed, 49 insertions, 0 deletions
diff --git a/x11/qimageblitz/Makefile b/x11/qimageblitz/Makefile
new file mode 100644
index 000000000000..f3b8ca59ee6f
--- /dev/null
+++ b/x11/qimageblitz/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: qimageblitz
+# Date created: 2008-01-15
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qimageblitz
+PORTVERSION= 0.0.4
+CATEGORIES= x11
+MASTER_SITES= SF
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE 4 integrated X11 desktop
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc uic gui rcc
+USE_CMAKE= yes
+CMAKE_DEBUG= yes
+CMAKE_VERBOSE= yes
+
+post-patch:
+ ${MKDIR} ${WRKSRC}
+ ${REINPLACE_CMD} -e \
+ 's,$${LIB_INSTALL_DIR}/pkgconfig,libdata/pkgconfig,' \
+ ${WRKSRC}/blitz/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/x11/qimageblitz/distinfo b/x11/qimageblitz/distinfo
new file mode 100644
index 000000000000..88e6f528b32d
--- /dev/null
+++ b/x11/qimageblitz/distinfo
@@ -0,0 +1,3 @@
+MD5 (qimageblitz-0.0.4.tar.bz2) = cb87c7f1c0455e8984ee4830f1e749cf
+SHA256 (qimageblitz-0.0.4.tar.bz2) = e902298edbfedea123e59f27d03d23ca273716d555eb2af4eff3e513f170ca5e
+SIZE (qimageblitz-0.0.4.tar.bz2) = 55720
diff --git a/x11/qimageblitz/pkg-descr b/x11/qimageblitz/pkg-descr
new file mode 100644
index 000000000000..325175ef6d5f
--- /dev/null
+++ b/x11/qimageblitz/pkg-descr
@@ -0,0 +1,6 @@
+Blitz is an interm image effect library that people can use until KDE4.1 is
+released. KImageEffect, the old image effect class is being dropped for KDE4.0
+and the replacement, Quasar, won't be ready until KDE4.1. Blitz gives people
+something to use in the meantime.
+
+WWW: http://sourceforge.net/projects/qimageblitz
diff --git a/x11/qimageblitz/pkg-plist b/x11/qimageblitz/pkg-plist
new file mode 100644
index 000000000000..961c66cccf36
--- /dev/null
+++ b/x11/qimageblitz/pkg-plist
@@ -0,0 +1,9 @@
+bin/blitztest
+include/qimageblitz/blitzcpu.h
+include/qimageblitz/qimageblitz.h
+include/qimageblitz/qimageblitz_export.h
+lib/libqimageblitz.so
+lib/libqimageblitz.so.4
+lib/libqimageblitz.so.4.0.0
+libdata/pkgconfig/qimageblitz.pc
+@dirrm include/qimageblitz