aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-inputmethods/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 20:56:24 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-02-05 20:56:24 +0000
commit74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8 (patch)
tree5a2cd52714027788ca840d18e6087ab373c335b4 /x11/qt4-inputmethods/Makefile
parent9650cc958392c895ef613d1abea30ed3510adffd (diff)
downloadports-74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8.tar.gz
ports-74cb0fb1e88e05ac2dc49f1aa7274c98a470a7c8.zip
Notes
Diffstat (limited to 'x11/qt4-inputmethods/Makefile')
-rw-r--r--x11/qt4-inputmethods/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
new file mode 100644
index 000000000000..6aebf51e26cf
--- /dev/null
+++ b/x11/qt4-inputmethods/Makefile
@@ -0,0 +1,66 @@
+# -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= inputmethods
+PORTVERSION= 4.2.2
+CATEGORIES?= x11
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt input method plugins
+
+BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+ qmake-qt4:${PORTSDIR}/devel/qmake4
+LIB_DEPENDS= QtCore:${PORTSDIR}/devel/qt4-corelib \
+ QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -prefix ${PREFIX} \
+ -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
+ -confirm-license
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/network' --exclude '${DISTNAME}/src/xml' \
+ --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
+ --exclude '${DISTNAME}/src/sql' \
+ --exclude '${DISTNAME}/src/tools/moc' --exclude '${DISTNAME}/src/tools/uic' \
+ --exclude '${DISTNAME}/src/tools/rcc' --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/assistant' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../..
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins/inputmethods|g' \
+ ${WRKSRC}/imsw-multi/imsw-multi.pro
+ ${MKDIR} ${WRKSRC}/../../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../../bin/moc
+
+.include <bsd.port.post.mk>