aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-inputmethods
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-01-21 21:13:21 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-01-21 21:13:21 +0000
commit43902f6ecc0189b88ec79a03b8b0b39425aa18dd (patch)
tree5b488e99af499ef5ed89d0b90cc3f0f14b1f1ad4 /x11/qt4-inputmethods
parent5534788943950923c05e59a02337cde792233450 (diff)
downloadports-43902f6ecc0189b88ec79a03b8b0b39425aa18dd.tar.gz
ports-43902f6ecc0189b88ec79a03b8b0b39425aa18dd.zip
Notes
Diffstat (limited to 'x11/qt4-inputmethods')
-rw-r--r--x11/qt4-inputmethods/Makefile25
-rw-r--r--x11/qt4-inputmethods/pkg-descr2
-rw-r--r--x11/qt4-inputmethods/pkg-plist7
3 files changed, 19 insertions, 15 deletions
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index 46f5fc3b75bb..6542bfdd9394 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -8,7 +8,6 @@
PORTNAME= inputmethods
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 0
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
@@ -29,22 +28,26 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/dbus src/network src/opengl src/phonon \
- src/qt3support src/script src/sql src/svg src/testlib \
- src/tools src/xml src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+ src/activeqt src/dbus src/multimedia src/network src/opengl \
+ src/openvg src/phonon src/qt3support src/s60installs \
+ src/s60main src/script src/scripttools src/sql src/svg \
+ src/testlib src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC= ${WRKDIR}/${DISTNAME}/src/plugins/${PORTNAME}
-CONFIGURE_WRKSRC=${WRKSRC}/../../..
+BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
.include <bsd.port.mk>
diff --git a/x11/qt4-inputmethods/pkg-descr b/x11/qt4-inputmethods/pkg-descr
index efc79b9aaf24..36bc69717e98 100644
--- a/x11/qt4-inputmethods/pkg-descr
+++ b/x11/qt4-inputmethods/pkg-descr
@@ -9,4 +9,4 @@ the application programmer with a single, common API for all operating systems.
The native C APIs are encapsulated in a set of well-designed, fully
object-oriented C++ classes.
-WWW: http://www.trolltech.com/products/qt/index.html
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-inputmethods/pkg-plist b/x11/qt4-inputmethods/pkg-plist
index bf964f3acbdb..3af105942e32 100644
--- a/x11/qt4-inputmethods/pkg-plist
+++ b/x11/qt4-inputmethods/pkg-plist
@@ -1,3 +1,4 @@
-lib/qt4/plugins/inputmethods/libqimsw-multi.so
-%%DEBUG%%lib/qt4/plugins/inputmethods/libqimsw-multi.so.debug
-@dirrm lib/qt4/plugins/inputmethods
+%%QT_PLUGINDIR_REL%%/inputmethods/libqimsw-multi.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/inputmethods/libqimsw-multi.so.debug
+@dirrm %%QT_PLUGINDIR_REL%%/inputmethods
+@dirrmtry %%QT_PLUGINDIR_REL%%