aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-opengl
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-12-02 19:47:17 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-12-02 19:47:17 +0000
commit43a46c6993b270c965c21db4fac822d938ec1475 (patch)
treeaf45a12b238a5ed25cadc0e0fb5a4984cacebafc /x11/qt4-opengl
parentde0eaeceeccc6bcf986371e4c3367b326eac64a6 (diff)
downloadports-43a46c6993b270c965c21db4fac822d938ec1475.tar.gz
ports-43a46c6993b270c965c21db4fac822d938ec1475.zip
Notes
Diffstat (limited to 'x11/qt4-opengl')
-rw-r--r--x11/qt4-opengl/Makefile5
-rw-r--r--x11/qt4-opengl/pkg-plist3
2 files changed, 6 insertions, 2 deletions
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 865fc858521a..4138ca6666f5 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= opengl
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
@@ -46,7 +46,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS+= -I../../include/Qt -I../../include
+CONFIGURE_ARGS+= -I../../include/QtCore -I../../include/QtGui \
+ -I../../include/Qt -I../../include
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
index 07a3b0d9bd9e..787b7289bee1 100644
--- a/x11/qt4-opengl/pkg-plist
+++ b/x11/qt4-opengl/pkg-plist
@@ -1,10 +1,12 @@
include/qt4/Qt/QtOpenGL
include/qt4/Qt/qgl.h
+include/qt4/Qt/qglbuffer.h
include/qt4/Qt/qglcolormap.h
include/qt4/Qt/qglframebufferobject.h
include/qt4/Qt/qglpixelbuffer.h
include/qt4/Qt/qglscreen_qws.h
include/qt4/Qt/qglshaderprogram.h
+include/qt4/QtOpenGL/QGLBuffer
include/qt4/QtOpenGL/QGLColormap
include/qt4/QtOpenGL/QGLContext
include/qt4/QtOpenGL/QGLFormat
@@ -22,6 +24,7 @@ include/qt4/QtOpenGL/QMacCompatGLuint
include/qt4/QtOpenGL/QMacGLCompatTypes
include/qt4/QtOpenGL/QtOpenGL
include/qt4/QtOpenGL/qgl.h
+include/qt4/QtOpenGL/qglbuffer.h
include/qt4/QtOpenGL/qglcolormap.h
include/qt4/QtOpenGL/qglframebufferobject.h
include/qt4/QtOpenGL/qglpixelbuffer.h