aboutsummaryrefslogtreecommitdiff
path: root/x11/qt4-opengl
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-07-16 10:12:15 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-07-16 10:12:15 +0000
commit8bd00266dc1b89a8a7a9d6170d1d895ef285c905 (patch)
tree78e6b0d3b242b999541f0e267c681933f7c9bc9d /x11/qt4-opengl
parentd35a45eeb49c097657f16ba58ccbdf86bc3a59b4 (diff)
downloadports-8bd00266dc1b89a8a7a9d6170d1d895ef285c905.tar.gz
ports-8bd00266dc1b89a8a7a9d6170d1d895ef285c905.zip
Notes
Diffstat (limited to 'x11/qt4-opengl')
-rw-r--r--x11/qt4-opengl/Makefile29
-rw-r--r--x11/qt4-opengl/distinfo6
-rw-r--r--x11/qt4-opengl/pkg-plist6
3 files changed, 15 insertions, 26 deletions
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 69fb879d367a..5bbe7cf165d8 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= opengl
-PORTVERSION= 4.2.3
-PORTREVISION= 3
+PORTVERSION= ${QT4_VERSION}
+PORTREVISION=0
CATEGORIES?= x11
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -18,27 +18,16 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt OpenGL library
-BUILD_DEPENDS= moc-qt4:${PORTSDIR}/devel/qt4-moc \
- qmake-qt4:${PORTSDIR}/devel/qmake4
-LIB_DEPENDS?= QtCore:${PORTSDIR}/devel/qt4-corelib \
- QtGui:${PORTSDIR}/x11-toolkits/qt4-gui
-
-CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
- qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
- xfmail-1.5.5_[1-2]
+USE_QT_VER= 4
+QT_COMPONENTS= qmake moc corelib gui
+QT_NONSTANDARD= yes
+QT_DIST= yes
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GL= yes
USE_XLIB= yes
-CONFIGURE_ARGS= -fast -no-exceptions \
- -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
- -qt-gif -release -system-libjpeg -system-libpng \
- -system-zlib -prefix ${PREFIX} \
- -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
- -no-nas-sound -confirm-license
-
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
@@ -61,7 +50,7 @@ CONFIGURE_WRKSRC=${WRKSRC}/../../
.include <bsd.port.pre.mk>
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
-e 's|flat_headers.path.*|flat_headers.path=${PREFIX}/include/Qt|g' \
-e 's|targ_headers.path.*|targ_headers.path=${PREFIX}/include/$$$$TARGET|g' \
@@ -71,11 +60,11 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
post-configure:
- ${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtOpenGL.pc|${PREFIX}/libdata/pkgconfig/QtOpenGL.pc|g' \
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
-e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
- ${WRKSRC}/../../lib/*Qt*
+ ${WRKSRC}/../../lib/pkgconfig/*Qt*
.include <bsd.port.post.mk>
diff --git a/x11/qt4-opengl/distinfo b/x11/qt4-opengl/distinfo
index 48b91bd5d5e3..8fb631a2787d 100644
--- a/x11/qt4-opengl/distinfo
+++ b/x11/qt4-opengl/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.2.3.tar.gz) = 13f12bf58a32ebf15837fcd605cb3c99
-SHA256 (KDE/qt-x11-opensource-src-4.2.3.tar.gz) = c163e72cb002435d1d261a47acdcb23e59c10e4263f983a5f2c2d2ca40ede75b
-SIZE (KDE/qt-x11-opensource-src-4.2.3.tar.gz) = 37635710
+MD5 (KDE/qt-x11-opensource-src-4.3.0.tar.gz) = 8012acea71b35c18247bd92c4721589d
+SHA256 (KDE/qt-x11-opensource-src-4.3.0.tar.gz) = abc37774d327a9b1d1d35e223f014c7e92168cd6c7baf66156badca68f8f1440
+SIZE (KDE/qt-x11-opensource-src-4.3.0.tar.gz) = 41955515
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
index 2499445c285f..876fccd7e413 100644
--- a/x11/qt4-opengl/pkg-plist
+++ b/x11/qt4-opengl/pkg-plist
@@ -18,8 +18,8 @@ lib/libQtOpenGL.la
lib/libQtOpenGL.prl
lib/libQtOpenGL.so
lib/libQtOpenGL.so.4
-lib/libQtOpenGL.so.4.2
-lib/libQtOpenGL.so.4.2.3
-lib/libQtOpenGL.so.4.2.3.debug
+lib/libQtOpenGL.so.4.3
+lib/libQtOpenGL.so.4.3.0
+lib/libQtOpenGL.so.4.3.0.debug
libdata/pkgconfig/QtOpenGL.pc
@dirrm include/QtOpenGL