aboutsummaryrefslogtreecommitdiff
path: root/x11/ruby-X11/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-05-30 15:47:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-05-30 15:47:57 +0000
commita11b14c2dadee206fbd4d1921613cda8e232cd80 (patch)
tree5409f4ecdb840c0a01f2670c7a7ad4be25ecb618 /x11/ruby-X11/Makefile
parent47cc74582a058320259441921aebc6f1e4795f3e (diff)
downloadports-a11b14c2dadee206fbd4d1921613cda8e232cd80.tar.gz
ports-a11b14c2dadee206fbd4d1921613cda8e232cd80.zip
Notes
Diffstat (limited to 'x11/ruby-X11/Makefile')
-rw-r--r--x11/ruby-X11/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11/ruby-X11/Makefile b/x11/ruby-X11/Makefile
new file mode 100644
index 000000000000..11acd3349f26
--- /dev/null
+++ b/x11/ruby-X11/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: RubyX11
+# Date created: 31 May 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= X11
+PORTVERSION= 0.2
+CATEGORIES= x11 ruby
+MASTER_SITES= http://hostname.2y.net/~matju/RubyX11/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= Ruby${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= ChangeLog Documentation Overview TODO
+EXAMPLES= tests/*
+
+do-install:
+ ${MKDIR} ${RUBY_SITELIBDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/* ${RUBY_SITELIBDIR}/${PORTNAME}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>