aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-devel
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2015-01-17 10:27:46 +0000
committerRene Ladan <rene@FreeBSD.org>2015-01-17 10:27:46 +0000
commit96098408b6bcadcb32958ff7c2da4e2fdf4215c8 (patch)
tree68c4c57daefa22ab05f2d69a654a4ba877e418b7 /x11/rxvt-devel
parent0ef9d57d87ef0889b7ee2336c33b9aa812aaef13 (diff)
Notes
Diffstat (limited to 'x11/rxvt-devel')
-rw-r--r--x11/rxvt-devel/Makefile144
-rw-r--r--x11/rxvt-devel/distinfo2
-rw-r--r--x11/rxvt-devel/files/patch-Makefile.in19
-rw-r--r--x11/rxvt-devel/files/patch-autoconf__config.h.in20
-rw-r--r--x11/rxvt-devel/files/patch-doc__Makefile.in12
-rw-r--r--x11/rxvt-devel/files/patch-src__command.c11
-rw-r--r--x11/rxvt-devel/files/patch-src__init.c22
-rw-r--r--x11/rxvt-devel/files/patch-src__rxvt.h11
-rw-r--r--x11/rxvt-devel/files/patch-src__screen.c62
-rw-r--r--x11/rxvt-devel/files/utmp_patch-src::logging.c12
-rw-r--r--x11/rxvt-devel/files/utmpx_patch-src::logging.c50
-rw-r--r--x11/rxvt-devel/pkg-descr7
-rw-r--r--x11/rxvt-devel/pkg-plist8
13 files changed, 0 insertions, 380 deletions
diff --git a/x11/rxvt-devel/Makefile b/x11/rxvt-devel/Makefile
deleted file mode 100644
index 50c69215d31b..000000000000
--- a/x11/rxvt-devel/Makefile
+++ /dev/null
@@ -1,144 +0,0 @@
-# Created by: Gary Palmer <gpalmer@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= rxvt
-PORTVERSION= 2.7.10
-PORTREVISION= 7
-CATEGORIES+= x11
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-dev/${PORTVERSION}
-PKGNAMESUFFIX= -devel
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Low memory usage xterm replacement that supports color
-
-DEPRECATED= No longer developed nor maintained and deprecated by x11/xvt and x11/rxvt-unicode
-EXPIRATION_DATE=2015-01-13
-
-USES= libtool perl5
-USE_LDCONFIG= yes
-USE_PERL5= build patch
-USE_XORG= xpm
-GNU_CONFIGURE= yes
-
-OPTIONS_DEFINE= 256_COLOR BIG5 EUCJ GB GREEK KR LINESPACE MENUBAR NEXT RXVT \
- SJIS SMART TRANSPARENCY XIM XTERM
-256_COLOR_DESC= Build with 256-color support
-BIG5_DESC= Build with BIG5 support
-EUCJ_DESC= Build with EUC Japanese support
-GB_DESC= Build with GB support
-GREEK_DESC= Build with greek keyboard support
-KR_DESC= Build with EUC Korean support
-LINESPACE_DESC= Build with linespace support
-MENUBAR_DESC= Build with menubar support
-NEXT_DESC= Build with NeXT scrollbar
-RXVT_DESC= Build with rxvt scrollbar
-SJIS_DESC= Build with Shift JIS support
-SMART_DESC= Build with smart resize support
-TRANSPARENCY_DESC= Build with transparency support
-XGETDEFAULT_DESC= Build with XGetDefault() support
-XIM_DESC= Build with XIM support
-XTERM_DESC= Build with Xterm scrollbar
-
-CONFIGURE_ARGS= --enable-utmp --enable-lastlog \
- --with-xpm --enable-xpm-background --enable-shared \
- --enable-mousewheel --disable-languages
-LIBS+= -lutil
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900007
-CONFIGURE_ARGS+= --disable-wtmp
-EXTRA_PATCHES+= ${FILESDIR}/utmpx_patch-src::logging.c
-.else
-CONFIGURE_ARGS+= --enable-wtmp
-EXTRA_PATCHES+= ${FILESDIR}/utmp_patch-src::logging.c
-.endif
-
-# enable 256 color
-.if ${PORT_OPTIONS:M256_COLOR}
-CONFIGURE_ARGS+= --enable-256-color
-.endif
-
-# enable big5 support
-.if ${PORT_OPTIONS:MBIG5}
-CONFIGURE_ARGS+= --with-encoding=big5 --enable-languages
-.endif
-
-# enable euc japanese support
-.if ${PORT_OPTIONS:MEUCJ}
-CONFIGURE_ARGS+= --with-encoding=eucj --enable-languages
-.endif
-
-# enable gb support
-.if ${PORT_OPTIONS:MGB}
-CONFIGURE_ARGS+= --with-encoding=gb --enable-languages
-.endif
-
-# enable greek keyboard support
-.if ${PORT_OPTIONS:MGREEK}
-CONFIGURE_ARGS+= --enable-greek
-.endif
-
-# enable euc korean support
-.if ${PORT_OPTIONS:MKR}
-CONFIGURE_ARGS+= --with-encoding=kr --enable-languages
-.endif
-
-# enable line-spacing
-.if ${PORT_OPTIONS:MLINESPACE}
-CONFIGURE_ARGS+= --enable-linespace
-.endif
-
-# enable menubar
-.if ${PORT_OPTIONS:MMENUBAR}
-CONFIGURE_ARGS+= --enable-menubar
-.endif
-
-# enable NeXT style scrollbar
-.if ${PORT_OPTIONS:MNEXT}
-CONFIGURE_ARGS+= --enable-next-scroll
-.endif
-
-# enable rxvt style scrollbar
-.if ${PORT_OPTIONS:MRXVT}
-CONFIGURE_ARGS+= --enable-rxvt-scroll
-.endif
-
-# enable shift jis support
-.if ${PORT_OPTIONS:MSJIS}
-CONFIGURE_ARGS+= --with-encoding=sjis --enable-languages
-.endif
-
-# enable smart resize
-.if ${PORT_OPTIONS:MSMART}
-CONFIGURE_ARGS+= --enable-smart-resize
-.endif
-
-# enable transparency support
-.if ${PORT_OPTIONS:MTRANSPARENCY}
-CONFIGURE_ARGS+= --enable-transparency
-.endif
-
-# make resources checking via XGetDefault()
-.if ${PORT_OPTIONS:MXGETDEFAULT}
-CONFIGURE_ARGS+= --enable-xgetdefault
-.endif
-
-# XIM (X Input Method) protocol support
-.if ${PORT_OPTIONS:MXIM}
-CONFIGURE_ARGS+= --enable-xim
-.endif
-
-# enable Xterm style scrollbar
-.if ${PORT_OPTIONS:MXTERM}
-CONFIGURE_ARGS+= --enable-xterm-scroll
-.endif
-
-post-patch:
- @${PERL} -pi -e 's|(PTYCHAR2\s+"[^"]+)"|\1ghijklmnopqrstuv"|' \
- ${WRKSRC}/src/ptytty.c
-
-post-install:
- @${CHMOD} 4711 ${STAGEDIR}${PREFIX}/bin/rxvt
-
-.include <bsd.port.post.mk>
diff --git a/x11/rxvt-devel/distinfo b/x11/rxvt-devel/distinfo
deleted file mode 100644
index 3f29b229860b..000000000000
--- a/x11/rxvt-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (rxvt-2.7.10.tar.gz) = 616ad56502820264e6933d07bc4eb752aa6940ec14add6e780ffccf15f38d449
-SIZE (rxvt-2.7.10.tar.gz) = 595073
diff --git a/x11/rxvt-devel/files/patch-Makefile.in b/x11/rxvt-devel/files/patch-Makefile.in
deleted file mode 100644
index f07f98d8a4d8..000000000000
--- a/x11/rxvt-devel/files/patch-Makefile.in
+++ /dev/null
@@ -1,19 +0,0 @@
-*** Makefile.in.orig Sat Aug 9 15:44:33 2003
---- Makefile.in Sat Aug 9 15:44:39 2003
-***************
-*** 9,15 ****
- first_rule: all
- dummy:
-
-! subdirs = src doc rclock src/graphics src/test
- allsubdirs = W11 $(subdirs)
-
- DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
---- 9,15 ----
- first_rule: all
- dummy:
-
-! subdirs = src doc #rclock src/graphics src/test
- allsubdirs = W11 $(subdirs)
-
- DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
diff --git a/x11/rxvt-devel/files/patch-autoconf__config.h.in b/x11/rxvt-devel/files/patch-autoconf__config.h.in
deleted file mode 100644
index 6dc47b63b56e..000000000000
--- a/x11/rxvt-devel/files/patch-autoconf__config.h.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- autoconf/config.h.in.orig Sun Oct 22 00:13:00 2000
-+++ autoconf/config.h.in Sun Oct 22 00:13:43 2000
-@@ -168,7 +168,7 @@
- #undef HAVE_UTMP_HOST
-
- /* Define location of utmp */
--#undef RXVT_UTMP_FILE
-+#define RXVT_UTMP_FILE "/var/run/utmp"
-
- /* Define in utmpx.h has struct utmpx */
- #undef HAVE_STRUCT_UTMPX
-@@ -180,7 +180,7 @@
- #undef RXVT_UTMPX_FILE
-
- /* Define location of wtmp */
--#undef RXVT_WTMP_FILE
-+#define RXVT_WTMP_FILE "/var/log/wtmp"
-
- /* Define location of wtmpx */
- #undef RXVT_WTMPX_FILE
diff --git a/x11/rxvt-devel/files/patch-doc__Makefile.in b/x11/rxvt-devel/files/patch-doc__Makefile.in
deleted file mode 100644
index 6dc0d7630cb4..000000000000
--- a/x11/rxvt-devel/files/patch-doc__Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- doc/Makefile.in Sun Mar 12 00:26:26 2000
-+++ doc/Makefile.in.new Mon Mar 27 01:39:53 2000
-@@ -40,9 +40,6 @@
-
- all: rxvt.1
-
--rxvt.1: rxvt.tbl Makefile
-- @if test x$(TBL) = x; then : ; else echo "$(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl | grep -v '^.lf' > rxvt.1 ; fi
--
- SEDREPLACE = -e 's%@RXVT_VERSION@%$(VERSION)%g;'\
- -e 's%@RXVT_LSMDATE@%$(LSMDATE)%g;'\
- -e 's%@RXVT_DATE@%$(DATE)%g;'\
diff --git a/x11/rxvt-devel/files/patch-src__command.c b/x11/rxvt-devel/files/patch-src__command.c
deleted file mode 100644
index 3aa7b9478e6e..000000000000
--- a/x11/rxvt-devel/files/patch-src__command.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/command.c.orig Thu Apr 5 03:52:39 2001
-+++ src/command.c Fri Jun 22 13:36:57 2001
-@@ -2878,7 +2878,7 @@
- unsigned char buf[256];
-
- va_start(arg_ptr, fmt);
-- vsprintf((char *)buf, fmt, arg_ptr);
-+ vsnprintf((char *)buf, sizeof(buf), fmt, arg_ptr);
- va_end(arg_ptr);
- rxvt_tt_write(r, buf, (unsigned int)STRLEN(buf));
- }
diff --git a/x11/rxvt-devel/files/patch-src__init.c b/x11/rxvt-devel/files/patch-src__init.c
deleted file mode 100644
index 262158bd0e6b..000000000000
--- a/x11/rxvt-devel/files/patch-src__init.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/init.c.orig Wed Dec 4 03:21:17 2002
-+++ src/init.c Mon Oct 10 00:30:31 2005
-@@ -1531,6 +1531,9 @@
- # ifdef VEOL2
- tio->c_cc[VEOL2] = VDISABLE;
- # endif
-+# ifdef VERASE2
-+ tio->c_cc[VERASE2] = CERASE2;
-+# endif
- # ifdef VSWTC
- tio->c_cc[VSWTC] = VDISABLE;
- # endif
-@@ -1650,6 +1653,9 @@
- FOO(VEOL, "VEOL");
- # ifdef VEOL2
- FOO(VEOL2, "VEOL2");
-+# endif
-+# ifdef VERASE2
-+ FOO(VERASE2, "VERASE2");
- # endif
- # ifdef VSWTC
- FOO(VSWTC, "VSWTC");
diff --git a/x11/rxvt-devel/files/patch-src__rxvt.h b/x11/rxvt-devel/files/patch-src__rxvt.h
deleted file mode 100644
index c3c5b44495c5..000000000000
--- a/x11/rxvt-devel/files/patch-src__rxvt.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/rxvt.h
-+++ src/rxvt.h
-@@ -804,7 +804,7 @@
- #define rxvt_Gr_ButtonRelease(x,y) rxvt_Gr_ButtonReport (r, 'R',(x),(y))
-
- #ifdef UTMP_SUPPORT
--# if !defined(RXVT_UTMPX_FILE) || !defined(HAVE_STRUCT_UTMPX)
-+# if !defined(HAVE_STRUCT_UTMPX)
- # undef HAVE_UTMPX_H
- # undef HAVE_STRUCT_UTMPX
- # endif
diff --git a/x11/rxvt-devel/files/patch-src__screen.c b/x11/rxvt-devel/files/patch-src__screen.c
deleted file mode 100644
index 1691e3704745..000000000000
--- a/x11/rxvt-devel/files/patch-src__screen.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- src/screen.c.orig 2003-03-23 17:56:06.000000000 +0100
-+++ src/screen.c 2011-04-19 23:27:32.000000000 +0200
-@@ -3520,6 +3520,7 @@
- Atom32 target_list[3];
- #endif
- Atom target;
-+ Atom property;
- XTextProperty ct;
- XICCEncodingStyle style;
- char *cl[2], dummy[1];
-@@ -3532,6 +3533,15 @@
- ev.target = rq->target;
- ev.time = rq->time;
-
-+ /* ICCCM: 2.2. Responsibilities of the Selection Owner
-+ * SelectionRequest:
-+ * If the specified property is None , the requestor
-+ * an obsolete client. Owners are encouraged
-+ * to support these clients by using the specified
-+ * target atom as the property name to be used for
-+ * the reply.
-+ */
-+ property = (rq->property == 0) ? rq->target : rq->property;
- if (rq->target == r->h->xa[XA_TARGETS]) {
- target_list[0] = (Atom32) r->h->xa[XA_TARGETS];
- target_list[1] = (Atom32) XA_STRING;
-@@ -3539,7 +3549,7 @@
- #ifdef USE_XIM
- target_list[3] = (Atom32) r->h->xa[XA_COMPOUND_TEXT];
- #endif
-- XChangeProperty(r->Xdisplay, rq->requestor, rq->property, XA_ATOM,
-+ XChangeProperty(r->Xdisplay, rq->requestor, property, XA_ATOM,
- (8 * sizeof(target_list[0])), PropModeReplace,
- (unsigned char *)target_list,
- (sizeof(target_list) / sizeof(target_list[0])));
-@@ -3547,10 +3557,10 @@
- } else if (rq->target == r->h->xa[XA_MULTIPLE]) {
- /* TODO: Handle MULTIPLE */
- } else if (rq->target == r->h->xa[XA_TIMESTAMP] && r->selection.text) {
-- XChangeProperty(r->Xdisplay, rq->requestor, rq->property, XA_INTEGER,
-- (8 * sizeof(Time)), PropModeReplace,
-+ XChangeProperty(r->Xdisplay, rq->requestor, property, XA_INTEGER,
-+ 32, PropModeReplace,
- (unsigned char *)&r->h->selection_time, 1);
-- ev.property = rq->property;
-+ ev.property = property;
- } else if (rq->target == XA_STRING
- || rq->target == r->h->xa[XA_COMPOUND_TEXT]
- || rq->target == r->h->xa[XA_TEXT]) {
-@@ -3588,10 +3598,10 @@
- ct.value = (unsigned char *)cl[0];
- ct.nitems = selectlen;
- }
-- XChangeProperty(r->Xdisplay, rq->requestor, rq->property,
-+ XChangeProperty(r->Xdisplay, rq->requestor, property,
- target, 8, PropModeReplace,
- ct.value, (int)ct.nitems);
-- ev.property = rq->property;
-+ ev.property = property;
- #ifdef USE_XIM
- if (freect)
- XFree(ct.value);
diff --git a/x11/rxvt-devel/files/utmp_patch-src::logging.c b/x11/rxvt-devel/files/utmp_patch-src::logging.c
deleted file mode 100644
index 20f9e436a24a..000000000000
--- a/x11/rxvt-devel/files/utmp_patch-src::logging.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/logging.c
-+++ src/logging.c
-@@ -82,7 +82,8 @@
- else if (sscanf(pty, "pts/%d", &i) == 1)
- sprintf(ut_id, "vt%02x", (i & 0xff)); /* sysv naming */
- #endif
-- else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3)) {
-+ else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3) &&
-+ STRNCMP(pty, "pts/", 4)) {
- rxvt_print_error("can't parse tty name \"%s\"", pty);
- return;
- }
diff --git a/x11/rxvt-devel/files/utmpx_patch-src::logging.c b/x11/rxvt-devel/files/utmpx_patch-src::logging.c
deleted file mode 100644
index 80f1a96def9e..000000000000
--- a/x11/rxvt-devel/files/utmpx_patch-src::logging.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/logging.c
-+++ src/logging.c
-@@ -82,7 +82,8 @@
- else if (sscanf(pty, "pts/%d", &i) == 1)
- sprintf(ut_id, "vt%02x", (i & 0xff)); /* sysv naming */
- #endif
-- else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3)) {
-+ else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3) &&
-+ STRNCMP(pty, "pts/", 4)) {
- rxvt_print_error("can't parse tty name \"%s\"", pty);
- return;
- }
-@@ -137,7 +138,9 @@
- STRNCPY(utx->ut_user, (pwent && pwent->pw_name) ? pwent->pw_name : "?",
- sizeof(utx->ut_user));
- STRNCPY(utx->ut_id, ut_id, sizeof(utx->ut_id));
-+#if 0
- utx->ut_session = getsid(0);
-+#endif
- utx->ut_tv.tv_sec = time(NULL);
- utx->ut_tv.tv_usec = 0;
- utx->ut_pid = r->h->cmd_pid;
-@@ -202,7 +205,7 @@
- rxvt_update_wtmp(RXVT_WTMP_FILE, ut);
- # endif
- # endif
--# ifdef HAVE_STRUCT_UTMPX
-+# if 0
- updwtmpx(RXVT_WTMPX_FILE, utx);
- # endif
- }
-@@ -254,7 +257,9 @@
- if ((tmputx = getutxid(utx))) /* position to entry in utmp file */
- utx = tmputx;
- utx->ut_type = DEAD_PROCESS;
-+#if 0
- utx->ut_session = getsid(0);
-+#endif
- utx->ut_tv.tv_sec = time(NULL);
- utx->ut_tv.tv_usec = 0;
- #endif
-@@ -274,7 +279,7 @@
- rxvt_update_wtmp(RXVT_WTMP_FILE, ut);
- # endif
- # endif
--# ifdef HAVE_STRUCT_UTMPX
-+# if 0
- updwtmpx(RXVT_WTMPX_FILE, utx);
- # endif
- }
diff --git a/x11/rxvt-devel/pkg-descr b/x11/rxvt-devel/pkg-descr
deleted file mode 100644
index d0cc4b6cda2a..000000000000
--- a/x11/rxvt-devel/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-Rxvt is an xterm replacement which uses a little less memory, and
-is suitable for use on machines with small memories. Tek4010 support
-is removed.
-
-Modifications were made by Rob Nation (nation@rocket.sanders.lockheed.com)
-to make it a little more compact, and to add and remove certain
-features.
diff --git a/x11/rxvt-devel/pkg-plist b/x11/rxvt-devel/pkg-plist
deleted file mode 100644
index cd1f3fad0559..000000000000
--- a/x11/rxvt-devel/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/rxvt
-bin/rxvt-2.7.10
-include/rxvtlib.h
-lib/librxvt.a
-lib/librxvt.so
-lib/librxvt.so.1
-lib/librxvt.so.1.0.0
-man/man1/rxvt.1.gz