aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-unicode
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2012-12-30 18:43:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2012-12-30 18:43:39 +0000
commit56980212e33dc73f0defcb6f7335b8cfc0a2f43e (patch)
tree0f667bbc410c0ea235441d626343632bc9a64907 /x11/rxvt-unicode
parentd5617b8932347ec3ca13c1acb47b0e68fe4ee2af (diff)
downloadports-56980212e33dc73f0defcb6f7335b8cfc0a2f43e.tar.gz
ports-56980212e33dc73f0defcb6f7335b8cfc0a2f43e.zip
Notes
Diffstat (limited to 'x11/rxvt-unicode')
-rw-r--r--x11/rxvt-unicode/Makefile23
-rw-r--r--x11/rxvt-unicode/distinfo4
-rw-r--r--x11/rxvt-unicode/files/extra-patch-imlocale16
-rw-r--r--x11/rxvt-unicode/pkg-plist1
4 files changed, 23 insertions, 21 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 3ef7e0fbd982..e47e4f111d1b 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rxvt-unicode
-PORTVERSION= 9.15
-PORTREVISION= 2
+PORTVERSION= 9.16
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
@@ -31,7 +30,7 @@ WANT_PERL= yes
OPTIONS_DEFINE= PERL XIM UNICODE3 ISO14755 COMBINING RXVT_SCROLLBAR \
NEXT_SCROLLBAR XTERM_SCROLLBAR BACKSPACE_KEY DELETE_KEY \
MOUSEWHEEL SMART_RESIZE IMLOCALE_FIX GDK_PIXBUF \
- AFTERIMAGE NOTIFY 256_COLOR
+ NOTIFY 256_COLOR
PERL_DESC= Embedded Perl interpreter
XIM_DESC= Support for XIM (X Input Method) protocol
@@ -47,7 +46,6 @@ MOUSEWHEEL_DESC= Support for scrolling via mouse wheel
SMART_RESIZE_DESC= Smart growth/shrink behaviour
IMLOCALE_FIX_DESC= imlocale encoding conversion fix
GDK_PIXBUF_DESC= Use gdk-pixbuf for background images
-AFTERIMAGE_DESC= Use libAfterImage for background images
NOTIFY_DESC= Freedesktop startup notification support
256_COLOR_DESC= Support for 256 colors
@@ -75,6 +73,15 @@ USE_PERL5_BUILD= yes
PLIST_SUB= PERL="@comment "
.else
USE_PERL5= yes
+MAN1+= urxvt-background.1 urxvt-bell-command.1 urxvt-block-graphics-to-ascii.1 \
+ urxvt-clipboard-osc.1 urxvt-confirm-paste.1 urxvt-digital-clock.1 \
+ urxvt-example-refresh-hooks.1 urxvt-extensions.1 urxvt-keysym-list.1 \
+ urxvt-kuake.1 urxvt-macosx-clipboard-native.1 urxvt-macosx-clipboard.1 \
+ urxvt-matcher.1 urxvt-option-popup.1 urxvt-overlay-osc.1 \
+ urxvt-readline.1 urxvt-remote-clipboard.1 urxvt-searchable-scrollback.1 \
+ urxvt-selection-autotransform.1 urxvt-selection-pastebin.1 \
+ urxvt-selection-popup.1 urxvt-selection.1 urxvt-tabbed.1 \
+ urxvt-xim-onthespot.1
MAN3= urxvtperl.3
PLIST_SUB= PERL=""
.endif
@@ -138,15 +145,9 @@ CONFIGURE_ARGS+= --disable-smart-resize
CONFIGURE_ARGS+= --enable-smart-resize
.endif
-# enable integration with gdk-pixbuf / or libAfterImage for background images
+# enable integration with gdk-pixbuf
.if !${PORT_OPTIONS:MGDK_PIXBUF}
CONFIGURE_ARGS+= --disable-pixbuf
-. if !${PORT_OPTIONS:MAFTERIMAGE}
-CONFIGURE_ARGS+= --disable-afterimage # To be upgraded
-. else
-LIB_DEPENDS+= AfterImage:${PORTSDIR}/graphics/libafterimage
-CONFIGURE_ARGS+= --enable-afterimage
-. endif
.else
USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+= --enable-pixbuf
diff --git a/x11/rxvt-unicode/distinfo b/x11/rxvt-unicode/distinfo
index 05e9616f33c9..75c4befc8753 100644
--- a/x11/rxvt-unicode/distinfo
+++ b/x11/rxvt-unicode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rxvt-unicode-9.15.tar.bz2) = ec1aa2932da844979ed8140bd92223defb12042aa5e877e05ac31139ca81f2b1
-SIZE (rxvt-unicode-9.15.tar.bz2) = 894764
+SHA256 (rxvt-unicode-9.16.tar.bz2) = 76bb15cdc8cc7709b01389727f7d818f1f401b6616121f0216165a4cb5e74874
+SIZE (rxvt-unicode-9.16.tar.bz2) = 898089
diff --git a/x11/rxvt-unicode/files/extra-patch-imlocale b/x11/rxvt-unicode/files/extra-patch-imlocale
index b075de9480d6..8fb82bd37eb8 100644
--- a/x11/rxvt-unicode/files/extra-patch-imlocale
+++ b/x11/rxvt-unicode/files/extra-patch-imlocale
@@ -1,8 +1,8 @@
---- src/command.C.orig 2011-06-22 14:44:37.000000000 +0400
-+++ src/command.C 2011-09-30 01:31:30.000000000 +0400
-@@ -256,6 +256,26 @@
+--- src/command.C.orig 2012-12-30 19:06:27.000000000 +0100
++++ src/command.C 2012-12-30 19:09:32.000000000 +0100
+@@ -403,6 +403,26 @@
+ return param;
}
- #endif
+void from_imlocale_to_locale(const char *imlocale, const char *locale, wchar_t *wkbuf, int len)
+{
@@ -24,16 +24,16 @@
+ }
+}
+
- void
- rxvt_term::commit_iso14755 ()
+ void ecb_cold
+ rxvt_term::key_press (XKeyEvent &ev)
{
-@@ -451,6 +471,9 @@
+@@ -456,6 +476,9 @@
if (rs[Rs_imLocale])
SET_LOCALE (locale);
+ if (rs[Rs_imLocale])
+ from_imlocale_to_locale(rs[Rs_imLocale], locale, wkbuf, len);
-+
++
if (status_return == XLookupChars
|| status_return == XLookupBoth)
{
diff --git a/x11/rxvt-unicode/pkg-plist b/x11/rxvt-unicode/pkg-plist
index 91b6e8efefae..d5af5059b1b4 100644
--- a/x11/rxvt-unicode/pkg-plist
+++ b/x11/rxvt-unicode/pkg-plist
@@ -2,6 +2,7 @@ bin/urxvt
bin/urxvtc
bin/urxvtcd
bin/urxvtd
+%%PERL%%lib/urxvt/perl/background
%%PERL%%lib/urxvt/perl/bell-command
%%PERL%%lib/urxvt/perl/block-graphics-to-ascii
%%PERL%%lib/urxvt/perl/clipboard-osc