aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-unicode
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /x11/rxvt-unicode
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Notes
Diffstat (limited to 'x11/rxvt-unicode')
-rw-r--r--x11/rxvt-unicode/Makefile3
-rw-r--r--x11/rxvt-unicode/files/patch-configure45
2 files changed, 47 insertions, 1 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 2a6ee74aa249..cadac20c5536 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -21,7 +21,8 @@ USES= pkgconfig shebangfix tar:bzip2
USE_XORG= xpm xft xrender
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LIBS="-lstdc++ -lutil" TIC=${LOCALBASE}/bin/tic
+LIBS+= -lutil
+CONFIGURE_ENV= TIC=${LOCALBASE}/bin/tic
CONFIGURE_ARGS= --enable-everything --with-term=rxvt \
--with-terminfo=${LOCALBASE}/share/misc/terminfo.db
diff --git a/x11/rxvt-unicode/files/patch-configure b/x11/rxvt-unicode/files/patch-configure
new file mode 100644
index 000000000000..eb5b7445d233
--- /dev/null
+++ b/x11/rxvt-unicode/files/patch-configure
@@ -0,0 +1,45 @@
+--- configure.orig
++++ configure
+@@ -4436,42 +4436,6 @@
+
+
+ LINKER="$CXX"
+-if test x$GCC = xyes && test x$GXX = xyes; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for working libsupc++" >&5
+-$as_echo_n "checking for working libsupc++... " >&6; }
+- save_CXX="$CXX"
+- save_LIBS="$LIBS"
+- CXX="$CC"
+- LIBS="$LIBS -lsupc++"
+-
+-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-struct test { }; void f() try { throw new test; } catch (...) { throw; }
+-int
+-main ()
+-{
+-
+- ;
+- return 0;
+-}
+-_ACEOF
+-if ac_fn_cxx_try_link "$LINENO"; then :
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: ok" >&5
+-$as_echo "ok" >&6; }
+- LINKER="$CC"
+-else
+-
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no, making everything bigger and slower" >&5
+-$as_echo "no, making everything bigger and slower" >&6; }
+- LIBS="$save_LIBS"
+-
+-
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+- CXX="$save_CXX"
+-fi
+-LINKER=$LINKER
+
+
+ if test -z "$orig_CXXFLAGS"; then