aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt-unicode
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2012-08-26 12:03:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2012-08-26 12:03:29 +0000
commit5bb88589f1a7410e0e7fa764192007c3be63454c (patch)
tree058b87c084423e2e49e8152998ccffe79bcd83d5 /x11/rxvt-unicode
parentacf555252ece3aa90d99758d07160cb4aa1394ca (diff)
downloadports-5bb88589f1a7410e0e7fa764192007c3be63454c.tar.gz
ports-5bb88589f1a7410e0e7fa764192007c3be63454c.zip
Notes
Diffstat (limited to 'x11/rxvt-unicode')
-rw-r--r--x11/rxvt-unicode/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 30e0926b0316..e70cd0524a27 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rxvt-unicode
PORTVERSION= 9.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= http://dist.schmorp.de/rxvt-unicode/%SUBDIR%/
MASTER_SITE_SUBDIR= . Attic
@@ -26,7 +26,7 @@ USE_GNOME= pkgconfig
USE_XORG= xpm xft xrender
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LIBS="-lutil"
+CONFIGURE_ENV= LIBS="-lstdc++ -lutil"
CONFIGURE_ARGS= --enable-everything --with-term=rxvt \
--with-terminfo=${LOCALBASE}/share/misc/terminfo.db
USE_BZIP2= yes
@@ -48,6 +48,7 @@ OPTIONS= \
IMLOCALE_FIX "imlocale encoding conversion fix" On \
GDK_PIXBUF "Use gdk-pixbuf for background images" On \
AFTERIMAGE "Use libAfterImage for background images" Off \
+ NOTIFY "Freedesktop startup notification support" Off \
256_COLOR "Support for 256 colors" Off
.include <bsd.port.pre.mk>
@@ -139,7 +140,7 @@ CONFIGURE_ARGS+= --disable-pixbuf
. if defined(WITHOUT_AFTERIMAGE)
CONFIGURE_ARGS+= --disable-afterimage # To be upgraded
. else
-LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
+LIB_DEPENDS+= AfterImage:${PORTSDIR}/graphics/libafterimage
CONFIGURE_ARGS+= --enable-afterimage
. endif
.else
@@ -147,6 +148,14 @@ USE_GNOME+= gdkpixbuf2
CONFIGURE_ARGS+= --enable-pixbuf
.endif
+# enable startup notification
+.if defined(WITHOUT_NOTIFY)
+CONFIGURE_ARGS+= --disable-startup-notification
+.else
+CONFIGURE_ARGS+= --enable-startup-notification
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
+.endif
+
# enable support for 256 colors
.if defined(WITH_256_COLOR)
CONFIGURE_ARGS+= --enable-256-color