aboutsummaryrefslogtreecommitdiff
path: root/x11/rxvt
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-10 03:36:09 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-10 03:36:09 +0000
commit606852512447fbfd0cb65fdc209c8483242453e1 (patch)
tree94b70715881c40edc1567aae787f3094dbc01e0d /x11/rxvt
parentdaf407906dfa1e37d3ef99c9c76d37d540b5fcc1 (diff)
downloadports-606852512447fbfd0cb65fdc209c8483242453e1.tar.gz
ports-606852512447fbfd0cb65fdc209c8483242453e1.zip
Notes
Diffstat (limited to 'x11/rxvt')
-rw-r--r--x11/rxvt/Makefile2
-rw-r--r--x11/rxvt/files/patch-ad26
2 files changed, 24 insertions, 4 deletions
diff --git a/x11/rxvt/Makefile b/x11/rxvt/Makefile
index a38af9801cdf..76b5e2889b05 100644
--- a/x11/rxvt/Makefile
+++ b/x11/rxvt/Makefile
@@ -10,7 +10,7 @@
PORTNAME= rxvt
PORTVERSION= 2.6.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/%SUBDIR%/ \
ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/rxvt/%SUBDIR%/ \
diff --git a/x11/rxvt/files/patch-ad b/x11/rxvt/files/patch-ad
index c057993b80dc..eb7db3a2dc0b 100644
--- a/x11/rxvt/files/patch-ad
+++ b/x11/rxvt/files/patch-ad
@@ -1,5 +1,5 @@
---- src/command.c.orig Thu Apr 5 03:52:39 2001
-+++ src/command.c Fri Jun 22 13:36:57 2001
+--- src/command.c.orig Thu Nov 1 22:18:35 2001
++++ src/command.c Mon Oct 10 00:29:07 2005
@@ -322,7 +322,7 @@
ttydev = tty_name;
@@ -9,7 +9,27 @@
for (c1 = PTYCHAR1; *c1; c1++) {
ptydev[len] = ttydev[len] = *c1;
for (c2 = PTYCHAR2; *c2; c2++) {
-@@ -2376,7 +2376,7 @@
+@@ -519,6 +519,9 @@
+ # ifdef VEOL2
+ FOO(VEOL2, "VEOL2");
+ # endif
++# ifdef VERASE2
++ FOO(VERASE2, "VERASE2");
++# endif
+ # ifdef VSWTC
+ FOO(VSWTC, "VSWTC");
+ # endif
+@@ -596,6 +599,9 @@
+ # ifdef VSWTCH
+ tio->c_cc[VSWTCH] = VDISABLE;
+ # endif
++# ifdef VERASE2
++ tio->c_cc[VERASE2] = CERASE2;
++# endif
+ # if VMIN != VEOF
+ tio->c_cc[VMIN] = 1;
+ # endif
+@@ -2376,7 +2382,7 @@
unsigned char buf[256];
va_start(arg_ptr, fmt);