aboutsummaryrefslogtreecommitdiff
path: root/x11/slim
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-04-09 11:57:24 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-04-09 11:57:24 +0000
commit9861d38aaba98827d8dc9f0dd586548ea447465b (patch)
tree0a1323f52ca39dc38efaf105a8d30c07b84cfddc /x11/slim
parent759a433b5b2c1cd0047e7c5c2389c1021bfe15c1 (diff)
downloadports-9861d38aaba98827d8dc9f0dd586548ea447465b.tar.gz
ports-9861d38aaba98827d8dc9f0dd586548ea447465b.zip
Notes
Diffstat (limited to 'x11/slim')
-rw-r--r--x11/slim/Makefile1
-rw-r--r--x11/slim/files/patch-cfg.cpp12
2 files changed, 13 insertions, 0 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 2311f67efaca..b4b651a09ca5 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= slim
PORTVERSION= 1.2.6
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://depot.fsck.ch/mirror/distfiles/
diff --git a/x11/slim/files/patch-cfg.cpp b/x11/slim/files/patch-cfg.cpp
new file mode 100644
index 000000000000..9a99a33d0a92
--- /dev/null
+++ b/x11/slim/files/patch-cfg.cpp
@@ -0,0 +1,12 @@
+--- cfg.cpp.orig Sat Sep 16 05:00:37 2006
++++ cfg.cpp Mon Apr 9 19:52:17 2007
+@@ -211,8 +211,7 @@
+ int n = -1;
+ n = position.find("%");
+ if (n>0) { // X Position expressed in percentage
+- const char* tmp = position.substr(0, n).c_str();
+- int result = (max*string2int(tmp)/100) - (width / 2);
++ int result = (max*string2int(position.substr(0, n).c_str())/100) - (width / 2);
+ return result < 0 ? 0 : result ;
+ } else { // Absolute X position
+ return string2int(position.c_str());