aboutsummaryrefslogtreecommitdiff
path: root/x11/slurp/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-01-13 20:13:20 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-01-13 20:13:20 +0000
commitbea55972c51c57cd08625d30061ae4c8587631f0 (patch)
treea722815a274e5cd257134cd2fcafdddfc9cac8e1 /x11/slurp/Makefile
parent65db53357802bac64fc74f62a380d40a8202d65b (diff)
downloadports-bea55972c51c57cd08625d30061ae4c8587631f0.tar.gz
ports-bea55972c51c57cd08625d30061ae4c8587631f0.zip
Notes
Diffstat (limited to 'x11/slurp/Makefile')
-rw-r--r--x11/slurp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11/slurp/Makefile b/x11/slurp/Makefile
new file mode 100644
index 000000000000..6f382e741db6
--- /dev/null
+++ b/x11/slurp/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= slurp
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Select a region in a Wayland compositor
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>=1.14:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo
+GH_ACCOUNT= emersion
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+post-patch-MANPAGES-off:
+ @${REINPLACE_CMD} -i '' "s/'scdoc/&-disabled/" ${WRKSRC}/meson.build
+
+.include <bsd.port.mk>