aboutsummaryrefslogtreecommitdiff
path: root/x11/stalonetray
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-04-08 03:05:55 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-04-08 03:05:55 +0000
commit3b917d9d28a0c7283c0ed75ab9a946be53bac7a6 (patch)
treea4859b158285fe66aa4d0caff8c97b3189b79a76 /x11/stalonetray
parent0864e90ae1c69fa65552e8fc0d530d973d34bc01 (diff)
downloadports-3b917d9d28a0c7283c0ed75ab9a946be53bac7a6.tar.gz
ports-3b917d9d28a0c7283c0ed75ab9a946be53bac7a6.zip
Add stalonetray 0.3, STAnd-aLONE system tray.
PR: ports/95393 Submitted by: Stepan Zastupov [RedChrom] <redchrom@gmail.com>
Notes
Notes: svn path=/head/; revision=159093
Diffstat (limited to 'x11/stalonetray')
-rw-r--r--x11/stalonetray/Makefile31
-rw-r--r--x11/stalonetray/distinfo3
-rw-r--r--x11/stalonetray/files/patch-src-main.c23
-rw-r--r--x11/stalonetray/pkg-descr6
4 files changed, 63 insertions, 0 deletions
diff --git a/x11/stalonetray/Makefile b/x11/stalonetray/Makefile
new file mode 100644
index 000000000000..0eb86a0ec9f3
--- /dev/null
+++ b/x11/stalonetray/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: stalonetray
+# Date created: Apr 6 2006
+# Whom: Stepan Zastupov [RedChrom] <redchrom@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= stalonetray
+PORTVERSION= 0.3
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= redchrom@gmail.com
+COMMENT= STAnd-aLONE system tray
+
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-native-kde --disable-debug
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo"
+
+MAN1= stalonetray.1
+PLIST_FILES= bin/stalonetray
+
+.include <bsd.port.mk>
diff --git a/x11/stalonetray/distinfo b/x11/stalonetray/distinfo
new file mode 100644
index 000000000000..3238b811205b
--- /dev/null
+++ b/x11/stalonetray/distinfo
@@ -0,0 +1,3 @@
+MD5 (stalonetray_0.3.tar.bz2) = 5f97e479a17f22f0a85896e7beead99c
+SHA256 (stalonetray_0.3.tar.bz2) = 59b0e88fa581fe5ad8cc899a260579c6689fa72506f639b8d8aa3903edc40389
+SIZE (stalonetray_0.3.tar.bz2) = 111612
diff --git a/x11/stalonetray/files/patch-src-main.c b/x11/stalonetray/files/patch-src-main.c
new file mode 100644
index 000000000000..b925b59922e9
--- /dev/null
+++ b/x11/stalonetray/files/patch-src-main.c
@@ -0,0 +1,23 @@
+--- src/main.c.orig Thu Apr 6 14:16:26 2006
++++ src/main.c Thu Apr 6 14:16:06 2006
+@@ -423,16 +423,20 @@
+ unlayout_icon(ti); /* or hide ? */
+ return;
+ }
++#ifdef DEBUG
+ print_icon_data(ti);
++#endif
+ update_positions();
+ tray_set_constraints();
+ DBG(4, "icon position were updated\n");
+ } else {
+ hide_window(ti);
+ }
++#ifdef DEBUG
+ DBG(4, "====================\n");
+ forall_icons(&print_icon_data);
+ DBG(4, "====================\n");
++#endif
+ }
+ }
+ }
diff --git a/x11/stalonetray/pkg-descr b/x11/stalonetray/pkg-descr
new file mode 100644
index 000000000000..64eea430c2d3
--- /dev/null
+++ b/x11/stalonetray/pkg-descr
@@ -0,0 +1,6 @@
+The stalonetray is a STAnd-aLONE system tray (notification area).
+It has minimal build and run-time dependencies: the Xlib only.
+The XEMBED support is planned. Stalonetray runs under virtually
+any window manager.
+
+WWW: http://sourceforge.net/projects/stalonetray