aboutsummaryrefslogtreecommitdiff
path: root/x11/sterm
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-07-04 06:14:25 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-07-04 06:14:25 +0000
commit0ef4da519e393fb40b38c94db54082976a7ff3a4 (patch)
treedf3eb00d707554313547400187129420b34ea4a7 /x11/sterm
parente35eb069bd85d49a866de9904dba89fc7a557f75 (diff)
downloadports-0ef4da519e393fb40b38c94db54082976a7ff3a4.tar.gz
ports-0ef4da519e393fb40b38c94db54082976a7ff3a4.zip
Notes
Diffstat (limited to 'x11/sterm')
-rw-r--r--x11/sterm/Makefile11
-rw-r--r--x11/sterm/distinfo4
-rw-r--r--x11/sterm/files/patch-Makefile12
-rw-r--r--x11/sterm/files/patch-config.mk11
4 files changed, 15 insertions, 23 deletions
diff --git a/x11/sterm/Makefile b/x11/sterm/Makefile
index 24fe1909dae4..6fdf95f72e9d 100644
--- a/x11/sterm/Makefile
+++ b/x11/sterm/Makefile
@@ -2,20 +2,23 @@
# $FreeBSD$
PORTNAME= sterm
-PORTVERSION= 0.3
+PORTVERSION= 0.4.1
CATEGORIES= x11
MASTER_SITES= http://dl.suckless.org/st/
DISTNAME= st-${PORTVERSION}
MAINTAINER= kitche@kitchetech.com
-COMMENT= A simple X terminal
+COMMENT= Simple X terminal
-LICENSE= BSD
+LICENSE= MITX
+LICENSE_NAME= MIT/X Consortium License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
freetype:${PORTSDIR}/print/freetype2
-RUN_DEPENDS= ${LOCALBASE}/share/misc/terminfo.db:${PORTSDIR}/devel/ncurses
+USES= pkgconfig ncurses:port
USE_XORG= x11 xext xft
MAN1= st.1
PLIST_FILES= bin/st
diff --git a/x11/sterm/distinfo b/x11/sterm/distinfo
index baa6cae85e91..5cece191fe09 100644
--- a/x11/sterm/distinfo
+++ b/x11/sterm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (st-0.3.tar.gz) = 6d6ca8e8a110530caf97538eab96f0ec28ad2dc419054afeea91e8187b940e34
-SIZE (st-0.3.tar.gz) = 24424
+SHA256 (st-0.4.1.tar.gz) = ee2f93c6d8cd95a5ab47423eeebde4a474be470309ceee33fa3c7757eae2bf31
+SIZE (st-0.4.1.tar.gz) = 32947
diff --git a/x11/sterm/files/patch-Makefile b/x11/sterm/files/patch-Makefile
index ccb4965174e8..ba4a83391616 100644
--- a/x11/sterm/files/patch-Makefile
+++ b/x11/sterm/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig 2012-11-02 20:09:49.000000000 +0100
-+++ Makefile 2012-11-26 21:33:04.882099791 +0100
-@@ -50,7 +50,7 @@
+--- Makefile.orig 2013-06-26 00:09:00.000000000 -0500
++++ Makefile 2013-06-26 00:10:14.000000000 -0500
+@@ -49,7 +49,7 @@
+ @sed "s/VERSION/${VERSION}/g" < st.1 > ${DESTDIR}${MANPREFIX}/man1/st.1
@chmod 644 ${DESTDIR}${MANPREFIX}/man1/st.1
- @echo If things do not seem to work, be sure that there is no \
- floating st terminfo in the .terminfo directory in your home dir.
+ @echo Please see the README file regarding the terminfo entry of st.
- @tic -s st.info
-+ @tic -s -o ${LOCALBASE}/share/misc st.info
++ @tic -s -o ${LOCALBASE}/share/misc st.info
uninstall:
@echo removing executable file from ${DESTDIR}${PREFIX}/bin
diff --git a/x11/sterm/files/patch-config.mk b/x11/sterm/files/patch-config.mk
deleted file mode 100644
index 9b764c43d099..000000000000
--- a/x11/sterm/files/patch-config.mk
+++ /dev/null
@@ -1,11 +0,0 @@
---- config.mk.orig 2012-11-02 20:09:49.000000000 +0100
-+++ config.mk 2012-11-26 22:28:12.270095047 +0100
-@@ -11,7 +11,7 @@
- X11LIB = /usr/X11R6/lib
-
- # includes and libs
--INCS = -I. -I/usr/include -I${X11INC} -I/usr/include/freetype2
-+INCS = -I. -I/usr/include -I${X11INC} -I${X11INC}/freetype2
- LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lutil -lXext -lXft -lfontconfig
-
- # flags