aboutsummaryrefslogtreecommitdiff
path: root/x11/tabbed/files
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-01-29 21:30:31 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-01-29 21:30:31 +0000
commitac7f329881c547ab02d2f946cad6204530669ba1 (patch)
treeb8ab49c1633a10e377fd6f7d672f21996df2649c /x11/tabbed/files
parent192712b7da1c422001afe63efd2506c090c9928e (diff)
downloadports-ac7f329881c547ab02d2f946cad6204530669ba1.tar.gz
ports-ac7f329881c547ab02d2f946cad6204530669ba1.zip
Notes
Diffstat (limited to 'x11/tabbed/files')
-rw-r--r--x11/tabbed/files/patch-config.mk64
1 files changed, 39 insertions, 25 deletions
diff --git a/x11/tabbed/files/patch-config.mk b/x11/tabbed/files/patch-config.mk
index a6e5ed4e804e..cbb51cbf5d80 100644
--- a/x11/tabbed/files/patch-config.mk
+++ b/x11/tabbed/files/patch-config.mk
@@ -1,25 +1,39 @@
---- config.mk.orig 2010-09-03 23:40:32.000000000 -0500
-+++ config.mk 2010-09-03 23:42:18.000000000 -0500
-@@ -4,12 +4,12 @@
- # Customize below to fit your system
-
- # paths
--PREFIX = /usr/local
--MANPREFIX = ${PREFIX}/share/man
-+PREFIX?= /usr/local
-+MANPREFIX = ${PREFIX}/man
-
- # includes and libs
--INCS = -I. -I/usr/include
--LIBS = -L/usr/lib -lc -lX11
-+INCS = -I. -I/usr/include -I/usr/local/include
-+LIBS = -L/usr/lib -L/usr/local/lib -lc -lX11
-
- # flags
- CPPFLAGS = -DVERSION=\"${VERSION}\"
-@@ -21,4 +21,4 @@
- #LDFLAGS = ${LIBS}
-
- # compiler and linker
--CC = cc
-+CC?= cc
+*** config.mk.orig 2014-01-19 21:53:24.000000000 +0400
+--- config.mk 2014-01-19 22:40:13.000000000 +0400
+***************
+*** 5,15 ****
+
+ # paths
+ PREFIX = /usr/local
+! MANPREFIX = ${PREFIX}/share/man
+
+ # includes and libs
+! INCS = -I. -I/usr/include
+! LIBS = -L/usr/lib -lc -lX11
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
+--- 5,15 ----
+
+ # paths
+ PREFIX = /usr/local
+! MANPREFIX = ${PREFIX}/man
+
+ # includes and libs
+! INCS = -I. -I/usr/local/include
+! LIBS = -L/usr/local/lib -lc -lX11
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\" -D_BSD_SOURCE
+***************
+*** 21,25 ****
+ #LDFLAGS = ${LIBS}
+
+ # compiler and linker
+! CC = cc
+
+--- 21,25 ----
+ #LDFLAGS = ${LIBS}
+
+ # compiler and linker
+! CC?= cc