aboutsummaryrefslogtreecommitdiff
path: root/x11/terminal.app/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-09-06 19:22:27 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-09-06 19:22:27 +0000
commit6a6647e0f5df54883bf4d96b8d1430fc2da6e21b (patch)
tree8b6178d5a0916ac3e683dea7baaae4856306badc /x11/terminal.app/Makefile
parentd6e043f3dc03583bb386dc7db7158964e2905406 (diff)
downloadports-6a6647e0f5df54883bf4d96b8d1430fc2da6e21b.tar.gz
ports-6a6647e0f5df54883bf4d96b8d1430fc2da6e21b.zip
Notes
Diffstat (limited to 'x11/terminal.app/Makefile')
-rw-r--r--x11/terminal.app/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11/terminal.app/Makefile b/x11/terminal.app/Makefile
new file mode 100644
index 000000000000..669042a90a26
--- /dev/null
+++ b/x11/terminal.app/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: terminal.app
+# Date created: 28 Aug 2006
+# Whom: gurkan@linuks.mine.nu
+#
+# $FreeBSD$
+#
+
+PORTNAME= terminal.app
+PORTVERSION= 0.9.4
+DISTVERSIONSUFFIX= +cvs20051125.orig
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+DISTNAME= ${PORTNAME}_${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= gurkan@linuks.mine.nu
+COMMENT= Terminal Emulator for GNUstep
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PORTNAME:C/\.app//}-${DISTVERSION}${DISTVERSIONSUFFIX:C/\.orig//}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>