aboutsummaryrefslogtreecommitdiff
path: root/x11/thingylaunch
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-04-14 14:30:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-04-14 14:30:41 +0000
commit264fd13ea4df858b24257835a6d0fc07eb917b97 (patch)
tree433f1d0b403bb1692f5b6b0436555376bef0445f /x11/thingylaunch
parent6feff3da5226d6b8ede5a86c34ffb4ce506346df (diff)
downloadports-264fd13ea4df858b24257835a6d0fc07eb917b97.tar.gz
ports-264fd13ea4df858b24257835a6d0fc07eb917b97.zip
Notes
Diffstat (limited to 'x11/thingylaunch')
-rw-r--r--x11/thingylaunch/Makefile27
-rw-r--r--x11/thingylaunch/distinfo4
-rw-r--r--x11/thingylaunch/pkg-descr2
3 files changed, 25 insertions, 8 deletions
diff --git a/x11/thingylaunch/Makefile b/x11/thingylaunch/Makefile
index 2a40df4ec4f9..140fc9892af0 100644
--- a/x11/thingylaunch/Makefile
+++ b/x11/thingylaunch/Makefile
@@ -2,26 +2,43 @@
# $FreeBSD$
PORTNAME= thingylaunch
-PORTVERSION= 1.2.2
+PORTVERSION= 2.0.1
CATEGORIES= x11
MASTER_SITES= http://gahr.ch/thingylaunch/
MAINTAINER= gahr@FreeBSD.org
-COMMENT= Lightweight tab-completing launcher for X
+COMMENT= Lightweight launcher for X
LICENSE= MIT BSD2CLAUSE
LICENSE_COMB= multi
-USE_XORG= x11 xproto
+OPTIONS_SINGLE= X11
+OPTIONS_SINGLE_X11= LIBX11 LIBXCB
+LIBX11_DESC= Build against libX11
+LIBXCB_DESC= Build against libXCB
+OPTIONS_DEFAULT= LIBX11
+
+USE_XORG= xproto
USE_CXXSTD= c++11
USES= cmake:outsource compiler:c++11-lib
-CXXFLAGS+= -std=c++11
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MLIBX11}
+USE_XORG+= x11
+.endif
+
+.if ${PORT_OPTIONS:MLIBXCB}
+USE_XORG+= xcb
+LIB_DEPENDS+= libxcb-icccm.so:${PORTSDIR}/x11/xcb-util-wm \
+ libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms
+CMAKE_ARGS+= -DUSE_XCB:BOOL=ON
+.endif
USE_GITHUB= yes
GH_ACCOUNT= gahr
GH_TAGNAME= ${PORTVERSION}
-GH_COMMIT= d7367d6
+GH_COMMIT= 6be8728
PLIST_FILES= bin/${PORTNAME}
diff --git a/x11/thingylaunch/distinfo b/x11/thingylaunch/distinfo
index 65f260266ef7..07e328371278 100644
--- a/x11/thingylaunch/distinfo
+++ b/x11/thingylaunch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thingylaunch-1.2.2.tar.gz) = a1f8d4028ade7dc1c10259fa662da633c45639c3c9426155aa7365dfb8116841
-SIZE (thingylaunch-1.2.2.tar.gz) = 8252
+SHA256 (thingylaunch-2.0.1.tar.gz) = 89d2fa8023c24f200ae55a9097d390c20bf4830f5bbcf629cbfac3d3e86a6bb7
+SIZE (thingylaunch-2.0.1.tar.gz) = 11194
diff --git a/x11/thingylaunch/pkg-descr b/x11/thingylaunch/pkg-descr
index 4f2bc8f7f9a1..6726e916ac28 100644
--- a/x11/thingylaunch/pkg-descr
+++ b/x11/thingylaunch/pkg-descr
@@ -1,5 +1,5 @@
Thingylaunch is a lightweight and fast application launcher for X.
Based on the original thinglaunch by Matt Johnston, it is enhanced
-with navigation keys, history and tab-completion.
+with navigation keys, history, bookmarks and tab-completion.
WWW: http://www.gahr.ch/thingylaunch