aboutsummaryrefslogtreecommitdiff
path: root/x11/tint
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-12-15 08:28:04 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-12-15 08:28:04 +0000
commit32bdf3fcec96fc4efde2d7a4ecca95b2cf6220b7 (patch)
treeb6eab12b28ba59111e18afa307004cec30d5477b /x11/tint
parentb11ec6a474c1f141d28d3529a314205a05c1c376 (diff)
downloadports-32bdf3fcec96fc4efde2d7a4ecca95b2cf6220b7.tar.gz
ports-32bdf3fcec96fc4efde2d7a4ecca95b2cf6220b7.zip
Notes
Diffstat (limited to 'x11/tint')
-rw-r--r--x11/tint/Makefile64
-rw-r--r--x11/tint/distinfo5
-rw-r--r--x11/tint/pkg-descr2
3 files changed, 39 insertions, 32 deletions
diff --git a/x11/tint/Makefile b/x11/tint/Makefile
index 496af528d6a6..c43939e39d9d 100644
--- a/x11/tint/Makefile
+++ b/x11/tint/Makefile
@@ -6,72 +6,82 @@
#
PORTNAME= tint2
-PORTVERSION= 0.9
+PORTVERSION= 0.11
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= dougb@FreeBSD.org
COMMENT= Lightweight freedesktop-compliant panel/taskbar/systray/clock
-LICENSE= GPLv2
-
MAKE_JOBS_SAFE= yes
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
PROJECTHOST= tint2
+USE_BZIP2= yes
+USE_CMAKE= yes
USE_GNOME= pango glib20
USE_XORG= xinerama xrandr xdamage xcomposite
USE_EFL= imlib2
-USE_GMAKE= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-battery --disable-tint2conf
+CMAKE_ARGS= -DENABLE_BATTERY:BOOL=OFF -DMANDIR:PATH=man
PLIST_FILES= bin/tint2 \
- etc/xdg/tint2/tint2rc \
share/tint2/default_icon.png
-PLIST_DIRS= etc/xdg/tint2 \
- share/tint2
+PLIST_DIRS= share/tint2
+
+OPTIONS= PYCONF "Configuration editing tool (req. python)" on
MAN1= tint2.1
-PORTDOCS= AUTHORS ChangeLog README NEWS
+PORTDOCS= AUTHORS ChangeLog README
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not link
+.if defined(WITH_PYCONF)
+USE_PYTHON= yes
+CMAKE_ARGS+= -DENABLE_TINT2CONF:BOOL=ON
+PLIST_FILES+= bin/tint2conf bin/tintwizard.py \
+ share/applications/tint2conf.desktop \
+ share/pixmaps/tint2conf.png share/pixmaps/tint2conf.svg
+PLIST_DIRS+= share/applications
+PYCONF_SRC= ${WRKSRC}/src/tint2conf
+.else
+CMAKE_ARGS+= -DENABLE_TINT2CONF:BOOL=OFF
.endif
+.if defined(WITH_PYCONF)
post-patch:
- @${CP} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.presed
- @${SED} -e "s# install-dist_docDATA##" \
- ${WRKSRC}/Makefile.in.presed > ${WRKSRC}/Makefile.in
- @${CP} ${WRKSRC}/src/tint.c ${WRKSRC}/src/tint.c.presed
- @${SED} -e "s#SIGCLD#SIGCHLD#g" ${WRKSRC}/src/tint.c.presed > \
- ${WRKSRC}/src/tint.c
-
-pre-install:
- @${ECHO} "rmdir ${X11BASE}/etc/xdg 2>/dev/null || true" > \
- ${WRKDIR}/pkg-deinstall
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+ @${MV} ${PYCONF_SRC}/tintwizard.py ${PYCONF_SRC}/tintwizard.py.Dist
+ @${SED} -e 's#pidof#pgrep#g' ${PYCONF_SRC}/tintwizard.py.Dist \
+ > ${PYCONF_SRC}/tintwizard.py
+.endif
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tint2 ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/tint2
+ ${INSTALL_DATA} ${WRKSRC}/default_icon.png ${PREFIX}/share/tint2
+ ${INSTALL_MAN} ${WRKSRC}/doc/tint2.1 ${MANPREFIX}/man/man1
+.if defined(WITH_PYCONF)
+ ${INSTALL_PROGRAM} ${PYCONF_SRC}/tint2conf ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${PYCONF_SRC}/tintwizard.py ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.desktop ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${PYCONF_SRC}/tint2conf.svg ${PREFIX}/share/pixmaps
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
@for file in ${RCS}; do \
${INSTALL_DATA} ${WRKSRC}/sample/$${file} ${EXAMPLESDIR}; \
done
-RCS= black_single_desktop.tint2rc default.tint2rc horizontal_icon_only.tint2rc rounded_multi_desktop.tint2rc tint2rc vertical_icon_only.tint2rc white_single_desktop.tint2rc
+RCS= icon_and_text_1.tint2rc icon_and_text_2.tint2rc icon_and_text_3.tint2rc icon_and_text_4.tint2rc icon_only_1.tint2rc icon_only_2.tint2rc icon_only_3.tint2rc icon_only_4.tint2rc icon_only_6.tint2rc icon_only_7.tint2rc text_only_1.tint2rc text_only_2.tint2rc text_only_3.tint2rc text_only_4.tint2rc text_only_5.tint2rc text_only_6.tint2rc tint2rc
.for file in ${RCS}
PLIST_FILES+= ${EXAMPLESDIR_REL}/${file}
.endfor
diff --git a/x11/tint/distinfo b/x11/tint/distinfo
index ee49120cf54e..8b0dac0b8420 100644
--- a/x11/tint/distinfo
+++ b/x11/tint/distinfo
@@ -1,3 +1,2 @@
-MD5 (tint2-0.9.tar.gz) = 411de6ccb8b82089852d8c854b12ddb9
-SHA256 (tint2-0.9.tar.gz) = 5f8b14969c7bd7758f6361faae279e1d0659c9be347a12a072f8cf93854f4703
-SIZE (tint2-0.9.tar.gz) = 206491
+SHA256 (tint2-0.11.tar.bz2) = fe106e6a6057d2631abddde9f82d3fd4fb1985c4fb93f10d3886417a9e22471d
+SIZE (tint2-0.11.tar.bz2) = 91716
diff --git a/x11/tint/pkg-descr b/x11/tint/pkg-descr
index c0505cb49c77..ab84b189cda3 100644
--- a/x11/tint/pkg-descr
+++ b/x11/tint/pkg-descr
@@ -13,8 +13,6 @@ Tint panel features
* clock with font, color and transparency
* multi-monitor : panel position adjust to monitor, taskbar by monitor
-LICENSE: GPL2 or later
-
WWW: http://code.google.com/p/tint2/
- Doug Barton