aboutsummaryrefslogtreecommitdiff
path: root/x11/tycoon/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-10-09 01:41:07 +0000
committerPatrick Li <pat@FreeBSD.org>2002-10-09 01:41:07 +0000
commit37b0e0142ccbe639d6191aad0184a671b35899e5 (patch)
treed0b342bf85e775f7e528d82ab89c92a64572ac9e /x11/tycoon/Makefile
parent18efa9504df1799294bb89757a725258b6977cdd (diff)
downloadports-37b0e0142ccbe639d6191aad0184a671b35899e5.tar.gz
ports-37b0e0142ccbe639d6191aad0184a671b35899e5.zip
Notes
Diffstat (limited to 'x11/tycoon/Makefile')
-rw-r--r--x11/tycoon/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11/tycoon/Makefile b/x11/tycoon/Makefile
index c52317ef860a..ae09dda9c673 100644
--- a/x11/tycoon/Makefile
+++ b/x11/tycoon/Makefile
@@ -13,15 +13,18 @@ MASTER_SITE_SUBDIR= X11/desktop
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= xforms:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
-USE_REINPLACE= yes
USE_IMAKE= yes
USE_XPM= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
-post-build:
- ${RM} -f ${WRKSRC}/xbackdrop/backdrops/index~ ;\
+post-patch:
+ ${RM} -f ${WRKSRC}/xbackdrop/backdrops/index~
${REINPLACE_CMD} -e 's,/usr/lib,${PREFIX}/lib,' \
${WRKSRC}/xbackdrop/backdrops/index
+ ${FIND} ${WRKSRC} -name '*.c' -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ 's,FL_REVISION>=80,FL_REVISION >= 80 || FL_VERSION != 0,g'
.include <bsd.port.mk>