aboutsummaryrefslogtreecommitdiff
path: root/x11/wdm
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-04-05 07:59:21 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-04-05 07:59:21 +0000
commitc83e0a16d6d0ad755d5a71295e545d35bc7ca1ca (patch)
tree79770c56448e59fa53aa747a2ec2aeace59663e2 /x11/wdm
parent94d8c477532b00aac2cf8033b55e0e92bde49b63 (diff)
downloadports-c83e0a16d6d0ad755d5a71295e545d35bc7ca1ca.tar.gz
ports-c83e0a16d6d0ad755d5a71295e545d35bc7ca1ca.zip
- Update to 1.28.
PR: ports/79486 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=132530
Diffstat (limited to 'x11/wdm')
-rw-r--r--x11/wdm/Makefile6
-rw-r--r--x11/wdm/distinfo4
-rw-r--r--x11/wdm/files/patch-src::wdm::session.c57
-rw-r--r--x11/wdm/pkg-plist8
4 files changed, 53 insertions, 22 deletions
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
index a6a1d540658d..64f53904a150 100644
--- a/x11/wdm/Makefile
+++ b/x11/wdm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wdm
-PORTVERSION= 1.27
+PORTVERSION= 1.28
CATEGORIES= x11 windowmaker
MASTER_SITES= http://voins.program.ru/wdm/ \
http://www.de.freebsd.org/de/gif/bsd/ \
@@ -28,7 +28,7 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
DEF_SERVER="${DEF_SERVER}"
CONFIGURE_ARGS= --with-logdir=/var/log \
--with-runlockdir=/var/run \
@@ -45,7 +45,7 @@ CONFIGURE_ARGS= --with-logdir=/var/log \
MAN1= wdm.1 wdmLogin.1
CPPFLAGS= -I${LOCALBASE}/include -DCSRG_BASED -DHAS_SETUSERCONTEXT
-LDFLAGS= -L${LOCALBASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib -lintl
DEF_SERVER?= ${X11BASE}/bin/X
diff --git a/x11/wdm/distinfo b/x11/wdm/distinfo
index 0e0b7095e115..4c93fff14e63 100644
--- a/x11/wdm/distinfo
+++ b/x11/wdm/distinfo
@@ -1,5 +1,5 @@
-MD5 (wdm/wdm-1.27.tar.bz2) = df2eeb24a4e56c075aae26a6d7b707a8
-SIZE (wdm/wdm-1.27.tar.bz2) = 379253
+MD5 (wdm/wdm-1.28.tar.bz2) = 4da8ffe3af233305786d9b6aab78b838
+SIZE (wdm/wdm-1.28.tar.bz2) = 381522
MD5 (wdm/beastie.xpm) = 0891d7d8ac81514f10aafeb8f8a89ca2
SIZE (wdm/beastie.xpm) = 66929
MD5 (wdm/daemon1-HQ-1280x960.jpg) = b38f175cf6b7167484afac423837ed1a
diff --git a/x11/wdm/files/patch-src::wdm::session.c b/x11/wdm/files/patch-src::wdm::session.c
index 884b5e7d664b..035205602185 100644
--- a/x11/wdm/files/patch-src::wdm::session.c
+++ b/x11/wdm/files/patch-src::wdm::session.c
@@ -1,6 +1,6 @@
---- src/wdm/session.c.orig Fri Jun 6 23:48:46 2003
-+++ src/wdm/session.c Tue Jul 22 20:32:23 2003
-@@ -534,6 +534,7 @@
+--- src/wdm/session.c.orig Sat Mar 26 22:57:04 2005
++++ src/wdm/session.c Sun Mar 27 09:22:42 2005
+@@ -533,6 +533,7 @@
int pid;
#ifdef HAS_SETUSERCONTEXT
struct passwd* pwd;
@@ -8,20 +8,43 @@
#endif
#ifdef USE_PAM
pam_handle_t *pamh = thepamh();
-@@ -613,6 +614,8 @@
- * Set the user's credentials: uid, gid, groups,
- * environment variables, resource limits, and umask.
- */
+@@ -562,6 +563,7 @@
+ /* Do system-dependent login setup here */
+
+ #ifndef AIXV3
++#ifndef HAS_SETUSERCONTEXT
+ if (setgid(verify->gid) < 0)
+ {
+ WDMError("setgid %d (user \"%s\") failed, errno=%d\n",
+@@ -609,6 +611,31 @@
+ verify->uid, name, errno);
+ return (0);
+ }
++#else /* HAS_SETUSERCONTEXT */
++ /*
++ * Set the user's credentials: uid, gid, groups,
++ * environment variables, resource limits, and umask.
++ */
+ /* destroy user environment before calling setusercontext */
+ environ = verify->userEnviron;
- pwd = getpwnam(name);
- if (pwd)
- {
-@@ -622,6 +625,7 @@
- errno);
- return (0);
- }
++ pwd = getpwnam(name);
++ if (pwd)
++ {
++ if (setusercontext(NULL, pwd, pwd->pw_uid, LOGIN_SETALL) < 0)
++ {
++ WDMError("setusercontext for \"%s\" failed, errno=%d\n", name,
++ errno);
++ return (0);
++ }
+ verify->userEnviron = environ;
- endpwent();
- }
- else
++ endpwent();
++ }
++ else
++ {
++ WDMError("getpwnam for \"%s\" failed, errno=%d\n", name, errno);
++ return (0);
++ }
++#endif /* HAS_SETUSERCONTEXT */
+ #else /* AIXV3 */
+ /*
+ * Set the user's credentials: uid, gid, groups,
diff --git a/x11/wdm/pkg-plist b/x11/wdm/pkg-plist
index 04378fb301fb..bbdd4b0668a7 100644
--- a/x11/wdm/pkg-plist
+++ b/x11/wdm/pkg-plist
@@ -29,6 +29,14 @@ lib/X11/wdm/wdm-config.dist
@exec [ -f %D/lib/X11/wdm/wdm-config ] || (cp %D/lib/X11/wdm/wdm-config.dist %D/lib/X11/wdm/wdm-config)
lib/X11/wdm/wdm-config.in
lib/X11/wdm/wdmReconfig
+share/locale/cs/LC_MESSAGES/wdm.mo
+share/locale/cy/LC_MESSAGES/wdm.mo
+share/locale/de/LC_MESSAGES/wdm.mo
+share/locale/en/LC_MESSAGES/wdm.mo
+share/locale/es/LC_MESSAGES/wdm.mo
+share/locale/fr_FR/LC_MESSAGES/wdm.mo
+share/locale/ja/LC_MESSAGES/wdm.mo
+share/locale/ru/LC_MESSAGES/wdm.mo
@unexec rmdir %D/lib/X11/wdm/pixmaps 2>/dev/null || true
@exec mkdir -p %D/lib/X11/wdm/authdir
@unexec rmdir %D/lib/X11/wdm/authdir/authfiles 2>/dev/null || true