aboutsummaryrefslogtreecommitdiff
path: root/x11/wmbutton
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-09-09 18:31:27 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-09-09 18:31:27 +0000
commit975f5a1beb41195fe0ca3208ee7cf5ac09aa84b4 (patch)
tree303109471a7db90a36301705cdffe6fa1685cebb /x11/wmbutton
parenta574054750b0a85efa4bbbd84da03bad35e406d5 (diff)
downloadports-975f5a1beb41195fe0ca3208ee7cf5ac09aa84b4.tar.gz
ports-975f5a1beb41195fe0ca3208ee7cf5ac09aa84b4.zip
Update to 0.6.1
PR: ports/85882 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=142309
Diffstat (limited to 'x11/wmbutton')
-rw-r--r--x11/wmbutton/Makefile32
-rw-r--r--x11/wmbutton/distinfo4
-rw-r--r--x11/wmbutton/files/patch-aa22
-rw-r--r--x11/wmbutton/files/pkg-message.in4
-rw-r--r--x11/wmbutton/pkg-descr2
-rw-r--r--x11/wmbutton/pkg-plist8
6 files changed, 27 insertions, 45 deletions
diff --git a/x11/wmbutton/Makefile b/x11/wmbutton/Makefile
index e2592d728b97..7c2674a602a5 100644
--- a/x11/wmbutton/Makefile
+++ b/x11/wmbutton/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= wmbutton
-PORTVERSION= 0.4
+PORTVERSION= 0.6.1
CATEGORIES= x11 windowmaker
-MASTER_SITES= http://www.cs.mun.ca/~gstarkes/wmaker/dockapps/files/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= jim
+MASTER_SITES= http://greek0.net/~greek0/wmbutton/
MAINTAINER= ports@FreeBSD.org
COMMENT= A dockapp that displays 9 buttons to run apps of your choice
@@ -18,20 +16,22 @@ COMMENT= A dockapp that displays 9 buttons to run apps of your choice
USE_X_PREFIX= yes
USE_XPM= yes
+SUB_FILES= pkg-message
+
do-build:
- @(cd ${WRKSRC} && make)
+ cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} \
+ -I${X11BASE}/include/X11 -I${X11BASE}/include \
+ wmb_libs.c wmbutton.c -o wmbutton \
+ -L${X11BASE}/lib -lXpm -lXext -lX11
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/wmbutton ${PREFIX}/bin
-
-post-install:
- @${ECHO} "===> Installing .wmbutton as ${PREFIX}/share/examples/wmbutton/wmbutton"
- @${ECHO} "===> Modify if you wish and copy to ~/.wmbutton"
- @${MKDIR} ${PREFIX}/share/examples/wmbutton && ${CHMOD} a+rx ${PREFIX}/share/examples/wmbutton
- @${INSTALL_DATA} ${WRKSRC}/.wmbutton ${PREFIX}/share/examples/wmbutton/wmbutton
- @${ECHO} "===> Installing README in ${PREFIX}/share/doc/wmbutton"
- @${ECHO} "===> Please read it for usage instructions"
- @${MKDIR} ${PREFIX}/share/doc/wmbutton && ${CHMOD} a+rx ${PREFIX}/share/doc/wmbutton
- @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/wmbutton
+ ${INSTALL_PROGRAM} ${WRKSRC}/wmbutton ${PREFIX}/bin/wmbutton
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/.wmbutton ${EXAMPLESDIR}/dot.wmbutton
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/x11/wmbutton/distinfo b/x11/wmbutton/distinfo
index 2e589815aac8..dc48ba6204c3 100644
--- a/x11/wmbutton/distinfo
+++ b/x11/wmbutton/distinfo
@@ -1,2 +1,2 @@
-MD5 (wmbutton-0.4.tar.gz) = 77b24ab49acfb667116d518d4bb99990
-SIZE (wmbutton-0.4.tar.gz) = 30351
+MD5 (wmbutton-0.6.1.tar.gz) = b4e8d35709252306739ccc1a2a826c08
+SIZE (wmbutton-0.6.1.tar.gz) = 48404
diff --git a/x11/wmbutton/files/patch-aa b/x11/wmbutton/files/patch-aa
deleted file mode 100644
index 9d5886bf304f..000000000000
--- a/x11/wmbutton/files/patch-aa
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.orig Sat Apr 10 16:49:04 1999
-+++ Makefile Sat Apr 10 16:51:43 1999
-@@ -1,15 +1,15 @@
--INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11
--LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
-+INCLUDES =-I${X11BASE}/include/X11 -I${LOCALBASE}/include -I/${X11BASE}/include
-+LIBINC =-L${X11BASE}/lib -L${LOCALBASE}/lib
- LIBS = -lX11 -lXpm -lXext
-
- TARGET = wmbutton
- OBJECTS = wmbutton.o readln.o
-
- .c.o:
-- gcc -O2 -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
-+ ${CC} ${CFLAGS} -c -Wall ${INCLUDES} ${CFLAGS} $< -o $*.o
-
- ${TARGET}: ${OBJECTS}
-- gcc -O2 -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
-+ ${CC} ${CFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
-
- clean::
- for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done
diff --git a/x11/wmbutton/files/pkg-message.in b/x11/wmbutton/files/pkg-message.in
new file mode 100644
index 000000000000..12b281e9c352
--- /dev/null
+++ b/x11/wmbutton/files/pkg-message.in
@@ -0,0 +1,4 @@
+*******************************************************************************
+Installing .wmbutton as %%PREFIX%%/share/examples/wmbutton/dot.wmbutton
+Modify if you wish and copy to ~/.wmbutton
+*******************************************************************************
diff --git a/x11/wmbutton/pkg-descr b/x11/wmbutton/pkg-descr
index 5eeba707ec7d..16f985ebe3ee 100644
--- a/x11/wmbutton/pkg-descr
+++ b/x11/wmbutton/pkg-descr
@@ -4,6 +4,6 @@ run just about any application you'd like to. Basically, if you can
type it in a shell command, wmbutton can run it. It is based on wmcp,
by Ben Cohen.
-WWW: http://www.cs.mun.ca/~gstarkes/wmaker/dockapps/other.html#wmbutton
+WWW: http://greek0.net/~greek0/wmbutton/
- Jim <jim@FreeBSD.org>
diff --git a/x11/wmbutton/pkg-plist b/x11/wmbutton/pkg-plist
index 559a5bfe00eb..4d1831854c52 100644
--- a/x11/wmbutton/pkg-plist
+++ b/x11/wmbutton/pkg-plist
@@ -1,5 +1,5 @@
bin/wmbutton
-share/examples/wmbutton/wmbutton
-share/doc/wmbutton/README
-@dirrm share/examples/wmbutton
-@dirrm share/doc/wmbutton
+%%EXAMPLESDIR%%/dot.wmbutton
+%%PORTDOCS%%%%DOCSDIR%%/README
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%