aboutsummaryrefslogtreecommitdiff
path: root/x11/wmcliphist
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /x11/wmcliphist
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
Notes
Diffstat (limited to 'x11/wmcliphist')
-rw-r--r--x11/wmcliphist/Makefile2
-rw-r--r--x11/wmcliphist/files/patch-Makefile19
2 files changed, 16 insertions, 5 deletions
diff --git a/x11/wmcliphist/Makefile b/x11/wmcliphist/Makefile
index d7970d3319a3..4fe05c18dabd 100644
--- a/x11/wmcliphist/Makefile
+++ b/x11/wmcliphist/Makefile
@@ -15,8 +15,8 @@ COMMENT= Clipboard history management dockapp for Window Maker
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= pkgconfig
-USE_XORG= xpm
USE_GNOME= gtk20
+USE_XORG= x11
OPTIONS_DEFINE= DOCS
diff --git a/x11/wmcliphist/files/patch-Makefile b/x11/wmcliphist/files/patch-Makefile
index 3b297e3c13de..319e5225db69 100644
--- a/x11/wmcliphist/files/patch-Makefile
+++ b/x11/wmcliphist/files/patch-Makefile
@@ -1,7 +1,10 @@
--- Makefile.orig
+++ Makefile
-@@ -3,7 +3,7 @@
- INCLUDES = `pkg-config --cflags gtk+-2.0` -I. -Ifoodock
+@@ -1,9 +1,9 @@
+ CC ?= gcc
+ PREFIX = /usr/local
+-INCLUDES = `pkg-config --cflags gtk+-2.0` -I. -Ifoodock
++INCLUDES = `pkg-config --cflags gtk+-2.0 x11` -I. -Ifoodock
# for normal use
-CFLAGS += -Wall -ansi -pedantic $(INCLUDES)
@@ -9,8 +12,16 @@
DEBUG =
# for debuggind purposes
-@@ -22,8 +22,8 @@
- lclint:
+@@ -12,7 +12,7 @@ DEBUG =
+ #CFLAGS += -Wall -g -ansi $(INCLUDES) -DFNCALL_DEBUG
+ #DEBUG = debug.o
+
+-LIBS = `pkg-config --libs gtk+-2.0`
++LIBS = `pkg-config --libs gtk+-2.0 x11`
+
+ OBJECTS = wmcliphist.o clipboard.o gui.o rcconfig.o history.o hotkeys.o utils.o $(DEBUG)
+ TARGET = wmcliphist
+@@ -23,7 +23,7 @@ lclint:
lclint $(INCLUDES) +posixlib *.c >lclint.log
wmcliphist: $(OBJECTS) foodock/foodock.o