aboutsummaryrefslogtreecommitdiff
path: root/x11/wmdrawer
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-08 15:49:56 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-08 15:49:56 +0000
commitfd3d892d40c13ef4617f0909c5bd4ab1f6bf182e (patch)
tree8e4ba67dcd5c689545f78088f5e54883f82d2a6e /x11/wmdrawer
parent306f5bfd4bb1832a7a8b36601b37f7860d51a994 (diff)
downloadports-fd3d892d40c13ef4617f0909c5bd4ab1f6bf182e.tar.gz
ports-fd3d892d40c13ef4617f0909c5bd4ab1f6bf182e.zip
Notes
Diffstat (limited to 'x11/wmdrawer')
-rw-r--r--x11/wmdrawer/Makefile19
-rw-r--r--x11/wmdrawer/distinfo1
-rw-r--r--x11/wmdrawer/files/patch-wmdrawerrc.example21
3 files changed, 38 insertions, 3 deletions
diff --git a/x11/wmdrawer/Makefile b/x11/wmdrawer/Makefile
index 7896e3e6ecc2..05c48468797d 100644
--- a/x11/wmdrawer/Makefile
+++ b/x11/wmdrawer/Makefile
@@ -8,15 +8,21 @@
PORTNAME= wmdrawer
PORTVERSION= 0.9.17.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 windowmaker
-MASTER_SITES= http://people.easter-eggs.org/~valos/wmdrawer/
+MASTER_SITES= http://people.easter-eggs.org/~valos/wmdrawer/:tarball \
+ http://www.daemon.li/downloads/:pixmap
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+DISTFILES= ${EXTRACT_ONLY}:tarball \
+ daemon.xpm:pixmap
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= j.el-rayes@daemon.li
COMMENT= A dockapp which provides a drawer to launch applications
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
USE_GMAKE= yes
@@ -26,4 +32,11 @@ MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt" DOCSDIR=${DOCSDIR}
MANCOMPRESSED= yes
MAN1= wmdrawer.1x
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR},g" ${WRKSRC}/wmdrawerrc.example
+
+post-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/daemon.xpm ${DATADIR}
+
.include <bsd.port.mk>
diff --git a/x11/wmdrawer/distinfo b/x11/wmdrawer/distinfo
index 1c081b33812e..f469f99fab4b 100644
--- a/x11/wmdrawer/distinfo
+++ b/x11/wmdrawer/distinfo
@@ -1 +1,2 @@
MD5 (wmdrawer-0.9.17.1.tar.gz) = bb7cfd5a8d5e6d6ab0920536e17e36d6
+MD5 (daemon.xpm) = 73f0efeba877d8c4b4cc863f1ef87bd5
diff --git a/x11/wmdrawer/files/patch-wmdrawerrc.example b/x11/wmdrawer/files/patch-wmdrawerrc.example
new file mode 100644
index 000000000000..fa0e46f0f913
--- /dev/null
+++ b/x11/wmdrawer/files/patch-wmdrawerrc.example
@@ -0,0 +1,21 @@
+--- wmdrawerrc.example.orig Tue Apr 8 23:36:16 2003
++++ wmdrawerrc.example Tue Apr 8 23:44:28 2003
+@@ -1,7 +1,7 @@
+ # Config file example for wmdrawer
+ [general]
+ # Dock's icon [optional]
+-#dock_icon panel-drawer.png
++dock_icon daemon.xpm
+
+ # Drawer's opening direction [required]
+ # Top to bottom = 0
+@@ -67,8 +67,7 @@
+
+ # Images directories
+ [images_paths]
+-/usr/share/pixmaps
+-/usr/local/share/pixmaps/
++%%DATADIR%%
+
+ # A first column with 5 buttons
+ # Each button must be defined with this syntax: